Insufficient space, at least that's what the phone says

Thanks Lidwien, but I don’t have the First edition, but the Second Batch.
I made the update to Cherry when I received it in august, and it’s looks good.
But I don’t know how to manually verify if the storage is efficiently unified or not…
If you have a clue…

Go to the apps,
tap on 'File manager’
Now you should see an internal storage of with a total space of around 13.7 GB
How much GB is available on your internal storage?

Your SD card should read a total space of around 29GB

Yes I have the same informations. So do I have an unified storage ?
When I’m installaing an app, where does it go ? On the 1Go hidden partition ? on the 13Go partition ?
How can I choose where to stock them ?

If you read in the ‘File manager’ the same as me, then you have one unified storage.
There is on your Fairphone no hidden partion of 1GB and a second 13GB partition.
It’s one unified partion of 13.7GB

Yes, you can choose where to stock an app.
Go to 'System settings’
Under the sub ‘DEVICE’ tap on "Storage"
Under the sub ‘DEFAULT WRITE DISK’ you can choose either the Internal Storage of your SD card.

Thanks for the precision about the non-existency of the 1Go partition :slight_smile:
But I’m confused because despite this unified storage and all the right settings you described, I still have this error message when trying to install more Apps : “insufficient space”

What’s wrong ?

Please go again to the ‘Filemanager’ and tell me how much is available on your Internal storage.

Well, you hardly used the Internal storage.

Could you go Go to 'System settings’
Under the sub ‘DEVICE’ tap on "Storage"
Under the sub ‘DEFAULT WRITE DISK’, where do you stock an app.
Is it on the ‘Internal Storage’ or is it on the SD card.

Now, it’s set to SD Card.
But I also tried “Internal storage” and nothing change when I’m trying to install app : always the message “insufficient space”

Set the default write disk to the Internal storage.
Switch off you phone and on.
Check if the default write disk is still the Internal storage.
Try to install the app again.
BTW, what is the app you have problems with?

After a reboot, the “internal storage” is always set :slight_smile:
It’s strange… I have problem only with some apps such as YahooMeteo, Sholi, Twitter (for now)…
Other are installed on internal storage (the space left is changing)

There seem to be an issue with installing some apps.
In the thread about Blendle you can read more about this.

1 Like

Hummm it’s looking a good way :slight_smile:
I will read this. Thanks :slight_smile:

I had the same kind of problem and now it seems solved!

I think it depended from a kind of conflict between a old version of the play store app and the FP operating system.

simply try to re-install the play store (and all the other google apps) via the Google Apps installer (it is present in your widget list)

(just for info. I have a FP 1st edition updated to cherry 1.6 but I did not (still) merged the 2 partitions)

hope it will work

I also have this problem too. I have no SD card. Whenever I try and download an app it also says insufficient room. I have to go to storage and delete cache and that usually does it. Under Default Write Disk there is a blue dot next to the words Phone Storage. It will not let me uncheck it. Preferred install location is set to Internal device storage.

I had this exact same problem a while back. I finally found a soluti, which did the job for me. You will need a root file manager like the one included in TOM toolbox ( When you open the root browser you need to go to data–>app-lib and erase whichever app you can’t update or install. Afterwards go to the play store and download it.

I hope that helped.

Maybe a good tip SirLukeSchande :slight_smile:
In my case, I solved the problem… by installing Cyanogenmod :slight_smile:

I’ve tried all the things you say, but my phone on google plays keeps saying ’ insufficient storage error’ , even if hough I still have like 249 MB left. I’ve got a android smart 4 turbo - how do I solve this?

@Amalka_Slavikova, do you have a Fairphone?
Because everything writen on this forum is for users with a Fairphone.


Like @Lidwien says this is a Forum about the Fairphone. Also this topic is quite outdated.
If you do have a Fairphone and have this issue following two topics are more up to date atm:
Insufficient storage error even after partition upgrade for FP1
Memory is full

This topic is now closed. New replies are no longer allowed.

1 Like