Insufficient storage error even after partition upgrade for FP1

For my fairphone first edition it was indeed, as mentioned above, so that only 1 Gb of internal memory was available for apps. After deleting enough (in total 50 Mb) apps everithing works fine again. I was told that the system keeps a minimum of 100 Mb free, so if less is left no apps will be installed. Thanks everybody for helping me out.

In my case, it is.

Could you explain in a little more detail what steps you took, and what happens when you try to install the mentioned apps? I hope we can help you out, since my problems seem to be gone, and according to this thread, I’m not the only one who succeeded.

In a nutshell, what helped in my case was wiping everything and restoring non-system apps including their data one by one through TitaniumBackup. I also tried, in one case, re-installing an app from the PlayStore and restoring “data only” via TitaniumBackup. Worked as well, got a lot of content in there which would otherwise be gone.

The main reason behind insufficient storage is due to cache. You can view this page for resolving insufficient storage problem of android.

I tried to clear the situation with a little bit too enthusiastically playing the storage upgrade. Other than I thought initially, my last effective backup was from September, thus I lost some apps which I had installed in the meantime. The weird thing is that some apps can be installed through the Playstore (or amazon or f-droid doesnt make a difference) and others don’t, irregardless of whether they are 500kb or 25MB in size. Same applies for updates…I was able to update around 50% of my apps, others remain unupdated (some deliberatedly like FB, admittedly) because of insufficient storage space. But being not able to install new apps does affect me in the long run. True, I could try again deinstall everything and format the whole device, but I am not eager to do so again until I know this will help this time.

You could try clearing the cache on one of the apps that is causing you this issue and see if it will then work updating. Otherwise try installing the app and then reinstalling from whichever app store you are wanting to use - it should then try to install the uptodate version.

Clearing cache does not work. Same for deinstall/reinstall, independent from the app store in use, it only effects that I cannot install the respective app at all. Now I lost Youtube app for example, luckily I didnt trz it with Whatsapp. However, Whatsapp is running out (30 days to update)…thus I am in the need to resolve this problem sooner or later.


My storage problems are gone since I have updated to FP OS 1.8.
In the moment its beta (release candidate), but very stable.
You can download it from

Best regards

Thanks @Bobby

For anyone that reads Bobby’s comment, I would add the extra disclaimer that there are a few bugs in this release that are being worked on still and you may loose your homescreen setup as part of the install so if you’re thinking “Oh good, upgrade time” you’ve been warned :wink:

After endless hours spent in the forum, I’ve finally found a solution that works (for me, at any rate). Like so many others, it seems, some of my apps wouldn’t update any more, others couldn’t be installed in the first place, Android claiming there was insufficient storage. However, there were GB of free storage.
As suggested in Storage update: No possibility to move apps, I installed the Link2SD app and, in settings, changed the “installation path” (“Installationsort” - I’m using the German version) to “internal storage” (might as well work with “external storage”, though!). And… Bob’s your uncle!

Thank you, FFFan!

After the unified storage update I had the same issue: I could update some apps - and some not. I even tried a (second) factory reset.

Your solution finally helped.

Edit: I suppose that the source of the problem is a setting while using the old OS version 1.6 (with no unified storage). I had the setting to save new apps to the bigger “Phone Storage” and not to the small “Internal Storage”. This setting was probably kept even during upgrades to unified storage and to OS version 1.8 while the “Phone Storage” no longer exists.

It’s really important while using Titanium Backup to opt-in the setting “migrate systemdata” (German: Systemdaten migrieren) in the settings -> restore (deutsch: Wiederherstellungen) before using the backups.

After using this after my first try I had no problems with two FP after storage upgrader.


We should probably pin that solution then. @FFFan, would you be willing to describe what you did in a little more detail, but as simple as possible in a “Reply as new topic” thread, which could be wikified by the community mods then? We could collect some solutions, since I have the feeling that there will be people with the same problem every now and then, still.

I’ll try my best - even though there isn’t much to add, really.

  1. Install the Link2SD app at
  2. Run Link2SD, allowing the ‘Superuser Request’ (just once, or for 10 minutes).
  3. Go to settings (the three little dots in the upper right corner) and choose ‘settings’.
  4. Under section ‘Native App2SD Settings’, choose ‘install location’ > ‘Internal’. I haven’t tried ‘External’, but if this setting means apps will be moved/stored to your external SD card, it could be worth a try…

And that’s all there is to it. Now, it is even safe to uninstall the app - otherwise you might be faced with the occasional ‘Superuser Request’ by Link2SD out of the blue. Even after uninstall, the memory bug will be gone for good.


Any ideas on what to do if you can’t install anything new (insufficient memory message) even if you uninstall some large apps? Am on 1.8 with the original 2 partitions (was waiting for the next is update to fix my woes before this problem came along)!

Hello all,

I still have this problem, and after making a backup of my data I find that I can not tap on the ‘Fairphone OS’ button: it simply doesn’t do anything. How can I install the unified storage upgrade?
I’m going nuts from the ‘insufficient storage’ messages while I have a 16gb microSD inserted thats not even half full.

I have the FP 1, running on cherry 1.6 already.



Never mind,

Found out how to solve this!

Somehow the updated got borked. Excellent documentation, problem solved. oh man, finally no more ‘blabla computer says no…’ messages. yes. bliss.


Same problem here :frowning:
I just updated OsmAnd (maps) and now I get the message (in German) not enough space. (30 MB remaining of 1 GB space - where?)
Then I connected the phone to my PC, and have 6 GB and 33 GB free space on internal and SD-card.
I thought it has to do with the “Arbeitsspeicher” (working storage?), but when I check the apps it’s only a handfull that are active.

I don’t really want to do a hard reset and restore everything again, that seems a lot of work…

FP1, no google play store, Fairphone Kola Nut 1.8.5.

(I am getting a bit frustrated right now after I also started getting the data roaming issues (with Eplus/O2 network - and don’t understand the solutions suggested) - after being very happy with my FP1 for so long. Now I get new problems every week I can’t solve since I am not an IT professional.)

edit: I found a number of pages that talked about “Installing the Storage Upgrade on the FP1 will undo this difference, and you will have more memory space for your own use.” so that seems to be what I am looking for. But then I found no instructions.

( I still don’t understand why the apps are taking up so much space if they are not in use. strange):

gratefull for suggestions, thank you! :penguin:

If I understand correctly, you have an FP1 first edition, and you haven’t applied the partition layout upgrade. If you’re unsure about whether you’ve updated the partition layout, check under Settings > Storage. In the new layout, the total space in internal storage will be a single 13.37 Gb bar with different coloured blocks. In the old layout there will be internal storage (1Gb) and phone storage.
In the old partition layout, there would be a section of 1 Gb reserved to install apps. Even though there may be more free space elsewhere on the device, this can’t always be used to install apps. The new layout works around this by merging different sections of storage.
On the page you linked to, there is another link to the instructions on how to upgrade the partition layout. It’s the link just above the warning. However, the process does perform a hard reset, which you mention you want to avoid.

To work around the problem you can try tips included on this page: How are apps stored on my Fairphone 1 (Internal, Phone, and SD Storage)?. Most useful is removing apps you no longer use. Moving apps to the Phone storage can also help, though not all apps can be moved.

1 Like

For sake of completeness, here is the wiki-Post for this topic, which I edited after having the same problem and luckily could solve it with the solution of @FFFan (Link2SD):