How to fastboot Fairphone 2?

I have just taken delivery of a Fairphone 2 ans wish to install Ubuntu Touch. To do this I need to boot the phone into fastboot (the little google android fellow). I have enabled the developer mode in the settings and switched on OEM, but the stated instructions to hold the on button and volume down to bring up fastboot do not work, no matter how long I hold the buttons down.

If anybody has any advice about this, I would be grateful, thank you!

Check out: #dic:fastboot

First press the volumebutton down and whilst holding it down press the on button. Press both buttons min. 10 seconds.

Thank you for the two replies. I have read #dic:fastboot to no avail.

When I hold down the power button and volume down there is a black screen which has ‘Fairphone’ at the top and ‘Powevered by android’ at the bottom (both in white text). Is this the fastboot screen?

I have installed the android tools on my ubuntu laptop but when I connect the fp2 booted in the I way describe above, I receive:

m@mxxx:~$ adb devices
List of devices attached

[and no devices are listed]

I am perplexed.

Thanks for any further help!


adb and fastboot are not the same

1 Like

Which means it’s clear adb devices does not bring up the FP2, you need to use ‘fastboot‘

Hello !

Its is :slight_smile:

The way to get your phone discovered by your computer under Linux is a bit complicated. What you have to do is :

  1. Open a terminal and go to /etc/udev/rules.d
  2. Create a file named 51-android.rules
  3. In this file, type this (on a single line) : SUBSYSTEM=="usb", ATTR{idVendor}=="2ae5", MODE=="0666" --> this is for ADB
  4. In the same file, go to the next line and type : SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE=="0666" --> this is for fastboot
  5. Reboot your computer

You can get more information there : on fastboot and on ADB. About the rules file : I hope this documentation helps.

As @paulakreuzer said, you need to use the fastbootcommand. Once your computer is rebooted and ready, put your phone in fastboot mode, connect it to your computer, open a terminal and type fastboot devices. If everything worked, your devices should be recognised by your computer and seen. You can get an other guide there :

1 Like

Thank you for the further replies, especially @anon59030904

I have followed your instructions exactly and rebooted, but fp2 in fastboot mode, but fastboot devices reveals nothing. Checked usb cable and it is fine.

It seems that the computer does not want to talk to the fp2.

Many thanks.

So, I think you have to enable developer mode on your Fairphone 2 first. Sorry I forgot this point ! In order to do so :

  1. Go to Settings --> About phone
  2. Tap 10 times on the “Build number” field
  3. Congratulations, you’re a developer !
  4. Return to the settings menu --> Developer options
  5. Enable Android debug
  6. Return to your computer

Then you have to install some Android tools, if not already done. You can open a terminal and type :
sudo aptitude install android-tools-adb.
If Ubuntu says adb is already installed, that’s great. You can plug your phone to your computer, and a message should appear saying that adb is enabled and that you can choose between some options. Unlock your phone, and choose File transfer. This handles MTP and ADB as well.

Then a little pop-up window should appear, asking if you want to trust the connection with your computer. Say yes, it’s you and your computer (normally). Then, if your terminal you type adb devices, it should answer something like 181931 device.

You can put you phone in fastboot mode by typing adb reboot fastboot, or by unpplugging your phone, shutting it down, and rebooting it to the fastboot mode with the power+volume down combination. If this works, (plug your phone and) type fastboot devices. Your phone should be recognised now, and you can install Ubuntu Touch on it.

Thank you @anon59030904 I know this is going to sound crazy but with this new fp2 phone in fastboot and adb and android tools installed, and developer mode enabled and debug mode and oem enabled, ubuntu is still not recognizing the phone…!

Do you have family/ friends/ anybody nearby where you could try it on another computer?
If they run Windows, no problem, it is very easy to quickly setup in Windows and check whether it works with Minimal ADB and Fastboot.

Oh no !! :frowning: I’m sorry, I must have forgotten something… I guess @AnotherElk’s solution is best, or at least ask someone who’s more skilled at this than me (it’s a long time since I do not need anymore to do this, because I just transfer my udev files from backup to another and it just does work the way I said it).

Ok, i just replicated this in Ubuntu. I have no special configuarion.

  1. Turn the phone of, diconnect all cables.
  2. Boot into Fastboot: Hold volume down, then press power, the phone will vibrate and the logo is displayed.
  3. Open the Terminal/Console in Ubuntu
  4. Connect the usb cable
  5. Type fastboot devices, the ouput should look like this:
    $ fastboot devices fc84f6bd fastboot
  6. Continue with the Ubuntu Touch installation.

Some help: The customizations @anon59030904 mentions above are helpful for adb, but not required for fastboot. My fastboot version is 3db08f2c6889-android , installing with the Android SDK,
my Ubuntu version is 17.04.

1 Like

In my case it helps to execute fastboot & the other commands with root rights.
So I usually type in sudo -i first and then execute everything else as root.

1 Like

Thank you @ben @BeMiGro and others for your various helpful replies. Unfortunately nothing seems to work. The curious thing is that I have done this successfully for an android table in the past, from the same laptop. The only other laptop that I also have immediate access to runs Ubuntu (both are 17.04). I will ponder this further, anon.

@aridus Did you do what @anon59030904 said about letting the phone trust the connection to your computer? This is what help me when I had a similar issue.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.