Home-Button&Pull-Down-Menü funktionieren nicht, Entwickleroptionen lassen sich nicht aktivieren

Hallo!
Vor zwei Tagen ist mein Fairphone 2, läuft mit Fairphone Open 19.11.2, wegen leeren Akkus runtergefahren. Nachdem ich es geladen&wieder angemacht hatte trat plötzlich folgendes auf:

  • Von den drei unteren “Tasten” funktioniert nur die ganz linke, die “Zurück-Taste”
  • Bei neuen Nachrichten klingelt das Telefon zwar wie gewohnt, es wird allerdings weder auf dem Startbildschirm noch im Menü eine Benachrichtigung angezeigt, auch keine verpassten Anrufe, Emails etc.
  • Das Pulldown-Menü kann ich nur einmal runterziehen statt, wie sonst, zweimal. Die Bildschirmhelligkeit z.B. kann ich dort nicht mehr verändern, das geht nur noch in den Einstellungen
  • einige Einstellungen waren nach dem ersten Anschalten nach dem Akkuabsturz verändert: z.B. war plötzlich die Vibration bei Berührung des Displays etc. eingeschaltet (vorher aus).
  • außerdem funktioniert die Kamera nicht (dieses Problem bestand allerdings auch vorher schon von Zeit zu Zeit)

Auf der Suche nach einer Lösung bin ich bei diesem Beitrag gelandet: 🇩🇪 Systemfehler: keine Benachrichtigungen, Home-Button, Pull-down Menü
Da hatte jemand das gleiche Problem. Als einzige Lösung wurde dort der factory reset vorgeschlagen. Hatte mich also schon damit abgefunden und wollte eben meine Daten auf den PC ziehen, da trat ein weiteres Problem auf, zu dem ich im Netz noch nicht fündig werden konnte: ich kann das Menü, in dem ich die Einstellung treffen kann, was ich mit der Verbindung machen möchte, nicht öffnen- und wenn ich, wie im o.g. Beitrag versuche, die Entwickleroptionen zu aktivieren, funktioniert dies einfach nicht! Also ich gehe über Einstellungen > Über das Telefon > 10mal Build-Nummer anklicken. Da passiert einfach gar nichts. Habe auch schon weniger/ öfter antippen versucht, aber unter den Entwickleroptionen steht jedes Mal wieder “Entwickleroptionen sind für diesen Nutzer nicht verfügbar”.
Kann mir jemand weiterhelfen?
Liebe Grüße
Hanschne

1 Like

Meines Wissens verfügt FP Open OS über TWRP, damit ließen sich Daten vom internen Speicher auf SD-Karte kopieren und auch der Factory Reset durchführen.

Zugreifbar ist TWRP, indem man das Telefon mit gedrückter Lautstärke-Runter-Taste startet. Anschließend die Optionen „Advanced“ – „File Manager“ wählen.

Vorsicht: Nicht der Option „Backup“ vertrauen – die übergeht z. B. Fotos und Dokumente und das Backup bietet nicht die Möglichkeit, auf Einzeldateien zuzugreifen. Unbedingt mit dem Factory Reset so lange warten, bis die gewünschten Daten nachweislich auf dem PC gelandet sind.

3 Likes

Hallo
Ich hab das gleiche Problem wie Hanschne:

  • kann Benachrichtigungsleiste nur noch einmal nach unten ziehen
  • unten funktioniert nur noch der linke Button
  • erhielt keine Benachrichtigungen mehr
  • Kamera kann nicht mehr mit dem Knopf an der rechten Seite gestartet werden
  • manche Spiele kann ich gar nicht mehr schliessen sondern muss das Handy «abmurksen»
  • Telefonate kann ich manchmal auf nicht mehr auflegen (schwarzer Bildschirm)

Ich möchte meine Daten via USB auf dem Mac speichern, doch mein FP2 wird nicht erkannt. Habe auf Mac Android File Transfer installiert, Handy mit USB verbunden. Ich erhalte keine Nachricht zu USB, habe darum unter Einstellungen > Mehr > Tethering > USB-Tethering aktiviert. Bringt nichts. Und auf Build-Nummer klicken geht auch nicht.

@Hanschne hast du das von TobiasF ausprobiert?

Hoffe ihr könnt mir helfen, Grüsse
csb

Hi,
ich hab mir eine Micro-SD-Karte besorgt und es aber leider nicht geschafft, auf die von TobiasF beschriebene Weise die Daten zu sichern (das kann aber auch an meinen begrenzten Fähigkeiten liegen). Die von ihm beschriebenen Optionen “Advanced”- “File Manager” konnte ich nicht finden.
Habe mir dann Amaze installiert und konnte damit zumindest meine Fotos auf die SD-Karte ziehen, anschließend habe ich das FP auf Werkeinstellungen
zurückgesetzt.
Bis auf die Kamera hat dann alles wieder funktioniert. Trotzdem keine wirklich zufriedenstellende Lösung, da z.b. alle Nachrichten usw. weg sind… Aber die Fotos sind zumindest sicher.
Danke an TobiasF an den Tip, auch wenn es nur so halb geklappt hat.
Viel Glück csb!
Vielleicht hat ja doch noch jemand eine andere Idee?

Hallo,
Ich habe das gleiche Problem und habe fairphone support team einen Nachricht gesendet. Ich warte auf das Antwort und werde sie sagen, wenn ich eine Lösung finde! Ich habe auch mehrere Beiträge im English gesehen, aber keine haben einige Antwort.
lg,
Tylaris

Hallo zusammen,

ich habe seit gestern das gleiche Problem wie ihr oben auch beschreibt.

  • Das Telefon schaltet sich immer wieder ab, z.B. wenn ich versuche zu telefonieren.
  • Bei Whatsapp zeigt es mir nur noch Telefonnummern an, keine Namen mehr.
  • Ob jemand angerufen oder ob ich eine Nachricht bekommen habe, wird mir nur noch über das blinkende Licht oben rechts angezeigt.

Ich hoffe es findet sich sehr schnell eine Lösung.

Viele Grüße
limafu

Willkommen im Community Forum.

Nur der Klarheit halber …

Soll das das gleiche Problem sein, um das es in diesem Topic geht? Ich lese das irgendwie anders.
Oder treten diese Sachen zusätzlich zu den vor allem im Topic-Titel genannten Problemen auf?

Bezüglich WhatsApp hilft vielleicht das hier …

Definitiv!
Ich habe mich wahrscheinlich nicht klar genug ausgedrückt.
Meine Auflistungen kommen zusätzlich zu den oben gannenten Problemen dazu.

Zum Thema Whatsapp:

  • Seltsamerweise zeigt es mir nun die Namen wieder an, jedoch kann ich Fotos, die mir geschickt werden, nicht mehr herunterladen / anschauen
  • Ich kann leider kein Backup durchführen, da ich bei Whatsapp unter Einstellungen keine Berechtigung erteilen kann -> ich werde direkt zu App-Info weitergeleitet. Dort kann ich die App entweder “Deinstallieren” oder “Beenden erzwingen”. Bevor ich aber deinstalliere, will ich ja erst alles sichern.
    Leider ein Teufelskreis

Vielen Dank aber für die Rückmeldung!

Backup Whatsapp
Gehst Du nach die app Whatsapp
Tippst Due auf die drei vertikalen Punkte in der oberen rechten Ecke des Whatsapp-App-Bildschirms.
Dann komst Du in die Einstellingen
Geh nach Chats
Geh nach Chat-Backup
dort könnst Du ein Backup machen.

Vielen Dank, aber das funktioniert leider nicht -> siehe

Hallo Zusammen, hier habe ich seit gestern das selbe Problemfeld wie Hanschne, bei mir im Detail sieht es so aus:

  • Es funktioniert von den drei zentralen Steuerungs-Buttons (Dreieck, Kreis, Viereck) nur der zurück-Button (Dreieck)
  • Die drei Steuerungs-Buttons geben aber alle Vibrations-Feedback (was ich deaktiviert hatte)
  • Das Top-Menu / Pull-Down-Menu mit den wichtigsten Grundeinstellungen (WLAN, GPS, Netz, Helligkeit…) lässt sich nur noch einmal herunterziehen und ist daher nicht voll zugänglich
  • Davon betroffen auch das USB-Verbindungs-Modus-Kontextmenü, das immer erscheint, wenn man das Telefon mit einem PC per USB verbindet (Folge: man kommt nicht aus dem Charging-only-Modus und kann nicht via PC auf den Speicher zugreifen)
  • Benachrichtungen aller Art (SMS, Whastapp, Signal etc) erscheinen nicht mehr, aber es vibriert
  • eigenes Hintergrundbild ist verschwunden und durch ein Standard-FP-Bild ersetzt
  • Entwickleroptionen sind nicht aktivierbar (10x Build-Nummer: nix passiert)

Weiteres hab ich nicht ausprobiert, weil ich mich nach mehrmaligen Reboot (und Akku rausnehmen etc) gleich ans formatieren und Neuaufsetzen machen wollte.

Da aber wie gesagt der USB-Verbindungs-Modus nicht mehr auswählbar ist, kann ich keine Verbindung zum PC (Ubuntu oder Windows, klappt beides nicht) aufbauen, d.h. ich kann kein Backup für SMS oder Signal ziehen. Darauf möchte ich nicht verzichten.

Zum Telefon: FP2, Android 7.1.2, Build-Nummer 19.08.1)

Umstände des Bugs: Fehler trat auf, nachdem das FP2 beim Fotomachen abgestürzt ist und ich es wieder hochfahren konnte (war nur durch Akkurausnehmen möglich, reagierte auf nix mehr). Es herrschten beim Forografieren Temperaturen um den Gefrierpunkt und es war ein bisschen feucht / Schneetreiben, hab es damit in Verbindung gebracht. War schon zuvor merklich langsam geworden (habe ich schon öfter bei niedrigen Temperaturen bemerkt). Sonst: habe in den letzten zwei Wochen das Display öfter mal mit einem feuchten einmal-Definfektions-Tuch abgewischt wegen dem Virus. Hat ihr das auch gemacht, ergo vielleicht ein Bug wegen irgendwelchen Flüssigkeiten an Stellen, wo sie nicht hinsollen?

Was machen wir jetzt? Was sagt das Fairphone-Support-Team, @Tylaris ?

Viele Grüsse, Michael

Hat schon Mal jemand versucht, sein Telefon im #dic:safemode zu starten, ob dort das Problem auch auftritt? Sonst könnte das evtl. helfen, um Daten zu sichern.

Auch im Safemode bleibt das Problem zumindest bei mir bestehen.
Dazu kommt das es bei mir ständig abstürzt (im Normalen und im Safemode).
Das abstürzen kann ich im Flugmodus etwas herraus zögern.

Ok, schade. Danke fürs Testen
Dann fällt mir nur noch Start in #dic:fastboot und twrp flashen oder twrp starten ohne zu flashen ein. Dann kannst du Mediendaten über USB auf einen Computer kopieren.

1 Like

Hab das Glück das ich fast alle Daten auf der SD-Karte gespeichert habe, von daher geht nicht viel verloren.
Habe auch noch einige andere Bugs, deren Behebung ich immer nur aufgeschoben habe. Daher hab ich auch schon einiges Gesichert gehabt.
Ohne Simkarte stürzt es momentan nicht ab, so das ich denn Flugmodus herausgenommen habe: Momentan verweigert es sogar die Google Sicherungen zumachen, neue Apps können auch nicht intalliert werden da kein Download stattfindet. Wlan 2,4Ghz wird verweigert, 5Ghz funktioniert.
Hatte seit dem letztem Update immer mal die Anzeige das die System-UI abgestürzt ist, danach kam meistens ein Reboot und alles funktionierte, nur heute mittag war nach dem Reboot das Problem das die Entwickleroptionen weg waren, ständiger Reboot sobalt es hochgefahren (circa nach 10-30s).
Werde jetzt mal schauen was noch auf dem Internen Speicher liegt, was ich noch brauch, und danach auf Werkseinstellung zurücksetzen.

Edit: Nachdem ich die micro-SD entnommen habe kommt es nach 1-5min zum neustart. Konnte mit vielen Neustarts jetzt die letzten Daten per Bluetooth sichern und im 3. Anlauf auch vor dem Neustart zurücksetzen auswählen.

Edit 2: Zurücksetzen hat funktioniert, bin nun am Einichten, Menüs sind wieder da und Buttons funktionieren wieder wie gewohnt.

Edit 3: Bitte denkt dran, das man auf die Speicherkarte danach kein Zugriff mehr hat wenn man diese als intergrierten Speicher konfiguriert hab.
Ratet mal warum ich das weiß :angry:
Hab etwa alle Daten verloren seit November 19. Dazu war mir mein Google Backup bei denn Fotos als aktuell angezeigt, war es aber nicht. So sind alle Fotos seit dem Update auf Android 7 auch weg … (hatte ich im November nicht mit gesichert, da Google das für mich macht …)

Viel Erfolg an alle anderen beim lösen des Bugs. Euch bleibt hoffentlich allen der Fehler (Edit Nr.3 ) ersparen.

1 Like

Das ist ja doof, @Forest, und überhaupt. Auch bei mir hat nix geholfen, hab das, was ich gebraucht habe irgendwie gesichert (heisser tipp, so lange WLAN und die Mailapp noch funktionieren: Backup-Dateien mit einem Fileexplorer wie FX Files ausfindig machen und dorthin verschieben, wo es die Mailapp finden kann und dann sich per Mail schicken…) und dann: Werkeinstellungen und neu einrichten.

Ganz schön nervig, ich hoffe, das Fairphone-Team interessiert sich für diesen Bug , der aus dem Nichts das ganze Telefon faktisch nutzlos macht und kann ihn in mit einem ein Update in Zukunft verhindern. Muss ich nicht nochmal haben!

Nochmal, hat irgendjemand von Euch in letzter Zeit mit Feuchtigkeit (Regen, Kälte, Desinfektionstücher) hantiert? Wäre ja wichtig zu wissen, ob es damit zusammenhängt…

1 Like

Naja ich konnte nur noch Whatsapps empfangen, senden ging nicht.
Apps konnte ich nur deinstalierren, Installationen waren auch nicht mehr möglich.
Das Google backup habe ich manuell gestartet, da stand dann beim Stand (des jeweiligen Ordners) das aktuelle Datum und die aktuelle Zeit (8.3.2020 14:37).
Jeder Versuch auf denn Speicher zuzugreifen wurde durch ein Reboot erfolgreich verhindert. Der Downloadordner z.B ging kurz auf und dan kam einmal kurz eine komplett weiße Seite und ging wieder zu.
Mein Handy hatte im November ein sehr kurzes Vollbad genommen, daher auch die Sicherung. Damals hatte ich es komplett zerlegt (auch die Module selber zerlegt) und erfolgreich getrocknet (1 Woche bis zum ersten Start). Die System UI abstürze hatte ich vorher aber auch schon. Danach hatte ich eher weniger reboots als zuvor. Seit dem funktioniert aber auch mein Display wieder besser (Hab die Kontakte gereinigt).
Also hat das eher nichts mit aktuellem Desinfektionsmitteln und co. zutun.
Was mich jedoch stutzig macht das es sich gerade so häuft.

Was mir gerade noch einfällt, bei mir waren alle Anzeigeeigenschaften, Audioeinstellungen und Verbindungseinstellung zurückgesetzt. Audioeinstellungen waren auch nach jedem Neustart zurückgesetzt und das Vibrieren beim berühren war auch wieder da.

Hallo zusammen, ich habe seit dem 9.März das gleiche Problem. Habe mein FP 2 die ersten Tage danach nur eingeschränkt genutzt, da ich keine Zeit hatte das Problem anzugehen.

Bei mir sind folgende Bugs (genau wie bei @OneOfThe17418 und @Hanschne) aufgetreten:

  • Von den drei unteren “Tasten” funktioniert nur die ganz linke, die “Zurück-Taste”
  • Bei neuen Nachrichten vibriert das Telefon zwar, es wird allerdings weder auf dem Startbildschirm noch im Menü eine Benachrichtigung angezeigt, auch keine verpassten Anrufe, Emails etc.
  • Das Pulldown-Menü kann ich nur einmal runterziehen statt, wie sonst, zweimal. Die Bildschirmhelligkeit, Flugmodus etc. kann ich dort nicht mehr verändern, das geht nur noch in den Einstellungen
  • einige Einstellungen waren nach dem ersten Anschalten nach dem Akkuabsturz verändert: z.B. war plötzlich die Vibration bei Berührung des Displays etc. eingeschaltet (vorher aus), WLAN war aus (zuvor ein), bei Drehung des Geräts: Hochformat beibehalten war ausgeschaltet (zuvor ein)
  • Davon betroffen ist auch das USB-Verbindungs-Modus-Kontextmenü, das immer erscheint, wenn man das Telefon mit einem PC per USB verbindet (Folge: man kommt nicht aus dem Charging-only-Modus und kann nicht via PC auf den Speicher zugreifen). Entwickleroptionen sind nicht aktivierbar (10x Build-Nummer: nix passiert).

Begonnen hat alles damit, dass das Handy morgens nach dem Einschalten plötzlich nicht mehr aufhörte Reboots zu machen (min. 20x hintereinander), das hörte dann irgendwann auf nachdem ich zwischenzeitlich den Akku raus genommen und das FP einmal auseinander gebaut (Display getrennt etc.) hatte.
Wie bei den anderen hatte ich einige Bugs schon zuvor (wie den bereits erwähnt Bug mit der Kamera). Allerdings habe ich genau wie @OneOfThe17418 den Display zuvor einige Male mit einem trockenen Taschentuch und Desinfektionsmittel desinfiziert wegen dem Virus…vielleicht liegt es doch daran?

Ich werde nun auch auf Werkeinstellungen zurücksetzen.

LG,
Isabel

Hallo,
ich habe dasselbe (und noch ein anderes) Problem: Seit einiger Zeit bekomme ich überhaupt keine Benachrichtigungen mehr - das 2. Mal nach unten wischen funktioniert nicht. Ich kann daher auch nicht umstellen auf “Datenübertragung”.

Bei den Einstellungen gibt es bei mir “Verbundene Geräte/USB” nicht.

Mein 2. Problem: Es funktioniert nur noch der Zurück-Button, also der Home-Button und der App-Button nicht mehr. Ich muss also jede Anwendung rückgängig machen, bis ich eine neue öffnen kann.