Help! Bootloop for seemingly no reason

My phone randomly shut down earlier today and just keeps on being in some kind of bootloop.

I can’t get into safe mode, it just keeps on restarting and I get the blue dots but nothing else. I’ve tried every combination of sim/SD/nothing/either and it won’t load. The FAQs don’t give me any help in this instance.

What should I actually do?

Hi bll and welcome to the forum.

You should contactsupport as you may require a repair under the guarantee or other guidance.

I would recommend removing the battery. I realise you’ve done that already, but this time wait 15 minutes before re-inserting it. Test the phone and then turn it off again before replacing the back cover if the problem is solved.

This could also be due to a poor electrical contact.

Your case sounds similar to the one below (not sure how that ended but I guess @pfreudenthaler probably did a factory reset).

I’ve contacted support.

I’ve had the battery out for an hour before with no luck, I’ll try again overnight and see if it works tomorrow.

I bought the phone second hand so no hope for warranty. Visually the battery, contacts etc look fine, unless the shite quality back case causes problems.

If you can get a copy of the receipt form the person you bought it from you may benefit from the warranty. get that and speak to Fairphone if you can

1 Like

You need the proof of purchase of the initial buyer, whether from a shop, operator or FP online shop.

1 Like

I don’t have a receipt, like I said I bought it second hand. It’s had absolutely no problems up to now.

I left the battery out all night, I charged it this morning, still the same problem. Still can’t get into safe mode.

What can I actually do beyond factory reset?

The issue is, can you get the person you bought from to provide you with a copy of the original receipt form Fairphone etc. Just to prove you are the legitimate owner, which could entitle you to 5 years warranty if you can get the phone registered with Fairphone,

I asked when I bought it and he didn’t have it either, it’s pretty uncommon on Wallapop

1 Like

Make sure it’s not a faulty contact. For that, you can use the Ifixit Teardown and individual articles as a guide. Disassemble the phone (but not the components), clean the contacts carefully with isopropyl alcohol and a cotton swab, leave to dry 24h, then reassemble paying careful attention to alignment of contacts. Boot with neither SD card nor SIM to start with.
Don’t over-tighten the screws: the assembly needs to be firm but damaged screws are a real problem. Read this and have a look around. Don’t do this if you’re not confident with fragile electronics, but you could see if there’s a fairphoneangel in your area who might be able to help.

1 Like

For anyone with the same problem I had to do a factory reset. Nothing else worked and there was no obvious reason for the problem. Now everything works bar the push notifications but that may have been from the last update.


Hi there

I’ve had my Fairphone 4 for over a year and last week I noticed it vibrating in my pocket, I pulled it out and saw it was restarting. I quickly realised that was stuck in a boot loop. The blue startup animation plays for an unusually long time (a couple minutes), then the screen goes blank, it vibrates, the fairphone logo shows and the whole process starts again.

I am not aware of any recent updates installed, and I did not recently install any apps. I have not recently damaged the phone in any way, although I did drop it and crack the screen ~1 year ago, but it remained functional so I never bothered to replace it. I cannot think of any specific event that caused this issue to happen.

I attempted to boot it into “safe mode” by turning the phone on and holding the volume-down button as soon as the blue swirling animation appears, but nothing different happens. I also tried removing the SIM card and it didn’t help. I have never installed an SD card.

I registered the phone for the extended 5 year warranty under the Fairphone website when I bought it.

Does anyone know what I should do?

Contact the place you bought it at, and show them your receipt if less than 2 years has passed. If more than 2 years has passed, which I’m fairly certain is impossible at the moment, show them the extended warranty email.

Report back what, if anything, they say.

That does not sound like safe mode however like you tried fastboot mode

Disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode.

So was a cable plugged in?

For safe mode see here dic:safemode

1 Like

I followed your link and it led me to the same instruction I used to enter safe mode from when the phone is turned off, ie:

  • Press and release the power button on to turn the phone on.
  • When the blue animation appears, immediately hold-down the volume-down button, until it boots into safe mode.

Unfortunately, nothing different happened.

Please find the exact link to the instructions I followed:

No cable was plugged in either.

Ok so safe mode is not accesible and would overall not help that much.

So I guess you can try this

And else Factory Reset is the last option


I tried letting the system fail many times in a row and it did not help.

I considered pursuing reimbursal or replacement via the warranty, but in the end I just decided that waiting even longer for that to resolve would be more of an inconvenience than factory resetting my phone. I implemented the factory reset and my fairphone 4 immediately sprang back to life. The issue hasn’t presented since.

Thanks for the helpful suggestions.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.