FP4 doesn't boot, stuck at blue dots


Maybe one of the experts here can help me. My FP4 was working fine until yesterday. I had turned on Airplane Mode during a flight and after turning this off again, it worked normally for a minute or so (not sure if it had connected to the new network) but then it rebooted.

It could however not boot but continued to show the blue dots moving around, after the Fairphone screen. I tried rebooting (many many times), taking out the battery for extended times, and fully charged the phone (it had been reasonably charged anyway). Nothing helped.

Somehow I also can’t start it in safe mode, at least not if I understood the instructions for doing so correctly (reboot, volume down when the blue dots appear).

No idea what could have caused the problem, but maybe someone here has experience? I found a thread where the same issue seemed to be discussed, but they had to solve it by fully resetting the phone.

Not sure if this could be related to the issue, but the phone had offered to do the latest software update a few hours before. This remained open as I was traveling.

Many thanks in advance for any suggestions you might have!


1 Like

As you said flight, did you travel abroad? Have you tried booting without SIM card?

Thanks for the quick response. Yes I traveled abroad (Germany-Poland). Just tried without the physical SIM, same result … There is also a virtual SIM though which I cannot turn off without access to the phone

Which SIM do you use for mobile Data? Overall its just a “Schuss in Blaue” however there have been issues reported with reboots abroad when 5G is enabled…

Just to try if its possible to boot into Bootloader and Recovery. Not sure if there is an Option to disable the eSIM from there or what it means (e.g. can you easily enable etc)

Edit: in this article is a link to the safe mode instructions and those seem to be different to what you did.

There was at least this one case, where problems with 2 SIM cards have caused a bootloop as well. Could have been 5G related, it’s not clearly mentioned in the thread.
Maybe both cards coming back to life after airplane mode triggered some bug that made the system crash :thinking:

So you didn’t initiate the update, right? It has happened before that a FP4 updated and rebooted itself.
There should be enough safeguards in place to make sure the phone boots properly, even if an update failed, but there’s always the possibility of edge cases that will land you in a bootloop.

As with the other thread, there isn’t a lot that can be done here, apart from trying to get into Safe Mode.
If that doesn’t work after let’s say 20 tries, the next step would be performing a factory reset :see_no_evil:

1 Like

have seen reports for Iode, so thought it could probably be somehow happening with FPOS as well, although the reports were not so extrem, i.e. the system still could boot and “just” rebooted itself more or less often .

Edit: just for completeness although not related to travelling

1 Like

Hi again everyone and thanks for all the tips! I actually managed to go to recovery mode thanks to one of them. But I’m afraid that’s how far I got :). The only option there that seems useful is the factory reset.
I also looked into the option of unlocking the bootloader. But either the article on this is incomplete or I actually need the IMEI (sticker in the phone) and the serial number - and the latter can only be found through the phones settings, great.
So if anyone has a great last minute idea I’m all ears! Otherwise I’ll lose the data but hopefully at least have the phone back

Unlocking the bootloader would require a factory reset, dont see any advantage to do this…

1 Like

Ah right, thanks. Well in that case there seems to be no way around it. Thanks anyway to everyone!

You can also get the serial number in the bootloader with fastboot getvar serialno, but that won’t help you here. To unlock the bootloader you need to enable that option in the phone’s settings beforehand and as @yvmuell said, unlocking it would wipe your phone anyway.

Yeah, sorry, factory reset it is :see_no_evil:

1 Like

Hi !

My case, with FP4 rebooting when using 5G is likely not related. Not the same behaviour at all! For me it was ( or is…) just a quick reboot when using 5g, especially in certain geographical areas ( = signal conditions ?) and then back to normal after the reboot.


I know and still you never know its not somehow related to 5G…

Sometimes a reboot seems to be enough to send the FP4 into a permanent bootloop / brick it, so 5G might still be related.
The more reasons for spontaneous reboots we can find, raise to support and hopefully (they) eliminate, the better, I’d say.

On that note, @pfreudenthaler , if you haven’t already, please #contactsupport, so they are aware of the problem and maybe can prioritize fixing this based on the amount of incoming reports.


My issue is absolute 5G related, but likely not related to this problem. Unless the reason for the first reboot is the same as mine, but the bootloop is different.

When I turn off 5G there is no reboot issue at all for me. And have spent the summer in a different geographical area, did switched on 5G and no problem at all. So likely related to certain signal conditions, which happens to be a few hundred meter from home…

1 Like

This was just meant as an example and that was clearly stated above, no one said its the exact same behaviour as you see. You have 5G related issues at home, others with Iode OS have seen this during travel and the current case is probably related to travel, 5G, the update, or who knows. Thats how troubleshoot works, never exclude anything.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.