FP4 crashed after using dual SIM, now stuck in boot screen infinitely

So, for about half a year I was using FP4 with one physical SIM card, but recently I moved my private one to an eSIM and used the physical slot for my business SIM card.

First day I noticed my phone would reboot randomly, or when mobile data was enabled, it would crash in the first two seconds, but it was still possible to enter settings and disable the physical SIM.

I was wondering if it was one of the cards’ fault, but no, separately they work ok.

Today I decided to try dual SIM again and this time after crashing phone is stuck on loading screen, even after removing the physical SIM.

Phone definitely has the latest android update.

The most likely culprit is still the physical SIM card in my opinion and given the amount of problems already reported in the forum. How old is it?
That it won’t start any more even without SIM is strange, of course. Have you tried booting inito safe mode, for example? Could the SIM have damaged the slot somehow, maybe because it was manually cut from a bigger SIM?

1 Like

If you have 5G and/or VoLTE enabled turn of one and/or the other once you can Boot again.

And for safe mode see here #dic:safemode

edit: can you boot into fastboot/recovery?

  • Power off your FP4 and once it’s off, connect the USB-C cable.* Boot your device into Fastboot mode.
    Press and hold the volume down button (up to five seconds)

For recovery its the Vol-up Button

Once you are in either mode you can use the Vol Buttons to move and power to confirm e.g. to boot to system. In worst case scenario you can hopefully do a factory reset from recovery (i.e. lossing all data).

1 Like

It is a year old, at counting from when I received it and it was not manually cut out.

After the Fairphone writing disappears, the blue animation will start. As soon as this happens, > press and hold the Volume down button.
Keep holding until your device starts.

It looks like it doesn’t work either

What did you try to boot into? Safe-/Fastboot-/Recovery Mode? For fastboot/recovery did you try to shut down, add cable and press the respective Vol Button as inidcated above?

Edit: official support article to do a factory reset through recovery with detailed steps to boot into fastboot and from there into recovery

I tried safe boot, ideally I don’t want to do factory reset

I understand and it would be good to know if you can boot into fastboot/recovery (just booting into it will not perform a factory reset) .

As the eSIM could also somehow be the culprit, can you check with your provider about options to deacticate at their End and how it could be reactivaed later or if this causes issues? Any chance to test another physical SIM? Do you have a SD card inserted?

Well, the eSIM has been in use for at least two weeks, it most likely is alright.
The physical SIM was used in other phone for months.
No SD card.

For fastboot, I need to hold vol down, plug in charger, select recovery mode, enter fastboot, reboot system now? Then also it loads infinitely

So I understand fastboot and recovery are working what is at least somehow a good sign. The physical SIM is not that old however even of it worked or works in another phone it does not mean its not faulty. I dont know whats wrong, if it would be my phone I would check with the provider about options to temporarily disable (not sure if possible or what it means) from there end to see if you can boot then. Otherwise I guess ( maybe others have further ideas) you will have to go with factory reset.

Factory reset worked, how can I make it less painful next time? I’ve heard of titan backup, or something like that

3 Likes

I inserted other SIM card and it… seems to work? Hmm, anyway, this topic I think can be closed.

So you now have the eSIM active and another physical SIM? Fingers crossed its solved and the SIM card actually was the culprit. Just when you see issues starting like reboot, turn off 5G and if this does not help also VoLTE. Just to prevent a complete crash again.

Reg. Backup: i think all tools backing up everything like Titanium need root. As I dont have root, my pictures are uploaded in a cloud, my calendar and contacts are synced with Davx and WA, Signal backups etc I move from time to time to SD card and or PC.

2 Likes

You may install magisk and TitaniumBackup apps, patch boot.img using magisk app, boot FP4 from the patched boot.img (fastboot boot boot_patched.img) and do the backup (on the temporarily rooted device).
Doing the restore would go the same way.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.