Headphone Jack/plug doesn't work

Today I also had the issue that a plugged in headphone was not recognized (sound played on the internal speaker). It worked as before after a reboot. Then, everythig was fine as it was for some days before. Audio stops when you unplug it etc. Looks more like a software than a hardware issue to me, if it can be fixed with a reboot.

I’m not sure if there was a headphone symbol before, now there is none if they are plugged in.

I don’t want a bluetooth headset as a general “workaround”, as it would be another device I have to keep charged, and it probably has a built in battery. I only use a bluetooth speaker now and then, which works fine.

2 Likes

Had the exact same issue with every app that creates sound (have not tried GMaps). Unbearable crackle with headphones, but fine with speakers. Out of curiosity, I opened the phone, disassembled the top module, blew some dry air into the jack plug, and onto the ribbon cable and its connector. Then reassembled everything.

So far audio on headphones is working as it should. I will wait a few days to claim it’s solved, but if I don’t update consider it as a quick fix (or at least a procedure worth trying). Hope you can solve your problem!

EDIT: Nope, it worked for two days but started crackling again. So I’m going to contact support now. Sad.

4 Likes

I tried also to disassemble it and clean the connectors on two phones (both had the same issue). In my case it didn’t help. I just returned them and bought a Chinese brand instead …

@WePhoton: Same here, but sometimes when audio “crashes” and after I disconnect the headset the speaker doesn’t work, when called no ringtone, microphone and earpiece also don’t work. After rebooting the phone all those problems are gone, until i have been using my wired headset for some shorter (5 minutes) ore (mostly) longer time (many hours). Luckily the FP3 reboots faster then any smartphone I had before…

1 Like

Same problem, I solved it restarting the phone but… surprise! Today I tried to make a phone call without headphones and the microphone didn’t work and I couldn’t hear anything, nor with the internal speaker nor on live voice. Thus I restarted the phone, and it went back to function normally, both with or without headphones.
In conclusion, it feels like at the beginning there was a problem with switching automatically from headphones in vs out. Restarting the FP3 and trying the various configurations it went back to normal. (Hope it’s clear, I don’t actually manage technical terms very well :slightly_smiling_face: )

2 Likes

Fairphone support told me that they are aware of our issue as several customers have reported it. They are still investigating the issue affecting a limited number of all devices.

So it seems for me there won’t be a software fix soon :thinking:
Might be the best solution to send it in for repair/replacement?

2 Likes

Same here. I plugged in headphones for the first time this afternoon after leaving my Bluetooth heaphones at work and… Grrr!!! No go!!. I’m guessing Fairphone didn’t carry out any beta testing on the FF3? I suppose I should be grateful that the audio didn’t crash.

Hi,
I just received my FP3 after my old phone broke down. But I am experiences difficulties with the headset (wired). I cannot use the buttons although it is for android. Also it is not always recognized. For example when I am on the phone and I just unplug the headset, the audio is not moved to the internal speaker. Instead I do not hear anything. When clicking on speaker mode, I can hear again the other person.

Is this a common software issue or is my phone faulty?

Thanks,
km

Are you using with the rubber bumper attached on the phone? I have found that some jacks don’t fit with the bumper on

Without the bumber and I tried a three headsets in total :frowning:

I just saw this:

The headset I used with my FP2 do not work on the FP3. When I plug in the jack, the phone continues to reproduce sound over the loudspeaker. Also the mic does not work. As if there was no headset plugged in at all.
Has anyone got a similar problem with their FP3?

I moved your post here to avoid duplicate topics, please have a look at the experiences shared here.

Thank you. Did not think of “headphone” as a tag.
Obviously this is a common problem.
Restarting the phone did (for now) solve the problem. Hoepfully, this need not be done permanently.

I am facing a weird problem with my FP3. I wonder if anyone else also has the same issue.

The phone gets stuck in earphone mode even after removing the earphones. The only way I can get audio to play is to restart the phone. After I restart, the phone works fine. The audio (calls, media, etc.) works fine. But if I put in my earphones to listen to something and then take them out, the audio (calls, media) stops working.

Any idea why? Is this a software or hardware issue?

2 Likes

I moved your post here to avoid duplicate topics, please have a look at the experiences shared here.

Thanks. So what do we do now? Restarting the phone cannot be a sustainable solution.

2 Likes

Ik kreeg van fairphone te horen om de telefoon te resetten. Dat heb ik gedaan en de hoofdtelefoon werkt zoals het hoort.

I was told by fairphone to reset the phone. I did, and the headphones work the way they should

Hello,

same problem for me:

  • Sound is OK through jack but after some time I can only hear crackles for around 10 seconds, and then, nothing. Tried 3 different jack earphones: same result. Tried different apps: same result.
  • When this occurs, only a reboot solves it
  • When this occurs, sound is OK through Bluetooth and on speaker
  • I experienced this problem 3 times this morning, on my bicycle, the phone being in my pocket. Even though I am not a mad max on the road, the movements of the phone in the pocket may be the cause of the problem
  • I did mention the problem to the online customer support

As the problem disappears after reboot, it might be a software issue.
Some other discussions about audio problems on FP2 and FP3 seem to indicate it is a software issue:


If so, a device replacement won’t be very helpful.
We would then have to wait for an OS update from Fairphone, or install another OS.

3 Likes