Green LED no deactivation

Dear FP-mates,

I have OS 1.2.8 on my FP2. I still have trouble with the LED (an other one than the one reported in the release news): when charging, it is green and it is impossible to change or deactivate. I want to deactivate it so that I can sleep.
As was reported last January on this forum, it is impossible to access pulse notification options.
Third party apps advised on this forum don’t work either (I tried different testing conditions: still green).

Is it possible to activate the pulse notification options without going into hard coding the system?




Interesting… I think my LED is flashing red during charging most of the time, but maybe this was before the update. I’ll have to have a closer look when charging next time. But nevertheless it’s blinking all the time, you’re right.

Anyway, I just place the phone with the screen (and LED) facing down on my bed table so I don’t see it. But that’s more of a workaround…

fortunately, my FP2 isn’t flashing yet shows the green LED when charging. i keep with your advice: i just turn it upside-down to have “peace of mind”.

Same issue here, I get a green-white LED, which I can’t turn off or change. It’s a pity, since I really hoped the update would solve the LED problem, not change it :slight_smile:

1 Like

For me that’s also the case. While charging it’s green. Also when the LED flashes for notifications, it’s not a consistent color. I would like to be able to change these settings in the settings of FP2 itself, and not an external app.

external apps don’t work either way.

Well too bad. I hope a programmer could make the pulse notification option work.

I noticed something else too. After charging, when I take out the cable, I sometimes get a green-white blinking LED (same colour as the charging one), as if I got a notification. But there is no notification and I can’t stop the blinking. It only stops when an other notification arrives and sometimes also if I connect the charging again.

This problem doesn’t occur every time, but often enough to get annoyed. Especially if you get this “notification” when you want to go sleeping :slight_smile:

So, the famous LED-bug gets worse?

For the charging LED I solved by installing XPosed+GravityBox which has an option to disable the LED while charging :slight_smile:

As I am not at all a DIY - mostly techincally challenged, could some please explain in very simple way what is XPosed and GravityBox, how can I get them and how do I use them to disable the led while charging. What I would want to able instead is to see the led blinking when ever I get a message (no sound needed, thank you, that I’ve been able to disable). Thanx for your understanding for a technically less than “mere mortal”

1 Like

The xposed framework kind of docks onto Android on a deep level, which allows you to install numerous modules for fulfilling tasks that the default system does not cover. Unlike installing another ROM (like CyanogenMod), you can remain on your default Android, but enrich it with lot’s of different modules that bring more/other features.

If you want to run it, you need to flash the xposed framework first, and then an installer app, which allows you to easily download and install all these modules for different additional features. Gravitybox is such a module, which is quite powerful and allows many modifications that you do not have on your default system.

If you want to install it, please have a look at this thread:


Sorry for the delayed feedback. Thank you for your answer. Unfortunately it was far too tech-jargo for me. Thank you for trying, though.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.