GPS fix takes very long after update (with e.g. and GPSTest)

I don’t see different behavior on my phone if the GPS was on beforehand, it’s not like it’s constantly updating your position in the background if no app is using GPS.

For which of the three values (used/useable/known)?

Did you try injecting PSDS / time data, any difference?


Hi there,
My first post here to try to fix my GPS issue.
I bought my FP4 last week and discover my GPS is very long to fix my position (with Waze/ GMaps)
To try to solve by myself :
I checked the apps parameter : Position always allowed
I reboot my FP4 several times
I installed GPS Test to see the behavior : Outside, without Wifi, with 4G, GPSTest first show me 19 to 23 in view/ 0 in use during 30 to 60 seconds before fixing the GPS
Do you think It could be an hardware issue ?
Do you have some other tips ?
My Fairphone version : FP4.FP4G.A.170.20220920

Some good news here. The GPS problem disappeared after turning off the phone, and removing the battery for about 15 minutes. Now I have instant fix within a few seconds, and no more inaccurate tracks or navigation anymore.

The reason I did that, was unrelated. My phone suddenly went completely dead during the night. I was afraid it was bricked, but the above method (removing the battery) solved the issue.
This was about 2 weeks ago, issues didn’t occur anymore since then.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Re-opening this topic as after the previous and the current update ( FP4.SP2J.B.086.20230807) I noticed that it took long to find a fix, GPS test had very few sattelites only and the time is incorrect and only after refreshing time data and PSDS and rebooting its fixed


Yep, can confirm. I thought I was going crazy.

1 Like

I got around this bug by using GPSTest and clearing assist data, injecting time and psds data. I then turned the phone off, removed battery and SIM.
On reboot, without SIM, GPS time was accurate again.
Turned it off and replaced the SIM and it’s still accurate.

It doesn’t help find the bug itself but it might resolve the bug for others. With luck the gps time will remain accurate.

1 Like

Yeah, that usually fixes it. And it’s great that there’s actually a simple workaround like that. But the thing is, it shouldn’t happen in the first place. :man_shrugging: I have never had this problem with any other phone.

1 Like

I just had to reboot, no need to take out the SiM or are you saying this is a permanent fix, i.e. it survives updates?


No idea of permanence. I just chucked all the advice,saw someone say that support claimed the SIM was to blame.

One would hope it survives the updates!

Another update and here we go again… Weird, at first time was correct, it just took quite long to get a fix then I let the FP lying on the table for a few minutes while GPSTest was till open and the time changed to incorrect

I can confirm that I’m currently also getting a wrong time: Jan 26, 2004 currently.

I just reported this problem to the fairphone support. My FP4 also has this issue, and a few seconds after the time in GPStest is marked as faulty the GPS fix gets lost :frowning:

Just asking the obvious, you are outside when you test the gps?

it doesnt matter really, there is something broken… the fix isnt staying after this update the time is repeatedly wrong… so to use navigation, plan ahead and be prepared a reboot is needed before it works…

In my case the time might be wrong, but neither do I lose the fix nor did I experience any problems with navigation so far.

Yes, it happens outside.

After the A13 upgrade I had a fix withing seconds, and correct date and time. Maybe finally fixed.

I haven’t experienced this problem since the Android 13 update either. I would wait a while longer before marking this as solved (again), but it’s possible that it’s finally fixed.