Android Auto - no/bad GPS after update FP4 to Android 12

I did some digging and 7168 days is not random:

Technical background: The current GPS navigation message (from satellite to receiver) only contains the ten least significant bits of the week. After 2^10 = 1024 weeks = 7168 days, the week number rolls over from 1023 to zero. Most GPS receivers handle this properly (they can determine the full year number by some other means), some (like the Garmin GPS18) don’t.
Seen here

aka GPS Rollover

I found that GPSLogger fixed it in GPS Weeknumber Rollover

I gave it a try and did the same procedure (reboot in airplane), it fixed in 15 sec and GPSTest showed and keep the correct date and is stable

Looking further, GPSTest also had handled this problem (years ago) in Backport GPS week rollover (wrong time) highlighting to earlier versions · Issue #379 · barbeau/gpstest · GitHub , I’m lost…

My current guess is that an old library or driver was shipped in the Android 12th update

1 Like

Whatever, please contact support to make FP aware and get help as needed

1 Like

Same problem, my previous video ( was taken without being connected to the car.
I’m out now for a few hours in may car, I will run gpslogger in background before connecting to the car and we will see if it’s “a reliable bypass”

1 Like

I’m not sure how exactly but my problem is currently solved, even without GPSlogger nor GPSTest running in background and even without the need to start the navigation before connecting to the car.

Perhaps that fix was in the latest security update?
Sounds good!

Hey @LibertyX82,

It’s weird but could you install and run GPSLogger, check if it’s ok there then retry GPSTest and see?
I can’t explain but since I did I don’t have the problem anymore, anywhere, Android-Auto included.

Not sure, as

So wrong time which you will see in GPSTest is the issue. So load time data and PSDS in the GPSTest App and then reboot seem to help. Did you follow the link to the other topic, or did you just read the first post visible here? The wrong time is an old issue not connected to A12 and not happening on all FP4. I had it now for the first time.

Unfortunately I experienced this problem, too, and sent a message to support, but I’m still waiting for their reply.
What I realized in my case was that the status bar where the provider, Bluetooth, etc is shown, was flickering like mad. Also my phone was really hot. So I disconnected my Bluetooth connection between the car and the phone and then the GPS signal was stable again in android auto using Google maps

1 Like

I noticed that hot part too last time!
Bluetooth?? Wow… Must try that next time. Good observation, thank you.

Are you now talking about the Android Auto connection only or GPS in general not working? What does GPSTest show for time? Mine was incorrect, after injecting PSDS and Time and rebooting, time was corrected and more Satellites found and without Android Auto no issues.

so when this is not related to Android Auto, please head over to the general topic moving forward, this topic here is about Android Auto related issues

this topic here clearly is about ANDROID AUTO and not anything general, so either all need to go together or those not using Android Auto head over to the general topic moving forward

1 Like

I saw my name mentioned but the response apparently is gone.
I do experience problems with GPS in combination with Android Auto when I first connect the phone and then activate navigation.
When I activate navigation and tap ‘Start’ to go on the road, and then connect the phone to the car, things work just fine. Just to be clear.

1 Like

Hello everyone,
since the Upgrade to Android 13 i have used Google Maps on the Android Auto Display twice. And everything did work as it shoud - no problems with the GPS fix - without me starting the navigation before plugging the phone in.

My guess is that the upgrade fixes this problem - it would be nice if someone could confirm that :slight_smile:

Have a nice day everyone,

As stated here before I would rather say, the problem is Android Auto related. There were some updates in the app, in the past weeks, too. So this could also have fixed the problem.

I don’t think that the Update fixed the problem, as the Android Auto App had the same version on my wifes Pixel 6 and it ran without failing to get a GPS fix.

Also, i had the Problem happen 2 on Saturday and Sunday before the A13 upgrade.

Ok, on a different OS / Device the issue could possibly not be existing. But I had the problem with both A11 and A12, while the problem did not occur for several weeks with A12.

I can state that the upgrade to Android 13 fixed the issue for me. No problem yesterday on the road.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.