GPS fix takes very long after january update (with e.g. Mapy.cz and GPSTest)

And this did work fine before the January update? I’ll update the title a bit so it’s more clear this doesn’t affect Google Maps, geotagging pictures, Assistant, etc. I’ll also mark in the wiki article that a workaround exists, i.e. using Google Maps. And I’ll change the impact to a green circle, since it works fine with Google Maps, which most people will be using for navigation. So for most people it works fine, so my interpretation is then that the impact is low.

I don’t know, I didn’t travel that much during December and January. And it’s still a bit random, but it currently affects only this app. I think the difference might me that both Google Maps and Waze use Google Location Services (which apparently work fine), but this app seems to be using the plain Android location API (because I can also find it in the Huawei AppGallery). But this doesn’t really explain why GPSTest manages to get the correct location while Mapy.cz cannot. :smiley:

1 Like

I have now installed the latest update some days ago and done a few tests.
It appears that the gps has not improved.
Even after having cleared data using GPSTest and rebooted, waiting a day, it still takes minutes to acquire a first fix.
As I have experienced the time to get a fix might differ from day to day, I compared the time to fix with GPS sports watch next to the fp4.
The watch acquired a fix in less than two minutes while the fp4 needed several more minutes.
GPSTest appears to acquire a fix faster than OsmAnd which I use to log tracks.

I don’t have this with Google Maps or when I shoot pictures and geo tags are added. Could it be that GPS always takes a minute to form a constellation to get a location fix? Android improves this by using known Bluetooth and WiFi signals for location as well. I know that the TomTom in my parents car also takes about a minute to get a fix on location. Depending on the line of sight, if there are no large buildings or even trees nearby it is faster.

Just trying to pinpoint if this is actually a bug, or just using the location services differently, and thus it’s slower to get a location. Because then it’s not a bug, those other apps should use the location APIs in Android to acquire a location faster.

Edit: Just did a test with my Pixel 3 and GPSTest, it takes more than a minute to get a location fix. So I think we can then confirm that it’s most likely an app specific issue, since location works fine otherwise on my Pixel 3 and Fairphone 4. I’ll mark it as solved in the wiki because it seems to work as it is designed to.

3 Likes

Android should download GPS Ephemeris data and Almanac via network. If the download was successful the sensor can immediately start triangulation giving a TTFF in seconds (hot start).

What I’ve been experiencing was in the range of a “cold start”. See Time to first fix - Wikipedia

Google Maps and using WiFi and Bluetooth signals for location services aren’t acceptable workarounds for me because of privacy concerns. And it wouldn’t help me hiking, out in the woods.

2 Likes

Has the new OTA improved / resolved that issue for you or others? :thinking:

1 Like

No. Had to clear assist data and power off the phone, again.

After this procedure TTFF was 2 seconds.

Looks like the GPS sensor is working, in principle, but an update gets it into a weird state.

1 Like

Which app are you using to test this? Google Maps works fine? Have you made any changes to your ROM? I’ve e.g. seen people using adb to disable system apps. Are you using a pristine Fairphone ROM?

Didn’t make any changes to the ROM, so yes, a pristine Fairphone ROM.
I’m using OsmAnd and Organic Maps for navigation. And GPSTest for analyzing GPS issues. Disabled (almost) everything Google.

1 Like

How did you disable the Google stuff? In the regular settings and disabling apps in the regular way? Just making sure a critical part of Android isn’t disabled to acquire a location faster. Those apps you mention work normally (like Google Maps) on other phones? I used GPSTest on my Pixel 3 and it was very slow to get a location while Google Maps is instant like on my FP4. So I’m not really convinced this is a FP issue. Seems to me a 3rd party app issue.

We probably have a different definition of “pristine” :smirk:

Are you using OsmAnd / Organic Maps from Google Play or the F-Droid versions?
The Play Store versions use com.google.android.gms.location included in the Play Services, so if you disabled com.google.android.gms you’ll likely run into problems there.
OsmAnd has added an option to switch to the google-less android.location API (see issue #14001 and this commit), but that’s only available in the nightly release for now. Not sure if something similar is planned (exists) for Organic Maps.
Since you linked to GPSTest on F-Droid I assume that doesn’t apply to you.

Regarding A-GPS data, I found this interesting comment from one of the Organic Maps contributors:

OSMAnd, however, also triggers A-GPS update automatically every 16 hours. I implemented similar feature in Organic Maps

So apparently OsmAnd (and the latest Organic Maps as well) are indeed updating A-GPS data, just not that frequently, didn’t know that :slightly_smiling_face:
Could anybody check if the time to get a fix improves for those apps after a day or so? :thinking:

3 Likes

We’re going off on a tangent here…

I’ve disabled Google Maps and “Google Standortgenauigkeit” (whatever that’s in english). WLAN and Bluetooth location are disabled. I’m using OsmAnd and Organic Maps from the Google Play store.

This usually works quite well for me.

The only (small) remaining problem for me - an update renders the GPS sensor non functional and I’ve to clear the data and power down to get it working again. Took me ages to figure that out the first time - now that I know about this “workaround” it’s just an annoyance. Unless this means my hardware is broken… :wink:

I used GPSTest on my Pixel 3 and it was very slow to get a location while Google Maps is instant like on my FP4. So I’m not really convinced this is a FP issue. Seems to me a 3rd party app issue.

AFAIK Google Maps uses additional methods to get a location - GPSTest uses just the GPS sensor. So your test essentially confirms my problem… on the Pixel. :thinking:

Does it? To me it seems it is slow on 2 phones, while it’s not slow when using other apps. So to me it’s an app issue (or simply how GPS is), not something FP can improve in their ROM, right?

The most recent update seems to fix this. I can get the GPS nearly instant.

3 Likes

I am experiencing this issue. What I observe is, that when the fix takes long there are only the GPS and the GLONASS satellites available (checked with GPSTest). In those cases usually a reboot helps. Then I see also Galileo and BeiDou satellites and the fix succeeds after a couple of seconds. However, sometimes it happens that the device does no longer see Galileo and BeiDou and the fix takes forever. Then only a reboot helps.

1 Like

A few days ago, I noticed that the GPS date was wrong. GPSTest showed September 2002. And at that moment, Mapy.cz could not get a GPS location when it was in the foreground. When I reopened GPSTest (and Mapy.cz was moved to the background), the navigation actually worked fine despite the wrong date. But when I moved the app to the foreground again to actually see the map, it stopped working. Unfortunately, it didn’t occur to me at that moment that I could try to inject time data using GPSTest, which might solve the problem. I will definitely try that next time this happens. Anyway, from what happened to me, I think it is safe to assume that there are two problems. First, sometimes the GPS date or time is incorrect and needs to be manually fixed by injecting data in GPSTest. (I think this should be handled by the OS. I have never had this problem on any other phone.) Second, some apps seem to be sensitive to this issue and cannot get the correct location on its own.

Related issues:

1 Like

I was affected by this problem and it was really annoying, because applications like car navigation and strava ride tracking didn’t work properly. However, since update FP4.FP3W.A.128.20220516 this problem is gone now, and the GPS is functioning instantly and very accurately. So I am very happy this problem is solved.

1 Like

Unfortunately a few updates later, the problem seems to have returned. Very inaccurate and a GPS fix takes ages. Navigation becomes useless the first 20 minutes, jumps all over the places.

It would be nice if Fairphone would improve their QA on their updates, it is very annoying this bug returns again.

Cant confirm…which app do you use? Had no issues with GMaps or MagicEarth the last days…

All apps I have using GPS. Google Maps, OSMAnd, Strava. It’s really a GPS problem in the phone, the same as described before. Getting a fix takes very long, in the mean time the location service jumps to nearby wifi/celltower locations, thus very inaccurate.
Version: FP4.FP4G.A.170.20220920