GPS fix takes very long after update (with e.g. and GPSTest)

We’re going off on a tangent here…

I’ve disabled Google Maps and “Google Standortgenauigkeit” (whatever that’s in english). WLAN and Bluetooth location are disabled. I’m using OsmAnd and Organic Maps from the Google Play store.

This usually works quite well for me.

The only (small) remaining problem for me - an update renders the GPS sensor non functional and I’ve to clear the data and power down to get it working again. Took me ages to figure that out the first time - now that I know about this “workaround” it’s just an annoyance. Unless this means my hardware is broken… :wink:

I used GPSTest on my Pixel 3 and it was very slow to get a location while Google Maps is instant like on my FP4. So I’m not really convinced this is a FP issue. Seems to me a 3rd party app issue.

AFAIK Google Maps uses additional methods to get a location - GPSTest uses just the GPS sensor. So your test essentially confirms my problem… on the Pixel. :thinking:

Does it? To me it seems it is slow on 2 phones, while it’s not slow when using other apps. So to me it’s an app issue (or simply how GPS is), not something FP can improve in their ROM, right?

The most recent update seems to fix this. I can get the GPS nearly instant.


I am experiencing this issue. What I observe is, that when the fix takes long there are only the GPS and the GLONASS satellites available (checked with GPSTest). In those cases usually a reboot helps. Then I see also Galileo and BeiDou satellites and the fix succeeds after a couple of seconds. However, sometimes it happens that the device does no longer see Galileo and BeiDou and the fix takes forever. Then only a reboot helps.

1 Like

A few days ago, I noticed that the GPS date was wrong. GPSTest showed September 2002. And at that moment, could not get a GPS location when it was in the foreground. When I reopened GPSTest (and was moved to the background), the navigation actually worked fine despite the wrong date. But when I moved the app to the foreground again to actually see the map, it stopped working. Unfortunately, it didn’t occur to me at that moment that I could try to inject time data using GPSTest, which might solve the problem. I will definitely try that next time this happens. Anyway, from what happened to me, I think it is safe to assume that there are two problems. First, sometimes the GPS date or time is incorrect and needs to be manually fixed by injecting data in GPSTest. (I think this should be handled by the OS. I have never had this problem on any other phone.) Second, some apps seem to be sensitive to this issue and cannot get the correct location on its own.

Related issues:

1 Like

I was affected by this problem and it was really annoying, because applications like car navigation and strava ride tracking didn’t work properly. However, since update FP4.FP3W.A.128.20220516 this problem is gone now, and the GPS is functioning instantly and very accurately. So I am very happy this problem is solved.

1 Like

Unfortunately a few updates later, the problem seems to have returned. Very inaccurate and a GPS fix takes ages. Navigation becomes useless the first 20 minutes, jumps all over the places.

It would be nice if Fairphone would improve their QA on their updates, it is very annoying this bug returns again.

Cant confirm…which app do you use? Had no issues with GMaps or MagicEarth the last days…

All apps I have using GPS. Google Maps, OSMAnd, Strava. It’s really a GPS problem in the phone, the same as described before. Getting a fix takes very long, in the mean time the location service jumps to nearby wifi/celltower locations, thus very inaccurate.
Version: FP4.FP4G.A.170.20220920

Does not seem to be a general problem, so I would probably #contactsupport to exclude a Hardware issue with your phone.

Else have you tried in safe mode (GMaps should still be available) to test? #dic:safemode

Or any of the other forementioned tipps?

1 Like

I also have GPS issues since last update.
Check this thread: GPS no refreshing fast enough - #5 by lordtaki

Yes, I can do that. I will also try to screenshot some GPSTest screens next time.
I however think the chances it’s a hardware issue are low, because the problem appeared directly after the system update, that must be related.

1 Like

even if related with the update there must be other settings/circumstances which facilitate this behaviour, as I dont have this problem. This makes it difficult to detect during QC before roll out of an update.

Def inform support they need as much information to troubleshoot

Some update made it slightly worse for me. It is not in the range of 4-6 minutes as before but still 1-2 minutes and ugly if you start navigating and had the GPS disabled. (this happens for different apps)

What’s the number of satellites you are getting in GPSTest? Does your system clock differ from the time shown there? What’s the value of TTFF (if any)?

Have you tried injecting PSDS / time data in GPSTest (in the left drawer menu) and rebooting the phone?

1 Like

With latest update, stock FPOS: TTFF 10 seconds inside my office. So maybe it’s a hardware problem with some phones? Or it’s because GPS is usually disabled. Mine is on all the time at least…

1 Like

Of course if the GPS is on there is no problem. This problem is regarding the initial GPS fix.

What’s the number of satellites you are getting in GPSTest ?

I can see many (>20). Even before I get the initial GPS.

Does your system clock differ from the time shown there? What’s the value of TTFF (if any)?

the time is identical and the TTFF is empty.

PS: sometimes I get a fast GPS fix (~20sec). But no idea under which circumstances (could it be due to disabled 5G?). Will have to try this a couple of times with reboots.

I don’t see different behavior on my phone if the GPS was on beforehand, it’s not like it’s constantly updating your position in the background if no app is using GPS.

For which of the three values (used/useable/known)?

Did you try injecting PSDS / time data, any difference?


Hi there,
My first post here to try to fix my GPS issue.
I bought my FP4 last week and discover my GPS is very long to fix my position (with Waze/ GMaps)
To try to solve by myself :
I checked the apps parameter : Position always allowed
I reboot my FP4 several times
I installed GPS Test to see the behavior : Outside, without Wifi, with 4G, GPSTest first show me 19 to 23 in view/ 0 in use during 30 to 60 seconds before fixing the GPS
Do you think It could be an hardware issue ?
Do you have some other tips ?
My Fairphone version : FP4.FP4G.A.170.20220920

Some good news here. The GPS problem disappeared after turning off the phone, and removing the battery for about 15 minutes. Now I have instant fix within a few seconds, and no more inaccurate tracks or navigation anymore.

The reason I did that, was unrelated. My phone suddenly went completely dead during the night. I was afraid it was bricked, but the above method (removing the battery) solved the issue.
This was about 2 weeks ago, issues didn’t occur anymore since then.