GPS doesn´t work on FP Open OS

Ohlala Paul, I tried to read more carefully the wiki of the forum to understand how to setup my FP open, and I realised I didn’t do much so far (basically I just installed the OS). From one article, there is always a link hiding another article, and another… I will write you back as soon as I am ready!

First thing first, I tried with my normal Fairphone Open 17.01 to open maps (with OSMand, and Swarm) but nothing worked: a pop-up with “waiting for location” appears on my screen. Then I tried to download Google maps. Same thing. However my location settings is turned on, and set up on “High accuracy”.

So I installed FasterGPS. Entered in the developper mode to make it work. I set up my location to Europe and Netherlands (where I live). Nothing changed. I changed the advanced settings INTERMEDIATE POS to 1.
Tadaaa! Swarm recognised where I am! Humm wait, no… OSMand and Google Maps don’t. I download Waze to check, same thing. “Waiting for location”. I reopened Swarm, “Waiting for location”… Arf!

With “GPS Status & Toolbox” nothing appears, except the compass.
It seems there is another problem.
What could it be?

EDIT: I just tried with SatSat. Left my phone for 2minutes next to the window and it worked. I just hope this will work also when I am moving… We will see!


Do you have wlan enabled? I learned that location mode works (at all/way better) with wlan enabled (as it seems to be used somehow )
(I’m using opengapps)

Hi, yes it is enabled. But anyway, I would like to use my GPS even when I am outside, when I am not connected to any WLAN…
I keep looking.

this doesn’t matter… It only has to be enabled, not connected… On the other hand, there’s also “device only” (my device is set to German, hope, the translation is correct). This is supposed to really only use gps…

Ah ok I get it. My location setting is set on “High precision” using GPS, Wifi and mobile networks (mine is set in French, I hope the translation is correct too!), but it doesn’t help.
By the way I lost again my location…

On FP Open the only way for “High Accuracy” and “Device Only” to be different is if you install microg (also explained in the #gpsguide).

Hi there,

Thanks for your messages.
So after trying a few things, my GPS did work a few times (approximately 15-30 seconds after opening SatSat for example…), but a few times it was still not showing anything, especially when I am not at home - which is exactly when I need to use my GPS btw. :slight_smile:

I was also a bit desperate because my banking app, among others couldn’t work without Google Services. Then I tried to install OpenGapps Pico package, so I went back to Google…
So far my GPS seems to work again. Cra-zy. Do they really control everything?

Cra-zy. Do they really control everything?

They scan the wifi networks around you and send the MAC adresses (BSSID) to Google. Google has a large database of wifi access points and their location (this data is also collected by Android smartphones with GApps installed). They can then do triangulation and send you the coordinates back, this is handy, since it gives you an approximate GPS fix within seconds.

You don’t need to be connected to a wifi network for this to work, but you have to have wifi enabled and your device should be connected to the internet (e.g. mobile data). Since the Google database is rather closed, there are similiar open source projects that try to achieve the same goal. Take a look at the Mozilla Location Service, if you are interested.

You can also use one of the free NlpBackends for Android, or the Mozilla Location Service Nlp Backend for Android to have a similiar behaviour without Google.


I had the same problem. A friend of mine then helped me and made some additional changes to the config. He changed the nptservers as following:

#North America

He also changed the Accuracy Threshold to zero. We both think, that this did the trick and after these changes my Gps works relatively fine. Sometimes the location is a bit of and needs time to set to a constant point, but in general it works very good.

I’m using the app Fastergps. Basically, this sets the ntp server, but you also can define further options. I’m getting a fix in up to 20 seconds…

I manage to use the GPS, but I have some questions:

  1. Every time there’s an OS-update, I have to reconfigure the gps.conf with fastergps, is that right? After each update, my settings seem to disappear from fastergps. This is quite annoying, because I tend to forget to do that until the first time I have to use the GPS after the update. Especially annoying when you have to update from FPOOS 17.07.6 to FPOOS 17.08.1 and then to FPOOS within one week.
  2. Does UnifiedNlp still work for you? When I do the self-check, the box for “System supports location provider” is not checked anymore. It did before (I don’t know when I checked last, but it did once…). I only use network location, not the service core. I tried to reinstall Unified Nlp from Github directly, but no difference
  3. Why doesn’t Fairphone integrate UnifiedNlp in the Open OS? Is seems possible according to this page: “UnifiedNlp can be build as part of Android when building an Android ROM from source”.
    Thanks for the help!

Since various weeks my GPS on FP2 Open (latest update) does not work.
I tried changing the GPS settings (high accuracy, only device etc), but I cannot see any improvement.
I installed SatStat as suggested in various threads, but I do not understand how it should help me: what do I have to look for?

Any suggestion?

PS Interestingly, I notice now I wrote a very similar message on this same thread more than 6 months ago. Well, unfortunately the issue is still there.

SatStat is mainly just a visual tool showing you how many sattelites your device is connected to or is trying to connect to.
In the compass red dots should appear, get bigger and turn blue. That symbolizes the device finding satellites and connecting to them. If no dots appear or they stay red then something is wrong with your GPS connection.

Check out the #gpsguide for more info.

PS: Oh and please don’t create duplicate posts.

Keep in mind that sometimes when GPS doesn’t work this is outside of your smartphone’s control.


Though it is rare, it happens more often than commonly reported by regular media.

I did not understand because I did not get any dot in the compass. Today, for some reason, they appeared and the gps eventually worked, but it took around 15 minutes.
In order to fasten connection I tried to install fastergps, as suggested in the guide. However, when I start the app, I get an error stating that I should enable root in order to use it. My phone is rooted.

Any further suggestion?

I am happy to know that my gps is working, but 15 minutes to get the position is not very convenient.

Fairphone Open OS is prepared for root so that rooting only means a change in the Settings, but by default it is not activated there I think.
If you had it activated before, did you check it is still activated in Settings - Developer Settings - Root Access?

A few weeks ago I also had serious GPS-problems (Open OS).
Satstat and other GPS-Apps refused to work (I couldn’t get a fix). At a certain point I removed Osmand completely and reinstalled it. After that GPS works again!
I experienced that more than once. It seems to me that Osmand hast to be reinstalled regularly which seems to have a positive effect on the GPS-function of our FPs on open OS. For whatever reason…


Good find :+1: .

However, I had OsmAnd running for months on Fairphone Open OS, and now for months on LineageOS … GPS was/is fine.

I used/use OsmAnd+ from F-Droid and the Open GApps pico package of Google services, and I set GPS to High accuracy which then uses Google’s backend to enhance location finding.
Perhaps that does play a role in this … What’s your GPS setup?

I use the application sumup for payments on my FP2… or I should say “I try to use”. Sumup needs localisation and even if I turn it on it still says that there’s no access to the position. I really need thins to work!!! any ideas?