Unified NLP on Fairphone 2 Open OS

Do you still have this problem? Have you found a solution? The same happens to me (and by the way, how did you find out that the backends don’t work while online? I know Osmand can locate me but I don’t know what it is using to do so…)

Has anyone encountered this message: “microG Services Framework Proxy has stopped”? I get it almost every time I launch my weather app (Meteo Swiss). The app works, though…

@Linda_CH: This happen if you install it before “microG Services Core”, just reinstall “microG Services Framework Proxy”.

The two patches seem to be merged upstream from what I remember. So it’s not any more necessary to apply them - and therefore it’s not even necessary to recompile it.

I just tried it in a newly installed FPOSOS:

adb root
adb remount
adb shell

In the shell:

cd system/etc/permissions/
rm com.qualcomm.location.xml
cd /system/priv-app/com.qualcomm.location
rm com.qualcomm.location.apk

Then again:

adb reboot


1 Like

I installed UnifiedNlp via F-Droid today after updating Fairphone Open to version 17.08.1 – and it just works (at least with OsmAnd~).

The Self-Check in UnifiedNlp Settings still says Your system does not support this UnifiedNlp package. Either install a matching package or a compatibility Xposed module and UnifiedNlp is not listed as active location provider in Android’s location settings. But still, my current location is shown immediately after starting OsmAnd~…

Same situation with the self-check:

Have you tried changing the location mode?
When I’m in “device only” mode, I have a fix really quick with satstat, then quite fast with Osmand, but 150km away… But in less than 1 minute I have a perfect location.
When I’m in “Battery saving” mode, I get a quick location within Osmand, but 1 km away and I don’t get a better location after 5 minutes.
Something wrong!

Yes, but I have no problems (except the mentioned error message in UnifiedNlp). When I use GPS I usually get a fix in ~3-4 seconds.

In battery saving mode the device uses visible cellular networks and Wi-Fi networks to determine your location, so you won’t get a more precise location if you wait.

You can install Mozilla Stumbler to help collecting Wi-Fi networks – so you can help us all to get more precise locations in battery saving mode :wink:


Well, I wasn’t very clear… I asked if you had tried changing the location mode because I wondered if you only had tried in “high accuracy” mode, which would give you a location even if UnifiedNlp doesn’t work. Sorry that I wasn’t clear.
Anyway, I’m happy to know that I’m not the only one having the bad report in the self-check!

Mine also claims not to work, but will give me a fix any combination of GPS, mozilla and localGSM. When connected to mobile data its very accurrate even without GPS, but then I have used the Mozilla Stumblr app around by area quite a bit!

I see your patch has been merged but UnifiedNLP still complains about missing support of non-Google location providers.
Am I missing something?

Edit: it seems to work correctly. I guess that’s just a bug in the self-check.

Unfortunately this isn’t the case anymore. I’m using at least one app that will stop having access to GPS location when I disable com.qualcomm.location. Confirmed 3 times after rebooting, just to make sure it wasn’t a coincidence.

I switched to LineageOS which doesn’t include this stuff and works much better a long time ago.

Fine, but I’m inclined to believe that the Google Play Services and Google Location dependent apps that I mentioned wouldn’t run under LineageOS anyway, so this isn’t the issue. The issue is that com.qualcomm.location is necessary for some recent niche-market apps to fix a location, and I can only wonder why, maybe they use geofencing or some similar technology, the most problematic apps that I know are maybe not coincidentally tied to geographically-delimited services.

Why? Lineage OS is based on AOSP and it pass the Google CTS, AFAIK. I’m honestly curious.

For the same reasons they don’t run on the FP Open unless Open GAPPS is installed and infrastructure like Qualcomm’s one hasn’t been messed with. I’m not suggesting they won’t ever run, but that in the end it won’t be different from any other implementation with Open GAPPS and proprietary infrastructure.

You could just test them yourselves and tell me please, here are the links to three big troublemakers:


LOS 14.1 and OpenGapps pico:

Totem seems to be available only in France
Citiz works fine, but didn’t find a car at my location (Munich :-))
Happycow also works, but insists on gps


Same results here with Lineage OS and microG (Mozilla Location Services as a UnifiedNlp backend), :slight_smile: (replacing Munich with Madrid).

Offtopic: HappyCow has an amazingly wide tracking libraries counter, :frowning:, but Citiz features none, :smiley:

There’s always a chance they run with UnifiedNlp (if they need network location) or with microG (if they need other Google services and APIs).

What infrastructure? Qualcomm hardware & drivers (low-level interfaces used by the system) need to comply with Google’s CTS and therefore they work through regular, generic APIs (high-level interfaces used by apps) in Android (Fairphone OS/Open and Lineage OS). I don’t know what are you referring to, :man_shrugging:


Many thanks for testing. I wasn’t clear however, Totem is the one that crashes without Google Services. Happy Cow and Citiz run with microG or Open GAPPS. They can all have GPS fix when they don’t crash, except for Citiz: with com.qualcomm.location disabled the GPS doesn’t turn on. The real problem however is network location. With GPS turned off the three can’t get a fix when Google Location isn’t available, Totem as I said crashes, Happy Cow will nag repeatedly that GPS and Google Location should be turned on, and Citiz will spin and never get a fix.

I forgot to add that microG can make Happy Cow and Citiz think that Google Location is available but I remember being annoyed by them not always getting a lock. The reason why I dropped microG is another one, it’s because of apps that complain about outdated Google Services. Open GAPPS naturally solves all problems, except again for the need to have Qualcomm service enabled in the case of Citiz.