GPS doesn´t work on FP Open OS

Hi All
Just a little feedback.
Ok i testet several gps app’s, like osmand, sygic, oruxmaps, gps tracks… And the GPS works with OpenOS and the app’s.
I have from starting on new installation with Twrp and also xposed with using this moduls.
See picture :

Dont knew any other reason.
Have a great day!
Lg ivi

New update is live. What does this fix “Unified Location provider” mean for us?

Well, I guess it means that now location services using mobile cells and Wi-fi to get your location are supported. As they mention “Jochen”:

Unified Location provider (Thanks Jochen)

it’s very likely that they added @jochensp’s patches to integrate Unified Nlp support:

If you want to use it, you nevertheless still need to install the corresponding middleware UnifiedNlp app and a backend app:

As far as I’d understand, this is independent of GPS, so I don’t know whether GPS behaviour will change with this update.

Updated my phone and tried different backends: PlayStore crashes and my GPS still seems to be completely dead… :’(

I’m on 16.05 now, and coarse location works as well as God. TTF ca 80 seconds. Play store crashes when it can’t find the position. Learned, I cannot deny location to the store :slight_smile:

I had to restore 16.04.0 and wanted to try again. I updated OTA, but got caught in a loop initialising apps. I found a way out, thanks to @maba007 and @Spielmops :slight_smile:

  1. Updated OTA to 16.05.0 and let initialise all apps for first time
  2. Interrupted the second initialisation process by launching TWRP (pressing Off button + Volume up for some time)
  3. Wiped Dalvik Cache and Cache
  4. Flashed the Xposed Framework (as I had it already installed and it was deactivated by update)
  5. Downloaded latest OpenGAPPS installer, transferred it to phone and flashed it.
  6. Wiped Dalvik Cache and Cache again
  7. Rebooted System

Half the icons and widgets disappeared from the Home screen, but they all worked fine and all the data was still there as well.

And now the GPS works just great again, system runs smooth and the phone knows where I am! :slight_smile:

Edit and PS: Huge thanks also to @jochensp, as it seems that the GPS fix in the last update is thanks to him! Cheers pal! :slight_smile:

1 Like

Unfortunately I did not manage to get gps running.

I installed fp open os 16.05 as a fresh installation via fastboot and did not install gapps. I installed osmand and komoot to tests gps. Afterwards i installed unified with f-droid and tried some backends. I also changed the 0 to 1 in gps.conf.

Any ideas, what else i can try?

same here… there is no workaround known for this… just take a support-ticket… otherwise your GPS problem will be heavily neglected…

There are some workarounds, like changing the config file as described above.

Also support is swamped and often takes many weeks to reply so the forum is often faster to find a workaround.

The gps finally worked with 16.06.
Unfortunatelly it bricked my phone. I will give it another try in the next days.

Can you state more precisely what you mean by “finally worked”. E.g how did you come to know that it worked before it bricked?

I updated to 16.06. My OsmAnd~ is still unable to find my location in high accuracy, which means that neither the WIFI, mobile network or GPS are providing my location. SatStat shows 2 satellites and WIFI networks, though. (Will try outside of my building if I see more satellites so that GPS can get my location).
Is any of you able to find the location via WIFI or cell network? Are you only facing problems with the GPS?

I am able to acquire a signal via wifi and celltowers using UnifiedNLP (on FP Open OS 16.05). However, since GPS is not working at all, switching between “device only” and “high accuracy” seems to cause problems with last known position registered in system which leads to nonsense behaviour on high accuracy (which is in fact wifi and celltowers only for me)

Since 16.05 coarse location works for me. Osmand, satstat and a few other apps all get a location (correct one…). In 16.05 GPS did work for me (but I changed GPS.conf). Had not yet time to test gps, as in the house I can’t get a fix. Walls are too thick

Just installed 16.06. Osmand still not working with gps (I got NO openGAPPS)

With the versions 16.04 and 16.05 i had no gps.
Saturday i installed 16.06 and tested the cycling app komoot and it showed directly the correct position. After a restart of the phone i was stuck in the fairphone powered by android screen.

What I noticed and what I want you to think about:

The thread-topic contains two terms, which have not much to do with each other:


GPS is able to show your location via satellites, GAPPS via network. Both go together with the location-item “high accuracy”, but both work independent from each other.

The topic says “GPS doesn’t work”, so it would be better for solving the problem, if you all talk about “GPS” - that is “device only” in your settings and not mix both ways of location.

Set your phone to “device only”, go outside with it to a location under free sky and use eg. “Satstat” (F-droid). It will take up to 5 minutes at the first time to see satellites and you can follow the process with Satstat. If this app shows no satellites after that long time under free sky, then you can say: “GPS does definitely not work”.



Good point.

I created that topic title. At that point everybody who did have those problems with GPS used Open GAPPS.
Does GPS not work for anybody whos not using GAPPS?

:point_up_2:here! I installed microG instead of GAPPS. I got unifiedNlp working, but on ‘device only’ in the settings, there is no way I get my location

Have you been outside with your phone for 5 minutes under free sky with “device only” in the settings?