English

Fairphone Open 16.06

I may have done things in the wrong order last time - i.e. tried Threema and GravityBox before flashing xposed and OpenGAPPS. Will try again with this update, maybe that’ll do the trick then and require a bit less time. Plus - I get a little more practice with this whole smartphone thing each time, so in general it should be getting a little quicker :wink:

Hello everyone,

I updated today to 16.06. Unfortunately, I have a serious problem with this build: Normally, I have two accounts on the phone. After the installation of 16.06, I could no longer access the second account: logging in just led to a blank screen with a black background. The navigation bar just had the back button. May this be the setup wizard that is not displayed properly?
I did a complete reinstall - including one with fastboot - but the problem still exists. When I create a new secondary user (or a guest user) and I switch to it, I just get the black screen. I can log out by sending the phone into standby (just by pressing the on/out button) and then switch back to the main user. Sometimes, the navigation bar in the main user account has also the back button, but not the home and switch app button afterwards.
Have others also encountered this bug?

For me users still work fine with 16.06.
Have you made a (TWRP) backup before the update?
The only advice I have is reset (cache, data, hard reset) but without a backup your secondary user data will be lost.

1 Like

I have tried a reset (cache & data, not sure about hard reset). As for the backup, I have at least a Titanium Backup, but I should have made a TWRP one (my fault that I did not).
What does “hard reset” mean here?

It should be noted that my system was certainly not a typical configuration: Xposed was installed together with SuperSU for both users.

A hard reset erases all user data and apps and should get rid of all software issues.

Titanium is great but restoring data from user 2 will restore them to user 1 right?

Just out of curiosity: What is the benefit of SuperSU if the OS already comes with root access in the developer options?

2 Likes

You are right, I have only made a backup for one user, and I do not know how to do one for two users with Titanium. Fortunately, I am only interested in restoring the data from the backed up user.

Well, SuperSU has a bit more options than the standard SU app of the FP2: You can grant root access only for a limited period of time. Moreover, you can also give the secondary users root access (I did not figure out how to do this with the standard SU app). However, I have also realized that only one of the users really needs su rights at the moment.

A post was split to a new topic: Open OS 16.06 - Users don’t work

Hey all,

HELP !

I just did the update and now I cannot go through the setup wizard ! When I am on the “select a wifi network” and after connecting to a working network, I am stuck on a screen “Just a sec…” that allows me to click “Next” and go back to the wifi step…

I cannot use any app as all other buttons are disabled !
I can access the settings menu from the lock screen but I don’t know what to do to get rid of this wizard…

Thank you all in advance

Sounds to me like your issue has the same root cause as the bug-topic I split above. There seems to be something wrong with the Setup Wizzard.

Hi,
I have the same problems updating to FP Open OS16.06 as with 16.05. It doesn’t work.
If I want to reinstall everything, do I update with Titanium Backup or TWRP? Which is better?
Regards

TWRP is great to revert back to before s*#'t hit the fan (if you made the backup at the right time) but restoring a TWRP backup after updating will also revert the OS to the version before the update.

But that doesn’t mean it’s not a good idea. Usually the update should not delete data anywaY, but if it does you can simply go back and try again.

I confirm this bug in FP Open OS 16.06.0:
https://forum.fairphone.com/t/two-sim-cards-cant-make-receive-calls-when-both-are-turned-on-workaround-wait-5-seconds/12118?source_topic_id=19061

Thanks!

1 Like

Hi,

I finally got around to updating, unfortunately I’m now stuck in the famous optimizing app loop. I have a titanium backup pro backup, no TWRP backup.

I’ve read various solutions here on the forum from hard reset to clearing dalvik cache, but unfortunately without clear step-by-step instructions. Can someone tell me exactly what I have to do next? (i.e. how do I clear dalvik cache? I looked in TWRP, but haven’t found it there). Alternatively, if I have to do a hard reset, what happens next? How do I then get FP Open OS back onto my phone (regardless of whether 16.05 or 16.06?)

I’m sure these things have been described before, unfortunately I just can’t seem to find them in the forum. Can someone please point me in the right direction?

Thanks!
Emmy

Ok, hold on, I did finally find cache and dalvik cache in TWRP and wiped those. Trying to reboot now…

So…cache and dalvik cache wiped, then restart.
It optimizies 125 of 125 apps, then says starting apps
Then comes the Fairphone flash screen
Then grey background with “Loading…” for a while
Then it goes back to “Android is starting” and optimizing apps again

Since the phone feels pretty hot at this point and the battery is mostly drained, I’m going to turn it off and charge the battery and try again later (have to leave home now anyways…)

Any advice from people who know more about this than I do on what to do next?

When I had this problem, I did the following:

  • clear Dalvik Cache and Cache partition.
  • sideload again opengapps.org package.
  • reboot and then worked fine for me.
1 Like

I made a step by step (also using the xposed and OpenGAPPS) here:

1 Like

Thanks, I followed @leVin42’s instructions and it worked, though I also lost about two thirds of the icons as well as all but the central home screen.

No idea whether the update is better or worse in any other ways, just glad for now that my phone is working again…

1 Like

Yes, i have a lot of them. Screen Tearing and random Restarts even if i do nothing on the phone… i pick it up and it say: Pleas Enter Pin. I have also the Black Screen-Problem after Calling (so no hangup). And the Scrolljumps when i brows.

I hope FP is fixing that… but my goal is SailfishOS :slight_smile:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.