Google Apps can't be reinstalled

Hey,
I just updated to 1.8.5 and I guess everything runs like it should. After upgrading I changed the storage partition to the single partition like explained.
My problem is that i cannot download the Google Play Store and all the other google apps. When I hit the Google Installer widget it downloads for a few minutes and then reboots. But then there still are no google apps installed and the phone asks me again to install them. I did it a several times but nothing happens.
I hope someone can help me!!

Best,
Jonathan

Hi Jonathan,

We investigated the issues with the 1.8.5 storage upgrade and there is something off in the google apps installation, which prevents it from installing correctly. We temporarily halted the availability of the 1.8.5 storage upgrade.

The developers are working on a new google apps package that will hopefully be available tomorrow to resolve the issue and enable you to re-install google apps.

4 Likes

I installed the Storage Upgrade for 1.8.5 with the ADB sideload, like you mentioned. Unfortunately I’m still stuck in the gapps installation loop.

Same problem here. No Google Apps and no way to get them. Arrrgh!

Sorry for the frustrations . I hope we will fix it tomorrow asap and you can reinstall gapps.

3 Likes

Same Problem Here … I repartioned my FP 1 (first Batch) , updatet manualy (updater did not do it propaly saying cache is full) and stuck around this circle of installing gapps .
Install it via updater
Reboot
Robot
Updater say there is no gapp…

I did install manually. But the first two times were giving me errors on updates due to the cache being full no matter Ho much I cleared updater data.

Therefore I did the unified 1.8.5 updater and now going to sdcard in recovery mode just shows an empty nameless folder so manual updating is no longer possible.

Anyway, hopefully tomorrow’s update will work.

1 Like

I have the same problem:
The loop after installing the Google Apps.
The Fairphone team is working for a fix for that problem.

Question to everybody “in the loop”:
Did you all do a manual update after the updater app failed?

It’s really frustrating…
I did also the manual update with repartitioning like here: https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Kola-Nut-1-8-5

And now I’m in the “Google Apps Loop”…

I hope the update will be there as soon as possible…

I did at first, but after I installed the Storage Update I tried the 1.8.5 update from within the “Fairphone Upgrader” again, but still had no luck with gapps

@paulakreuzer: Yes, I did the manual update because the update in the Fairphone app failed.

@paulakreuzer @Marco Is there no quick fix for this problem? Isn’t it possible to install the Google Apps manually?
Because of that I can’t use my phone until I have reinstalled the GAPPS.

The problem is, the SD card isn’t mounted correct in the recovery tool, so the installation is only possible over ADB on my phone. I can’t access the phone storage.

I tried to reinstall the update via ADB, but I get the following error:
“Error: Invalid partition setting
15: ebr2 3d80000:3d00000
Installation aborted.”

hi Paul, I did a manual update from 1.5 to 1.8.5, because for the updater app hasn’t been working at all for quite a while (I didn’t get round to updating to 1.6 straightaway, and when I wanted to, 1.8 had just been announced and then pulled again…).
Hopefully tomorrow’s fix will get us unlooped!

POST SHOULD BE IGNORED FOR NOW, SEE POST 83

Ok. Lets think this through.

After a ‘normal’ installation of a new ROM one can install the gapps manually through recovery.

This depends on the android version of android. FP 1.8.5 is based on Android JB Version 4.2.2 / Kernel 3.4.5.

This means we need Google Apps 20130812 for Android 4.2.2 (looking for url, wait a moment).

  • Download file
  • put gapps zip on your external SD
  • boot into recovery
  • install from sd
  • select gapps.zip
  • sit back and wait for the install

Hmm seems Unified isnt completely installed. 3e recovery still can’t mount sd.
Putting the gapps on intermal sd doesn’t work either.
smaller size sd doesnt help
formating sd as etx4 doesnt help
sideloading doesnt work due to missing scatter file in gapps (logical, its an update, not a rom image)

hmmmm, trying the flash route described by @Kephson next…

1 Like

Hi rick,

yes, I’ve tried this thing already on the week-end. But doesn’t work for me.

The Fairphone Updater App tells me I’m on 1.8.5, by upgrading from 1.6 by only(!) running the “1.8.5 Storage Upgrader”. Is it true that it includes a full 1.8.5 system as well, since the Upgrade process page told me on Saturday that I have to install the 1.8.5 system afterwards (which doesn’t work, due to the described problems).

Since you linked to adb sideload I can also quickly explain “due to the described problems”: No system upgrade currently works for me, because adb sideload works just fine, but the installation afterwards does not any more: The scrollbar fades away after approx. 25% installation process, the Android appears to continue its installation process and tells after some time “Failed.” - nothing else, and the installation process is aborted by then. A reboot will load the 1.8.5 system as before (as if nothing happened).

Best regards, Alexander.

@daveboschma I tried this as well. I tried to install it via adb sideload, but had no luck

Hopefully there will be a fix to this by tomorrow. Really need gapps.

For the record, tonight I tried to go back to Cherry 1.6 via the Installer to see if I could install gapps then, but after rebooting I’m still in 1.8.5, or so the Installer says. I’m staying well clear from adb, that’s out of my league…

Ok, I could fix the problem with flashing of the Fairphone binaries via SP Flash Tool, see here:
http://forum.xda-developers.com/wiki/Fairphone_Fairphone/Guides#How_to_restore_Fairphone_if_you_totally_bricked_it

For this I needed a lot of time to find all tools and drivers for download. If somebody needs all the files, please contact me with a personal message so I can send you a download-file with all needed drivers and tools.

I used Windows 8 to flash the binaries. After flashing I could install the Google Apps and now I’m installing all my apps and restoring the data…

Please note: I did the manual update before with formatting the phone to get the new storages. After that I couldn’t reinstall the Google Apps.

1 Like