New software update Kola Nut 1.8.5 is ready

same problem here. cant send text messages anymore since all google apps are out of order. im really looking forward to some kind of help here! :smiley:

Hi Paul, so I haven’t done anything else since you advised against it - however I now found that my Playstore has disappeared and I can’t seem to reinstall Google apps. Other apps do seem to be working but not having the Playstore is inconvenient.

I have tried step 1 of these suggestions, not 2 as am reluctant to do lots of inconvenient things now if there may be an easier solution later (hopefully!). The widget is greyed out and does seem to do ‘something’ when I click it, however it hasn’t brought the Playstore back.

Like someone else said, I bought the Fairphone because I wanted a fair product but did not realise I’d have to dive into all this software stuff… Really hope the team come up with a solution where the effort/knowledge required on our part is minimal. Thanks everyone who’s trying to help!

I haven’t done anything else since you advised against it - however I now found that my Playstore has disappeared and I can’t seem to reinstall Google apps.

What have you done so far, from your last post I assumed you haven’t started the update process yet, but if you are missing your GAPPS then you obviously did

Has anyone had further success with this issue?
Via trying to install the update, my google apps were already deleted. But since, for whatever reason, I do not have enough storage space on my FP, I can not continue.
I would rather not install the update manually…

Hey all,

Just a quick update; we are working on a solution for the problems with reinstalling Google Apps and the Storage upgrader in 1.8.5.

As soon as we have an update (which will be later today) we’ll immediately post it here. Thanks for your patience in the meantime…!


My problem is fixed since yesterday night :grinning:, see my post here:

If somebody needs a detailed description how flash the Fairphone with SP Flash tool, write me a private message.
Please note, that all data will be removed with this step, so make sure you have a backup.
If somebody wants to flash the phone, write me a detailed description, which steps you did and whats going wrong.

After the flashing you can install the Google Apps and restore your backups. Then you can use the Fairphone Updater and all should be like the Fairphone Team it planned.

The first step of the update worked, now opening the fairphone updates says that I’m currently on version 1.6 and taht 1.8.5 is available. However after downloadig the update it says “No space available on /cache”, wehn I press RESTART it says “File not found: /cache/”.

I’ve completely emptied /cache, the partition has a size of 123MB. Any idea how to get around this? Or the easiest way to resize partitions?

Some people have this problem (mostly those without the official storage upgrade).
The Fairphone Team is working on a fix.
There are some workarounds posted here but I’d suggest to wait for the solution because most people who continued updating after this error are now stuck without Google Apps. (unless you don’t need/want them anyway, then you can do a manual update.)

I suggest to wait for the official update, too :wink:

1 Like

Hi Fairphoners,

Our software team is working hard on narrowing down the issue with the Storage Upgrader 1.8.5. We can’t give a clear outlook on a fix yet but I assure you it will be soon. After we got aware of the issue we immediately took the Storage Upgrader offline.

Please note: the “normal” Kola Nut 1.8.5 is working as it should (for both FP1 old storage layout and FP1 with already upgraded partition layout - and FP1U devices), so you can safely update. Only for users who want to unify their storage with a Storage Upgrader need to wait a bit longer.

For users who already performed the Storage Upgrade and are now stuck with Google Apps that won’t install; we will offer a solution for you.

Sorry for the inconvenience!


Hi Rick,

@paulakreuzer recommended to wait as I might be stuck without google apps. But actually at the current stage I am without play store and without gmail.

What I did:

  1. more than 1 year ago: followed some post toincrease the phone storage, this was before fairphone realized that 1GB is not plenty of space for all users
  2. yesterday: happily clicked on install update, it told me that it needs to restart and that I should start the updater again after the reboot
  3. today: noticed that the second update fails because of lac of space in /cache
  4. noticed that the play store and gmail aren’t there anymore (google maps still works)
  5. added the google apps install-widget, clicking on it to reinstall, this opens the fairphone updater, which brings me back to step 3.

As I did not use the Storage Upgrader (but something else, following a description in the old forum) I hope the update will fix this situation too.



If you unofficially repartitioned your first edition FP1 yourself in the past, I’m afraid you will keep on having issues. Read more here how to solve this: New software update Kola Nut 1.8.5 is ready


Hi rick,

“keep on having issues” is a bit frustrating. I hoped to read a better solution.

I’m absoluteley not a techie.
I started yesterday with the upgrade and immediately after that reading on the forum.

I was in version 1.8 after having repartitioned myself.
The upgrade with the fairfone updater didn’t work so I upgraded manually with to the version with ‘unified’ filestorage.

Now i’m in 1.8.5 but i’m stuck in the GApps loop.

As the downgrading to 1.6 and then upgrading to the new 1.8.5 seems to work, i would like to perform this.

I downloaded the 1.6 updater. But i can’t get it working. When i try to install it manually from SD-card in recoverymode the phone doesn’t recognize any folder on the sd-card.
Someone help?


Yeah, it sounds like we’ll have to do some jiggery pokery to factory reset. I don’t know, sounds like I’ll need to buy a new phone as I don’t have the time or energy to do this.

1 Like

is it necessary to install “all” google apps with the Google Updater Widget or can i just download the play store and then download myself the apps I want to have (whatsapp, maps etc)? Can I sync my google contact list with my fairphone without having the google apps?


Dear all,

I know there are a lot of posts in this thread as well as in the update 1.8.5 thread.
I spend last evening finding a workable solution. There is only one solution (for now): manual downgrade using the ‘bricked’ procedure. I described in detail in reply #82 - Google Apps can’t be reinstalled - what you can do to get out of the gapps update loop.

If you feel uncomfortable with the flasher software, then wait for an official repackage of v1.8.5.
If you don’t mind installing some extra software and are willing to go the flasher/bricked option, see reply 82.

In short the procedure is: flash 1.6 unified using SP flasher -> update to 1.8.5 using FP update -> install gapps using FP update -> done!

Don’t try to install any other version through the recovery mode, it won’t help you since there is no way to install gapps afterwards reliably (e.g. through recovery). The recovery in FP1 isn’t good enough. We need a reliable ClockWorkMod Recovery or similar for FP1 but there isn’t one.

@Kephson has a slightly faster method, but then he (or someone else) needs to publish a ‘scatter’-file for the V1.8.5 image for FP1.

On the bright side: if you go the flasher route, you will automatically have a FP1 with Unified storage. (in other words: 1 big storage disk).

Caution once again: BACKUP! and use this method only if your stuck in the loop and feel comfortable with flashing.


@MDP @TheoGB see post Google Apps can't be reinstalled and Google Apps can't be reinstalled.

Based on the technical skills needed of what you already tried you should be fine going the flasher-route.

@JonathanSchreiber yes, unfortunately google apps is a one package solution… there are a couple of google apps that need to be installed as an android upgrade instead of just installing it as you would with normal apps.

Thanks for your work and investigation in this problem.

For myself I would feel comfortable enough to go the flasher way. But I’d like to get some update from @anon12454812 and @Marco on this topic, when we can expect a fix!

I there any update of you progress?

A “we are not ready today, but we guess we will have something by friday” would be at least something :wink:

1 Like

@SHuber Since you are where you are (in the gapps loop or you did a manual upgrade or you used the Meteos repartition), you will probably need an unbrick procedure anyway.

If there is an option to fix the gapps installer for the stuck-peoplem that would fix most of the problems… but I am unaware of such an easy fix.

The only other option I can see FP (@anon12454812 or @Marco) providing that would work is a ClockWorkMod port for FP1 or similar (so we can use Recovery to get out). Since the cache partition isn’t big enough for a new update and some of us have already repartioned again while going to 1.8.5 they (FP) are out of easy options.

A worst case scenario would be a ‘bare minimal’ version (under 120mb) so the cache partition becomes an option. Then repartion once again and then back to 1.8.5 as planned.