Google Apps can't be reinstalled

The supplied File Explorer can’t access that area, so far as I can see. It’s hard to know what the cause is and hard to Google results around it.

Okay, you can certainly see a lot more with Simple Explorer but you can’t tell where the Recovery thing might be viewing so I can’t work out where to copy the 1.8.5 OTA zip, assuming that might even resolve the problem, tbh.

I have the same problem.

Manually updated to 1.8.5 after the update via the fairphone update app didn’t worked.

Now I am in an unsucessful loop for install the GAPPS.

Is there a way to get the old fairphone update app back or is there a way to manually install the app store?

I really don’t want to care about my smartphones software - I just want to use it…

I have the exact same problem as ibes and TheoGB - Please provide a fix or workaround asap.

I will try to install it manually:

As far as I understand - also the newest app store version is compatible with the fairphone.

__ edit __

Ok - don’t seem to work.

And guess the google play store is not the same as the “google apps” - right?!

For the users who are having this issue; if you open up the Fairphone Updater app on you device, you see Kola Nut 1.8.5 as the current version installed?

Yes - I do - after manually update to 1.8.5
the update through the update-app didn’t work.

1 Like

I am on 1.8.5 on the device, yes.

Okay. Clear the Cache Data of the Fairphone Updater app (settings -> apps), close all apps in the background after that -> open the Updater app again and go to Advanced Mode -> Google apps. While downloading keep the screen active this time (just keep tapping it every few seconds), should hopefully solve the issue.

Besides, you all have the storage upgrader installed already? or you using the old partition layout?

I installed the 1.8.5 Storage Updater version. Prior to storage updater the Recovery mode let me view he partition where you could drop zips to check out.

@ibes could it be that that Google Play APK is too late a version for what we’re running in Fairphone? There are a bunch of older ones here

I use the FP1 and manually upgraded to 1.8.5 and don’t have the storage upgrader installed, but repartitioned with another method from XDA forum. I have no luck as well to reinstall GAPPS and get stuck in the loop.

Tried already to keep my screen active while installing GAPPS but it didn’t help

Than that is causing the issue, read my comment here: New software update Kola Nut 1.8.5 is ready

1.8.5 is installed and the partition is unified. I just went trough all the steps mentioned (clear cache of the updater, close all apps, open the updater and update through advanced -> google apps, kept the screen active and restarted) When the phone restarted it still said to reinstall g apps.

1 Like

manually updated to 1.8.5 with the unifier .zip

I unified through the updater app straight after I did the update (I had been delaying it because I didn’t want to bother setting my device up again, but seeing how my I had to do this after this update I decided to go through with the unification process.)

Do you need to have the Android Development Tools available on your PC to use the ADB sideload option?

Because frankly £288 for an Xperia Z3 Compact is probably worth less than the time I don’t have to faff around with that. Especially if it’s likely to be the same situation.

Is there an external tool that can reset the phone or is this the ADB stuff?

You can try to install Fairphone OS 1.8.5 manually.

Tried to install 1.6 to see if this helps.
Didn’t worked…