Signature verification failed

Hi Nitram, this sounds exactly like the problem, tomorrow we hope to release a fix! :sweat:

Hi Marco,

good to hear, but the problem is, that I cannot install just anything from the Recovery console any more. I have described this behaviour in my postings before.

Also, please post where the Recovery console looks for its /sdcard folder. What is it, physically, and in which folder does it look, and if this is somewhat linked to (or from), from where to where would there usually be a link? I have written before that I have used adb sideload to circumvince the non-presence of /sdcard with the result explained before.


@Amber I tried also to update via ADB but this fails and the recovery tool doesn’t find the SD card or the internal phone storage…

Hi Marco, to be honest I do not know if I upgraded to the storage upgrade. I turned on wi-fi and my phone prompted me to update, I just tapped the notification and tapped “next” a lot (I don’t remember the process to the letter).
As far as I can tell I can install Google Apps. This may not be the problem. However, Google Store is not available - I can tell because when I go to settings by moving the finger from far left or far right to the right or left, respectively, and select the six dots, the “Play” symbol on top right is not there anymore. Whether this means Google Apps is not installed I do not know. During the last few hours I have installed the Google Apps multiple times - it downloads, installs, restarts, the android robot shows up, after some time black screen, then blue fairphone screen and then the phone seemingly works, except for the except for the ASOP keyboard not working message.

Hi, I’ve the same Problem like "fdblvw"
I downloaded the files from and there is the Storage_Upgrader still online, which causes the Problems…
Perhaps you will take it away…

I first installed the Storage Uprader and rebooted then.
Now I cant access any storages in the system recovery, not even my backup :frowning:

Tried with ADB to install the Storage_Upgrader / FP1_KolaNut_v1_8_5_OTA doesent work with the following error:
Invalid Partition setting
15:ebr2 3d80000:3d00000

Additionally, I have to say that I had installed CyanogenMod from chrmhoffman, but it doesn’t worked well and I installed the Original FP-OS again.

Hope that there is any solution soon :blush: thanks for your great work.

If I go to the Data Manager in the OS, and select the OS-Installation file, it’s opening it in the FP-Updater. It looks good until it reboots and the message pops up: is not correct
Perhaps this helps

Hi there!
I’m having the same troubles with the 1.8.5 storage upgrade. I tried downgrading, reinstalling manually and via the FP updater - none of that worked out…
I alway get the “signature verification failed” notice
Or when I try to Upgrade manually the SD Card isn’t detected at all.

So does anybody know when a new google apps package will be available?
Or is there any other solution to this bug?

Thanks for the good work, looking forward for some news on this!

Please see in the topic, there is a solution with the SP Flash tool:

1 Like

Works like a charm, used the scatter file to Downgrade to 1.6 and then updated automatically to 1.8.5


The problem is I can’t install anything because the SD Card can’t be found.

One day or other all the people will have a working phone again ;-), I believe

Storage Upgrade is available again, so try doing this: first, download Storage Upgrade from Fairphone Updater. Then follow the instructions and restart your phone. This time update should be successful (not aborted installation or whatever). Finally, download GApps and restore your data with, for instance, Titanium Backup (you should have made a backup before all this :wink: ).

I hope this is useful for you!

Was the fix released? I tried several times to reinstall GAPPS, but after installing and restarting I still get the keyboard not working message.

This was the last official note from the Fairphone Team:

Does everything else but the keyboard work? Especially Google Apps?

If so try this:

In case you run into the problem of Android displaying the error “Unfortunately, Android keyboard (AOSP) has stopped“, thus robbing you the possibility to enter text in any form (short messages, emails, URLs in browser, etc.), simply follow these steps to get rid of it:

  1. Open up the menu
  1. navigate to Settings
  2. open Apps
  3. open option All
  4. find app Android keyboard (AOSP)
  5. choose option Clear data
  6. find app Dictionary Provider
  7. again choose option Clear data

In Google Apps can’t be reinstalled I have posted how I could solve this problem for me using the new Storage Upgrader and the Fairphone OS 1.8.5 for unified partition together with the tool ADB available for both Windows and Linux from Google Developer tools. Of course I cannot guarantee that it is working same way for you as it was for me, so I cannot guarantee anything. If you use my guide then you do at your own risk!

1 Like

I am quite sure I just updated to 1.8.7. But same problem with the same error message. You wrote there would be a new update by tomorrow, that was month ago … ?

Marco was talking about the hotfix for the storage upgrader which was released on may 27th.

As you didn’t post here before could you please tell us what the error message says.
Also if you are not sure if update to 1.8.7 worked open the updater app again. It will tell you your current operating system. If you are not on 1.8.7 go to settings > developer options, tick “stay awake”, plug in your phone and try updating again.

PS: Someone else just confirmed that the storage upgrade fix works with 1.8.7 too, so do that if you didn’t already.

Sorry, I thought my post would come up as reply under the one where I pressed “reply” …

I updated to 1.8.7, first with the updater, than again several times manually, whiping data factory reset bevore I did so. The updater app, tells me I am on 1.8.7. and wants to reinstall google apps. than restart lead to

I try going back to 1.6 know, and than try to deinstall the updater app, so it stopps telling me there is an update that does not work.
To be fair, I have to add, that I changed the storage layout earlier, and now have about 7GB Internal and 7GB Phone Storage. (I also would like to keep it that way. I don’t like the to have all the storage in the phone as internal storage, because I guess, that all app data will then be stored on the sd card, and if i take that out, all apps stop working. )

It’s your decision and I don’t know of an official way to get back from the unofficial storage layout, but let me assure you that app data is stored on the internal storage and not on the SD card. In fact there is an option (settings > developer options) called “protect SD card” that makes sure apps need to ask permission to even read the SD card. The only app I have that stores data on my SD card is Titanium Backup, which has root access.

1 Like