New software update Kola Nut 1.8.5 is ready

@daveboschma & @keesj I would just like to remind: I and others have not played around with partitions and still we’re stuck as we’re unable to flash any OS after installing only Storage Upgrader manually according to official fairphone manual install site coming from 1.6 old partition layout. I hope that this can be fixed otherwise we’re quite lost although we have tried to follow as close as documented the official Fairphone install recommendations.

Kees, the issue here is that the Recovery Console does not see the /sdcard storage any more and therefore cannot install any OS (or whatever) sent to both internal or external storage.

@Amber I am painfully aware that you followed the official route and still got stuck.

@keesj Thanks for you’re quick reply, will try the MTP-mode in future.

Hello Amber,

We have identified the problem(recovery not being flashed) and fixed it on a soon to be released partition upgrader. We are now working on a fix for the current users who already did the upgrade.


Thankfully the Updater App came back - this time it all went through fine and it updated along with Google apps.

Thank you


Hi all,

Our software team fixed the issue and the Storage Upgrader 1.8.5 is back online - through the Fairphone Updater app and as a manual download.

For the users that are affected by the issue introduced in the previous Storage Upgrader; we are still working on solution for you.



1 Like

@daveboschma , when I connect the FP to my pc, I also only see my external SD-card and not internal storage anymore. I did before I ran the manual storage updater.
On the phone itself I see both.

Hi @megalies,

try the following:
When you connect your phone with a USB cable, you’ll get a notification saying “connected as XXX device” Pull down the notification bar, tap the message “connected as XXX device, touch for other USB options” and you’ll see a menu. Choose “Media device (MTP)”

If you’re on Windows (7 or 8), your phone should show up immediately as FP1. If you use Mac, see here: . If you’re on Linux, see FP, Linux and MTP file transfer for various solutions.


I had the same issue, no more internal storage visible on my PC, when connecting my Fairphone.
Thanks to your solution I got it back.

Thank you.

1 Like


I have successfully update from 1.6 to 1.8.5, everything went well, but since the update, my phone keeps looking if there are new updates. How do I stop that ?

Thank you

Excellent, that works. Thanks @kgha.

1 Like

I have “played” with the partitions of my FP1 and so I’m not able to install the latest software update because of the “cache too small” problem.
So after reading lots of advices in a bunch of forums, I decided to follow jopi79’s and daveboschma’s instructions. But I have screwed it… totally.
I downloaded the “storage 1.8.5” and installed it from internal SD, wiped cache and data and rebooted. Since then my phone only shows the blue screen with no text. After a while “loading” is displayed, screen goes black and blue again. Nothing else happens. It seems to continuosly reboot…
Any idea how I could fix it? Is there a chance to bring it back to live or is it broken?

1 Like

What is storage 1.8.5? is this the storage upgrader? If this is the case most likely the second stage formatting is failing and this results in a reboot loop.

Can you still enter recovery by pressing volume up + power ?

Hi Paul,

I have the same problem mentioned here (not enough cache space, Update not finishing and Google Apps missing). I know you mentioned there would be a solution soon but that was three days ago so I’m wondering if there is a new solution yet that I have missed or if I should continue to wait.

Apologies if this is repetitive of 100 other people’s posts and questions but I just thought I’d check in directly to be on the safe side. Thanks in advance.


Yesterday the Fairphone team fixed the Storage Ugrade and re-released it but people, like you, that allready have theese problems have to wait a bit longer.

For the record I’m not a Fairphone employee. As a moderator I’m part of the forum community like you, so I don’t know more than what the FP team posts on the forum.


Did you also choose to perform the “storage upgrader” or did you just follow the normal release cycle? How do you know you have a “not enough cache” problem?

I’m too tired of this update. I don’t really know what updates I made. The updater app says I got 1.8.5 and I can’t install the gapps. My storage is only one, but this is only from the last update.
Can anyone tell me if fairphone is working to find out a solution for this?
I need the gapps for my job.

1 Like

Did you try to update/install any app from the Play Store? This should reset your connection to GCM.

Since you state that it stopped working. Did you try to set the music on the SD card as ringtone again after the update? I imagine this has to be done so the Fairphone can link the ringtones.

Did you try to clear the cache of the Fairphone Updater? If not, go to Settings > Apps > All > Fairphone Updater and press “Empty cache” and/or “Erase Data”. Does this help?

I tried empty cache it doesn’t change anything. I didn’t try “erase data” because I’m afraid of what it’ll do. Will I need to update again if I press “erase data” ?
Tanks a lot for your answer