From LineageOS 18.1 to Fairphone OS

Good morning everyone!
it’s my first post so be patient if I’m wrong, it’s all in good faith!

As the title suggests, I’m trying to revert to the original Fairphone ROM (for Fairphone 3+) after using LineageOS 18.1 for a year or so.

I found this guide ([https://support.fairphone.com/hc/en-us/articles/360048148532]) very well done but I have an error. Obviously I have already done the steps of the first part.
I’m on windows.

At the moment of launching the executable “FP3_flashall.exe”, after choosing “1” to delete all the data the program does not go ahead because “there is no devices attached”.

First

I try to go to recovery (Recovery mode is from LineageOS) and enable ADB (I had already unlocked it from the settings). The unlock (if I launch the command “adb devices” the phone is seen) and I re-issue the command.
The executable starts, sees the devices and restarts it in bootloader but stops here:

“press any key to continue …”

Well, then don’t continue, otherwise I wouldn’t be here :slight_smile: … what can I do?

This is where it crashes on the second attempt
Second

Hi and welcome to the community. Might be you need to install the fastboot driver.To do this: ensure your device is in fastboot mode and connect it to your PC. Go to Windows update. Manually search for updates (even if autmotically done an hour ago). go to additional updates and then driver and install whatever comes up with google/bootloader…

3 Likes

Hello and thanks for the quick reply!

I noticed from the bootloader that there is no version for the bootloader on the device, could this be the reason? (sorry for the image quality but I have no other way)

Since windows update fails to download any files automatically. Is there any .inf files that I can download?

This may be of interest in downloading extra drivers.

1 Like

Thanks everyone for the support but I finally solved it using another route!
Being a Driver problem I wanted to try Linux and it worked!

To be precise (maybe it is useful to another user) I did the procedure from EndevourOS (an Arck distribution). The package to install via paru (instead of apt-get apt and apt-get mtp-tools) is:

paru -S android-sdk-platform-tools

Then simply follow the guide from step 5!
https://support.fairphone.com/hc/en-us/articles/360048660371-Install-Fairphone-OS-on-FP3-FP3-Linux-Ubuntu-

For the moment everything seems to be working perfectly! Thanks again for the support!

4 Likes