FP4 stuck on B.079

My Fairphone 4 is on the B.079 build. It says that the system is up to date when I manually check for updates (settings/system/Sytem update) even though it seems like B.086 and B.089 have been released. I tried on cellular, wifi, while charging (>90% battery) or unplugged.

Is it normal or is there a way to force the update in some way?

1 Like

Same issue. I’m stuck on B.086 even though B.089 is out. I’ve contacted support last night and waiting for a response

What are your providers ? This is a crucial information since the update needs the agreement of the provider before its release to its clients.


Sometimes updates are delayed with some networks (here’s a recent example). Perhaps that’s the case here.

I guess your Support request included your network/carrier? If it didn’t, you can still add information to your request, Support usually only works Mo-Fr anyway.


What happens with people using multiple sim cards?

I don’t know but I can imagine two behaviours :

  • Only the SIM 1 counts.
  • If one of the two networks don’t validate the update, you have to wait.
1 Like

That’s weird :wink: I’d think that if one of the two networks validates the update, you’ll get it :wink: (the networks don’t talk to one another)

Then you could have problems with the other SIM card…

The networks don’t need to talk to each other. It would be enough to implement a rule in Android indicating that an update is offered if and only if validated by the two networks.

But anyway it is just speculation on my side.

1 Like

I removed the sim card and still my phone tells me that there are no updates available…

As already stated updates are sometimes delayed for certain operators.
If you indicate your country and operator we can maybe compare your experience with those of others.
As a rule I would advise against trying to force the update, unless advised to do so by official support.

Ah! I didn’t think about that. I’m on Voo (which uses the Orange network) in Belgium. but I bought the Fairphone directly from Fairphone, not through my carrier.

I see. I’m on Aldi Talk/O2 network in Germany. Still filed a support ticket, so let’s see how it goes

Drillisch O2 got the update… So not an O2 issue in general

1 Like

Support asked me to use another SIM to update.
I had a spare O2 SIM lying around that I use sometimes in my mobile hotspot. I inserted it and checked for updates again. It worked!
What’s confusing to me is that my Aldi Talk sim and my O2 Sim both use the same operator but still only one of them gave me an update


Thats weird indeed, how old is the SIM card?

Both are almost 2 years old.

Not that old… If this happens again I would try to replace the Aldi Talk one probably…maybe just some strange hiccup

Good to know!
I don’t have access to any other SIM card. I tried to remove the SIM and to perform a network settings reset but no luck.

I’ll contact the support then.

1 Like

Yes, please do and keep us updated!

I’m also stuck on B.079 :cry:
Provider is “Yesss”, using the “A1” network, Austria.
So many security issues not fixed :frowning:
The Samsung phone of my wife gets updates every month.
I cannot imagine, that the service provider is the reason to not getting updates.

1 Like