FP4 Root Access is possible, maybe a bit risky

That’s strange, you shouldn’t have to mess with the slots at all :thinking:

Did you always have issues with OTA updates?

I do not remember anymore the details exactly. It was just once on “initial root”. Maybe I also tried a different method than the current one, butmaybe not :wink:
The OTA process never worked for me. For sure, I can help me booting a patched image via fastboot, but that is not so comfortable than using your described approach.

Personally I would have probably performed a fresh install when the initial problems occured or after the first failed OTA, something feels off.
But I fully understand not wanting to waste time setting everything up again, it’s also a great way to test your backup strategy though :smirk:

If you ever have to perform a clean install or switch to a different ROM let me know if the OTA updates start working :slightly_smiling_face:

Haha - test backup strategy… I do this a lot of times during my work, but in private life I am always afraid…
Now, I remember - I’ve tried to use alternative OS (e.g Lineage or similar) and then returned to FOS.
Sure, I will let you know! BTW - fresh install means basicly doing a complete factroy reset? Or should I do sth else?

Yeah, I totally get it. I can’t keep myself from messing with devices so I can get it running again in maybe half an hour (backups remote and on SD helps), but it’s still always a hassle, too many things that can’t be properly automated.

Fresh install means flashing factory images (or some other ROM), a factory reset doesn’t restore (potentially damaged) partitions.

For me from the first OTA on the procedure with trying to keep Magisk did not work at all. So I started recovering the orginal boot image, run the OTA, reboot and root the FP4 from scratch. BTW, probably I am the FPOS case @hirnsushi mentioned before :wink: