FP4 Root Access is possible, maybe a bit risky

Thank you for moving and your quick response! Yes, I tried with B.086 as B.089 does not seem to be available for me and I could not find it anywhere else to download. I also read through this thread, but several suggestions (e.g., “boot first only, do not flash” or “check boot slot”) did not help. Before I have to wipe my data and go back to B.079, I just wonder whether this can be fixed.

Hi. I solved the issue that I created myself. After reboot, I installed the latest Magisk (26.3), although Magisk 26.1 was already installed, but hidden. This new Magisk did not show that the boot.img was patched. By chance, I just spotted that my hidden Magisk app is back and after opening it, it requested to perform additional steps. (You may know what I mean.) After this, the phone was rooted again successfully.


I was trying to root my phone, but I am currently in a bootloop.

I followed the steps described by hirnsushi in post #43.

I used the boot.img B.069 even if there were more recent releases because it has been 4 months since I last updated my OS,
and the method described to know my Build number didn’t help me.

I entered this boot.img in Magisk
I transferd the patched boot.img on my PC
I rebooted to fastboot,
booted with the patched boot.img (without flashing it)
Waited for the device to boot (took a bit longer)
Opened Magisk (did not get the Additional Setup ask), chose direct install and rebooted.

Got in a bootloop : after 2 or 3 loops (fairphone image > unlocked warning, no /e/ image, back to Fairphone image) I land on recovery page (try again/factory reset, or back arrow that sends me to the page where I can choose between reboot, update, factory reset or advanced, where I can enter fastboot/booloader/recovery/etc

I tried to change slot but it did not help.

I need to root my phone in order to image all my data, hidden somewhere after a factory reset not wanted (nor consented by me) but that’s another problem I’ll see later.
First I need to get out of that bootloop.
Can somebody help me please ?

Welcome to the community :wave:

I’m not sure I follow you, are you running /e/OS? :thinking:
If that’s the case you shouldn’t be using any of the stock FPOS boot.imgs.

If the data was on this phone rooting won’t help you, after a factory reset that’s gone for good.

Thank you fro welcoming me

Oh… okay. I am let’s say a bit lost, so I’m trying everything I can…
My intention was to try a tool like diskdigger but it needs to work on a rooted phone.
Now I end with a bootloop so I try to come back to previous state…

Yes I am running /e/OS. I did not understand I could not use those boot.img sorry…

I’m afraid you won’t have much luck with disk digger, since newer versions of android enforce encryption for userdata and you don’t have access to the decryption key after a factory reset. So any data you could recover using such a tool would be nothing but an encrypted mess without that key…

1 Like

Okay, this is what I am discovering reading more and more about it.

I wanted to try this method (on stackexchange) that requires root, that is why I was trying to root my FP4 - But now I am more and more afraid the encryption won’t be decryptable…

Yeah, as @AndreasChris already said, that won’t help you.

Even if you could get at that encrypted data, without the keys you won’t be able to decrypt anything, and those are stored in the keystore and get recreated on a factory reset (not that you would be able extract the keys without the reset either).
Basically if you can’t boot into Android userland you are out of luck, accessing anything from before a reset, that’s completely out of the question.

That data is gone, sorry.

Wow. Okay.
UserLAnd ? Well I am ready to try anything… before saying bye to a hundred of gigas of photos and work in Signal app. That’s pretty much all, but everything to me.

Well if you have a solution to get me out of that bootloop without doing another factory reset, it would already be great.

But if you judge it irrelevant for that topic, you can delete my posts. Thank you for your answers.

We might be able to get you out of the bootloop somehow, but if a factory reset has already been performed and assuming it worked as it should’ve, we won’t be able to recover that decryption key. There were some recovery games you could play, back when decryption keys of phones were usually stored in flash memory, but with newer devices equipped with some kind of TPM (aka dedicated crypto and key-store hardware), that became basically impossible. Performing another factory doesn’t make much of a difference at that point.

Signal does have a backup functionality that can be set up. If you have copied the backup file at some point and still have the passphrase for that, you can at least restore your messages up to that point, but otherwise I’m sorry for your loss. Unfortunately it’s those kind of stories that make me take regularly backing up my data seriously… :frowning:

Ah sorry, by that I mean a fully booted system, but there’s nothing to try here.

You could flash a stock /e/ boot.img to get out of the loop, but that will just get you back to the state after the factory reset, there’s no way to restore your data from before.

The only way forward is a fresh install, sorry.

Yes I know… And as I don’t store my data online (cloud) I am pretty careful about backups.
But of course this is when my phone became too full to keep up with huge Signal backups.
So I “just” lost a month of data, but of course it was the most important and the densest.
First I was pretty relaxed because I was sure I had a desktop version of Signal, but I don’t know how, I discovered it was disconnected 2 months earlier.
As Signal don’t keep any backup of data elsewhere (this is what we ask for), I know that it is only stored on my phone memory.

And most precious part was in “24h before erased” stories so I can’t ask recipients to help me. I saved all on “notes for myself” which is what I wanted to get back, not with a Signal backup but with what was shown directly in the app.

Anyway. I am mourning over right now. Because I know it is out of my reach and abilities.
Thank you both for your explanations :pray:


Okay, I will try that thank you.

I wouldn’t, there’s nothing to gain from a fixed bootloop.

A fresh install is the better route, won’t bring back your data either, but at least there’s less of a chance of breakage later. A system brought back from a failed stated has always a greater probability of failing again for reasons that might not be apparent at this point.

You are right. I gave up. Doing a factory reset right now (at least I believe as my screen is broken in the bottom-left corner. Something is written but does not change since a few minuts
“[?]a. . .
[?]ta. . .
[?]adata. . .
after I touched Fomat data/factory reset and confirmed after the warning)

Okay I could see the log :

“Wiping data…
Formatting /data…
Formatting /metadata…
Data wipe complete.”

I had to format several times to be able to see the log, and following times the log said something like “metadata/ota no such file or directory” I hope it won’t create problems. But it doesn’t seem to.
I could boot normally and landed on setup page of /e/.

Now battery is low so I am loading it before seeing if everything went as it was supposed.

Thank you again for your support.

I’ve tried this approach several times - for me it will lead into a kind of boot loop. The FP4 boots until “Fairphone 4” banner and then reboots immediately. This repeats for 5 or 6 times.
After that, the phone boots without installing the update and have lost root. Also, I need completely restart the OTA process.
Did I missed something?

  1. Uninstall magisk (restore)
  2. Install OTA, do not press on restart,
  3. Install magisk root to inactive slot and reboot directly from magisk app

You didn’t miss something, there are a few people for who that process just doesn’t work. We’ve tried several times to narrow it down to a module or setting that causes it, but so far there hasn’t been a conclusive answer :man_shrugging:

All I can say is that in my sample size of 1 FP4 on FPOS (2 if I count my own one on Calyx) I regularly update I’ve never had any issues with that process in the last 20 months or so (so never basically).
But those don’t use any intrusive/complex modules, just a systemless host file and root access for a few apps.

One thing I’ve had a few times is that Magisk will sometimes fail to install, but that’s clearly visible in the logs it displays, can be fixed by just hitting install again and shouldn’t lead to a bootloop just a non-rooted system if you don’t notice it and reboot.

Thanks. I have the same setup - systemless host and some few root apps. The only thing I remember is that I manually needed to change the active slot (A/B) when I rooted the phone the first time (jan 2022). (There were some unresolveable boot loops, afair)