FP4 recordings via USB-C devices (e.g. iRig HD2) with the native recorder have very bad audio quality


I was trying a view devices with my Fairphone 4 to record audio via USB-C (some Soundblaster devices and an iRig HD2). In general the devices did work but unfortunately the resulting audio has very poor quality.

Here you can listen to my iRig HD2 FP4 Recording.

I tried the exact same setup on my old Huawei Nova (with a broken screen) and got very good audio quality – the difference is staggering: iRig HD2 Nova Recording

This is not an Android 12 issue. I previously did some tests with Android 11 and it was the same. I hoped the problem would go away with 12 but it didn’t.

Anyone any ideas what’s going on?

Best wishes,

1 Like

Because of my feeling that something is wrong I requested support on the official fairphone website. I will keep you informed here.

I didn’t listen but there an oft reported clipping, so only using a low input can cure that.

1 Like

Thank you, but it is not clipping. I tried changing the input level. It only made the recordings quieter. Quality didn’t improve.

1 Like

Hi, I never tried this before but I can reproduce it with my FP4 and an old ‘SoundBlaster Play!’. That sound card is working great with my old smartphone but recordings with the FP4 sound terrible. Seems to be a general issue.

1 Like

I added the #issue to…

Thanks for contributing to the wiki! I personally would give it a :green_circle:, since you can still use the phone and the impact is relatively low since not many people use this (I suppose). I get it impacts your use case alot, but the wiki is more to give an objective overview of issues. But I’ll leave it up to you to implement that change or not.

Thank you for your response. I compared the issue with the other yellow ones and each is kind of – you can still use the phone. That’s why for me it is a huge impact. Right now it means I have to take two smartphones with me to get the job done. So for me

:orange_circle: :orange_circle: Medium impact - I can only partially use the phone

fits very well.

But for the objective overview I will change it to green.

1 Like

Oh boy, at first I used the integrated audio recorder and Rehearsal Assistant (f-droid). The latter always gave me excellent results on my old phone and the linked audio file in the first post is an example of that quality.

After reading a lot about sound issues on this forum I tried a third app for audio recordings called Audio Recorder (available via F-Droid or Google Play Store).
And the result is :drum: drumroll :drum: good audio quality.

Maybe Rehearsal Assistant is using the fairphone’s integrated recorder and that one is really really bad.

So this #issue is solved for me.
But the integrated audio recorder is definitely an issue.
I do recommend Audio Recorder (link above).


That’s great to hear! But it sounds then also a non Fairphone issue, right? Since switching from app fixed it for you. What do you think? I’m asking in the context of the wiki. We should make sure it’s a collection of well tested issues that are really FP specific issues. This may sound like the app you used may have a bug. Because if it was e.g. a FP driver or hardware issue, any app would have the same behavior. Unless it’s indeed using the native recording app from FP, which is unusable. But that has to be confirmed then.

It seems that Fairphone’s audio recorder is the real issue. But you need to know that this might influence other audio apps. Because the other app I use still works perfectly fine on other phones – so this is definitely a Fairphone issue in some way.
That’s why I would keep the issue in the Wiki. Maybe under another Title? But it should be mentioned there somehow, right?


I think this might be related:

Audio processing is definitely an issue on FP4. Unless you choose raw/unprocessed audio stream, it’s full of these artifacts.


Can you explain how the native recording app somehow is used by other apps? Do you have a source for that? I don’t think they can be related. Sure, the native recording app is horrible. But have you really confirmed that this is the cause? Maybe reach out to the developers of the app first to check if they have to do something to make it work better. I prefer to have really confirmed and reproducible issues in that wiki and not every issue someone comes across that may or may not have to do with other things outside of FP’s control. Only things that FP can fix should be in that list to keep it also relevant to FP support.

I’m not saying it’s impossible what you’re saying. Like @Razem points out, there are more issues. But if we as a community can pinpoint the cause on a low level, it will help FP to fix them better as wel. And if it’s something they can’t fix, but the app developer should, then FP was wasting time investigating something. I would suggest to reach out to the app developers and see if you can find out more with them. Because another app seems to work fine, right?

I don’t think it uses the stock audio recording app. But it uses the same processed audio stream that the stock app uses. Both Audio Recorder and Open Camera let you select the raw audio input. So I’d argue the problem is on both sides. Fairphone’s audio processing pipeline is messed up, but on the other hand, any recording app (especially those focused on music recording) should give you the option to not use the processed audio and record the raw input instead.


Sorry I can’t. Maybe it is a native recording setting that can be used by apps and this setting is miserable on the fairphone 4 (speculations). I only know that I never had any issues with the other app except on the Fairphone 4. Fairphone 1, Huawei Nova, Fire Tablet – all good. So I expect it to be something special with the Fairphone 4. This should be reproducible for everyone who has another android device at hand.

Of course you can delete the issue in the wiki.
No problem for me, do as you please.
If anyone is searching for something related they will probably end up here and find the info they need.

@Razem Sorry I didn’t see your last post before writing this.

My point is not to delete it, but to make sure the list of issues are truly FP issues. Maybe reach out to the devs of the app to verify your assumptions, via a bug report for example. It will make the conclusions more solid if they can confirm this.

Unfortunately Rehearsal Assistant is too old for that.
You won’t reach the developer.

As I previously mentioned I think the issue with the integrated recorder should be mentioned in the wiki – that would be sufficient. This app is definitely an issue, because if you use an audio recorder you normally expect it to be able to record in the quality the microphones are able to deliver. If I had known that, this whole thread wouldn’t exist. And I could have saved myself some time.

1 Like

I see indeed that that app you were using at first is indeed almost 10 years without new updates. This adds to my point. If Audio Recorder | F-Droid - Free and Open Source Android App Repository does work fine, but you haven’t pinpointed the root cause problem, I personally find it too soon to jump to conclusions. Since it is listed in the wiki I suppose you already reported the issue to FP support (that’s in the wiki as a requirement, just as proving it is reproducible), did FP support already replied?

Just to make this clear: the wiki isnt anything official, and a wiki can be updated by everyone as they wish. There is nothing like a requirement, its just what you would like to see.

And even if this app is no prove there are other indicators there might be issues as far as I understand.

As I mentioned in the second post, I requested support, but no response yet. I also updated it with my new findings yesterday.

The root cause problem for me is…

if you use an audio recorder you normally expect it to be able to record in the quality the microphones are able to deliver.

Unfortunately the Fairphone Recorder can’t do that.