🇬🇧 🇫🇷 FP4 Random reboots in Monaco

(French below)
Hello,

I’m living in France and working in Monaco. When in this country, I experience randomly a short full-freeze (maybe 3 seconds) followed by a reboot. It happens several times a day, sometimes 4 times during my lunch break. It never happens in France (or really rarely).
My operator is Bouygues from France (which has antennas on the other side of the border I think). I usually get the 3G, and sometimes a quite unstable 4G (quite common for foreigners).
My build number is FP4.SP29.B.069.20230510 . I bought my phone in December 2022. I think that I did not have the issue at the beginning and it started with an update, but not sure at all.

I tried several things without success:

  • enabling only 2G/3G (I don’t have 5G subscription)
  • disabling roaming
  • forcing Bouygues 3G network
  • disabling 4G calls and MMS
    I’m also using a bluetooth Shokz headset. I don’t have stats with bluetooth disabled.
    I used once Wi-Fi and no 3G/4G a day and had no crash I think, but I need to retry to be sure. (it would not be a solution, I only have wi-fi at work)
    I don’t have any logs of the system yet to track what happens before the last reboot.

I’m out of ideas and it’s very annoying (even if the reboot is quite fast). Any additional idea is welcome.

– French version –

J’habite en France et je travaille à Monaco. Dans ce pays, je subis aléatoirement des freezes courts (peut-être 3 secondes) suivi d’un redémarrage. Cela arrive plusieurs fois par jour, parfois 4 fois pendant ma pose déjeuner. Cela n’arrive jamais en France (ou vraiment rarement).
Mon opérateur est Bouygues (qui a des antennes du côté français je crois). Je reçois habituellement la 3G, parfois de la 4G bien instable (assez courant pour les étrangers).
Mon numéro de build est FP4.SP29.B.069.20230510 . J’ai acheté mon FP4 en décembre 2022. Je pense que je n’avais pas le problème au début et que ça a démarré avec une mise à jour, mais pas sûr du tout.

J’ai essayé plusieurs choses sans succès:

  • activer seulement la 2G/3G (je n’ai pas d’abonnement 5G)
  • désactiver l’itinérance
  • forcer le réseau Bouygues 3G
  • désactiver rles appels 4G et les MMS
    J’utilise aussi des écouteurs Shokz bluetooth. Je n’ai pas de stats avec le bluetooth désactivé.
    Une fois j’ai utilisé le Wi-Fi sans 3G/4G pendant un jour et je n’ai pas eu je crois de reboot, mais je dois réessayer pour être sûr (ça ne serait pas une solution, je n’ai du Wi-Fi qu’au bureau).
    Je n’ai pas de logs système pour suivre ce qui a pu se passer avant le dernier reboot.

Je suis à court d’idées et c’est très ennuyant (même si le reboot est bien rapide). Toute idée est bienvenue.

Update: logcat data

07-04 14:11:47.789  3544  3544 F libc    : Fatal signal 6 (SIGABRT), code -1 (SI_QUEUE) in tid 3544 (init), pid 3544 (init)
07-04 14:11:47.812  3544  3544 F libc    : crash_dump helper failed to exec, or was killed
1 Like

Have you contacted your provider about this and how old is the SIM card?

1 Like

Hi, I did not try to contact my provider (I don’t expect any help).
My SIM card is 2 years old. Random reboots is unheard from colleagues with the same provider with a phone from a different brand (I did not have any particular issue with my previous phone (a Galaxy A5 2017) with the same SIM card.
I forgot to say I don’t have any SD card.

The provider has to do their part of homework to support a device properly. Also, even if a SIM works in another phone it not mean its not faulty. So I would contact the provider and Fairphone support.

1 Like

Quite likely. Taken with (?) no problems when not using mobile data, for me this points to an adjustment required either on the carrier side or FP side, possibly both, but they need to talk, so I’d advise contacting both. Check which carrier you’re using on the Monaco side, but equipment and configurations may vary even with a single operator.

Today I disabled the 3G/4G and used only the Wi-Fi and did not have any reboot.
I did not try yet the Safe Mode (as suggested as a preliminary step of support), so I’ll do that next week and contact the Fairphone support if the problem is still there (I bet it will).
Thanks to all of you for your suggestions.

1 Like

The same thing happened to me both abroad ( Cech Republic) & in the UK… what makes this so serious is that it is location dependent… to travel on a trailway journey - it will start rebooting in one area and then be OK in another, bad luck if you get off in an area that is affected - there is no fix other than disable the phone. I replaced the SIM and did a hard reset to try to fix it…
After this, and the brightness bug where it is unusable outdoors , I sadly relegated the FP4 to being a spare :-/

:thinking: That’s strange, because AFAIK there are people in the UK having the FP4, if there was a specific issue with the local network(s) they would had already spotted it.

You said “abroad”, this means your phone is roaming: Have you checked which operator it uses when this happens? Is there a specific one, or does it happen with several different?

The strange thing is you said that you tried disabling roaming and still had crashes, despite still using the french Bouygues network. What is the difference between using Bouygues in Monaco, and using Bouygues a couple kilometers away in France? :open_mouth:

You’ve mentioned “unstable 4G”, but that doesn’t necessarily explain anything either. I’m sure there are lots of FP4 users with unstable Bouygues 4G connections in France, they would had noticed if this would consistently cause crashes.

So, what is the special, Monaco-specific thing which causes your FP4 to crash?

You say working in Monaco, so you clearly spend a lot of time there. Are you sure your phone only crashes while in Monaco? Does it perhaps crash just as often in France, but you don’t notice it (because you don’t need it so much while at home for instance)?
FP4s do experience the occasional unexplained random crash, yours might be starting to get specially “touchy”.

I don’t know how is organized the network in Monaco. I don’t know if Bouygues have towers within the country, or if from the neighborhood of my office I get cells located in France. Given that I never had any roaming message and that my phone always displays « Bouygues », it would say I only get Bouygues network.
Note that in some parts of the “country” (it’s more like a town), many people with French providers stop getting any network. It’s my case with Bouygues (and I think it’s the same with Free).

Sorry for not being precised enough, I did not want my message to become too long. I meant than in Monaco, my phone (and my previous Samsung phone) switches between Bouygues 3G and Bouygues 4G. The 3G is more stable, but with 4G I sometimes lose the data connectivity for a moment (a least 1 minute) and then either the data is back or it switches to 3G. I don’t witness such problem in France.

I’m 100% sure it happens only in Monaco, or much much more frequently in Monaco. My use is of my phone is:

  • 2 days a week in Monaco, on 3G/4G => several crashes a day (I would say roughly 6; more frequent when I use data like listening podcasts or browsing, but I can happen randomly, maybe when apps communicate in the background). Note that the network does not send my any message that I’m roaming.
  • at home, I’m always in Wi-Fi. So I expect no crash. I would notice: I need to enter the PIN code for a complete reboot.
  • outside, in France (when doing sports, groceries, commuting…) I get no crash.
  • I was recently for 3 weeks in Réunion island (French island in Indian ocean), which is considered as roaming (I got the pricing message when I arrived and the displayed network name changed). I got no crash (or so rare that I cannot remember).

Yes, such a number of reboots is annoying as one can guess. Not to the point that I would switch to my previous phone back, but annoying is several scenarios.

Me neither. I haven’t been there for at least 10 years now. You say there is no roaming message, so it seems there is some agreement through which French operators cover it just like the French territory.

That’s normal, it chooses the best option, and if it’s not working falls back to the inferior one. That shouldn’t make your phone crash, it’s something happening all the time (except in a big city). I live (mostly) in the boonies and have my fair share of “phone looking for a reliable connection” (FP4 too, Orange FR).
Meaning that this shouldn’t (normally) be the cause of the crashes.

As much as it pains me, I think your only hope is to check with Bouygues… :flushed:
It seems they do something special with their network relays inside Monaco, something the FP4 apparently doesn’t like…

I had the same problem in both at home (EE in the UK ) and when roaming (Czechia - O2? )

In both countries the problem is very localised, and worked fine in some areas… so very weird - never seen anything like it

:thinking: That would mean it depends on specific conditions being met.
I’d suggest both you and @Veloman contact support (with as precise information as possible, including use of 5G or not), because this might indeed be fixed in some future network driver update.

If it doesn’t only happen in Monaco and/or Bouygues, it must be due to the FP4 not playing nice with some specific-but-not-uncommon network setting.

Bonjour à tous,

J’ai exactement le même soucis avec mon FP4 qui jusqu’à il y a quelques jours fonctionnait parfaitement bien.

Je pense avoir trouvé d’où viens le problème et ce qui provoque les reboot intempestifs.

Depuis la dernière mise à jour, les options Volte et Vowifi sont disponible chez Free et donc, il y a quelques jours, j’ai activé l’option Wifi Calli et dans les paramètres, j’ai sélectionné ‘’ Appels via le Wi-Fi : Si le réseau wifi n’est pas disponible, utiliser le réseau mobile’'. Afin que le FP4 bascule sur les appels wifi lorsque je suis chez moi où je ne capte pas très bien.

Avec cette option activée, lorsque le téléphone capte mal le réseau et que le wifi est désactivé, le téléphone freeze puis reboot même si vous avez du réseau.

Depuis que j’ ai remis les réglages par défaut ‘’ appels via le réseau mobile, les reboots ont disparus.

J’espère que cela aidera certains.

1 Like

Avez-vous essayer d’installer la dernière version de juin 2023 ?

Je suis déjà sur la version de juin.

J’ai toutes les options possibles désactivées (appels wi-fi…).
Le support m’a proposé de réinitialiser les options APN du réseau. Hier j’ai eu 2 reboots. Mais lors des 2 jours précédents à Monaco j’avais aussi eu moins de reboots qu’auparavant. Je vais tester encore un jour, puis je vais essayer une esim data d’un autre réseau. Le support m’a suggéré de tester une autre sim d’un autre réseau mais je ne peux pas emprunter la sim de quelqu’un d’autre pendant une journée.

Bonjour,

Après quelques jours sans soucis, les reboots intznpestifs sont revenus…, je vais donc contacter le support

Salut ,

As tu tester le mode sécurisé (ou safe mode) ?

Ayant les mêmes soucis de reboot que toi , j’ai essayé le mode sécurisé qui démarre ton tel avec les applis par defaut sont actives uniquement, afin d’éviter qu’une appli corrompu fasse planter le tel .

Cela me permet de constater que lorsque j’utilise la 5g comme mode de connexion, le tel fini par rebooter .

Lorsque je suis connecté en wifi , pas de reboot !

Tente cette manip, tu verra ainsi si ton soucis viens de ta Sim ou d’une appli.

Pour démarrer en mode sécurisé :

Si votre téléphone est allumé

  1. Appuyez sur le bouton d’alimentation pour activer l’écran.

  2. Appuyez et maintenez enfoncé le bouton power pendant environ 1 seconde. Une fenêtre contextuelle s’ouvrira, affichant l’option Éteindre .

  3. Appuyez et maintenez Éteindre pendant quelques secondes.

  4. Vous verrez une fenêtre contextuelle Redémarrer en mode sans échec . Appuyez sur OK

  5. Votre appareil démarrera en mode sans échec . Vous verrez les mots Mode sécurisé dans un champ de texte en bas.

Si votre téléphone est éteint

  1. Appuyez et relâchez le bouton power pour allumer le téléphone. L’écriture Fairphone apparaîtra.

  2. Après la disparition de l’écriture Fairphone, l’animation bleue commence. Dès que cela se produit, maintenir enfoncé le bouton Volume bas et continuer jusqu’à ce que votre appareil démarre.

  3. Si tout s’est bien passé, dans un champ de texte gris en bas à gauche de votre écran, les mots 'Mode sécurisé sont inscrits.
    Si vous ne les voyez pas, éteignez votre appareil et réessayez.

A+

Oui, j’avais essayé le Safe Mode, ça a reproduit le problème. J’ai ouvert Chrome et ai navigué le plus vite possible dans des pages Wikipédia, et en quelques secondes ou minutes j’avais le crash.
Mon plan est d’essayer encore 2j à Monaco (actuellement j’ai 2 crashs par jour). Puis de prendre une eSIM data Free/SFR et de tester encore (en mettant ma SIM actuelle dans mon ancien téléphone).

Ok,

Mais d’après ce que je lis c’est que tu as testé en 4g ou 5g , pas en wifi ?

Je disait juste , de te connecter en wifi au lieu de la 5g et de voir si tu as les mêmes reboot, histoire de bien être sûr que c’est la carte sim qui est en faute .