FP4 is no longer recognized on Windows 10 / 11 via USB

Hello everybody,

I was very happy to buy a new Fairphone and would like to continue supporting this project. But now I have a problem:
FP4 is no longer recognized on the computer. USB cable is tested, OK. Other Android devices are recognized on the same PC without any problems.

After testing with several computers, other good USB cables and replacing the USB port bottom module, I returned the FP4 and got a new one. After a few days the same problem, no USB data connection. (It has nothing to do with Windows, my old Samsung works on the same computer and in the car there is the same problem).

Does anyone know this error and have you found a solution.

The support was very friendly, but could not help. And since I need the USB data connection daily (WIFI is not possible, it must be a cable connection), otherwise I have to buy an unfair product again, which I do not want.

best regards

Sorry about my (poor) English

Do a factory reset and try again without any third party app installed

Thank you, I have already done that, it did not change anything

best regards

Maybe deleting driver and other devices will help

Or have you any Apps installed to block connections? Is it not recognized at all or is it at least charging? I assume you enabled MTP on the FP, the phone will not keep that, it has to be done every time you connect?

The support had also suggested this to me. After reboot of Windows and connecting the Phone:
The FP4 is not recognized. My old S7 is recognized immediately.
I am sure the error is in the FP4. After installing all the apps everything worked for a few days without problems. Then - no new apps or changes to the phone - no more connection. With the replacement device exactly the same after a few days. That’s why I ask here if others know this problem. I have the impression it could be a hardware problem. It is not the USB port, it has been replaced first.
best regards

It would be really bad luck if you would have received two devices with the exact same fault, so I’m not so convinced its the FP4 alone… searching the forum does not show many topics


So is it charging or not?

charging is fine, even »Quick charge«
Perhaps many users do not use USB data transfer. Most probably use the cloud and wifi. But for me, this is an important feature.

Similar problem here:
MyPhoneExplorer loses its USB connection to my PC, Win10, with a USB-C to USB-C 3.2 Long Life Cable + USB-C to USB-A adapter, supplied by Faiphone.
My solution was to use a USB-C port on the PC instead of a USB-A one, i.e. USB-C to USB-C connection.


thank you i’ll try that tomorrow.

The crazy thing is that it worked fine with all the different cables i have and then it stoped working.

In my Car there is no USB-C only USB-A and this connection is needed for the navigation Display. And this doesn’t work either since the USB connection ist lost.
Guten Abend


I tried the USB-C port on the PC: no connection, only charging.

Thanks for your help and ideas, now I guess I’ll have to keep using my old S7 for now and send the Fairphone back. I guess it’s definitively broken.

Have a good evening!

Let’s not forget about safe mode :slight_smile:

1 Like

I don’t use a FP4, but I do, with my FP3 running the latest FPOS, observe the following.
If I boot my PC (Windows 10 [10.0.19043.1766]) and my FP3 and then connect the latter by a certified USB cable I obtain a viable USB File transfer connection (or other protocol).

If however I then disconnect the FP3 after first using the Windows “Safely Remove Hardware and Eject Media” function, when I later reconnect the phone, Windows fails to recognize it. I also notice that after “ejecting”, the “USB key” icon remains (uselessly) in the tray.

If I just unplug the cable without the proper preparatory Ejection then the icon disappears as it should, and I can later reconnect and the phone is recognized.
[Edit - but even that only happens if, on the phone, I go to Settings > Connected devices > USB. I don’t have to change anything, just open the settings. It’s as though this initiates a handshake.]

So there’s definitely a bug somewhere and to my mind it looks like it might be more on the Windows side than the phone’s. In view of the necessity of opening the Settings on the phone, maybe they are both at fault in different ways! There is of course no evidence that this is the same problem experienced with FP4 but it’s suspiciously similar.

For those who are encountering the FP4 problem, you might try going to
Settings > Connected devices > USB
and try different combinations, notably for “USB controlled by”. Mine is set to “This device”.

Do you can test it on a Linux host?

Two more ideas:
-Enable USB debugging mode after entering developer mode.
-Review the access, read and write permissions that Android 11 may ask you for. It is one of the biggest drawbacks I have had jumping from version 6 to version 11.

there is no possibility of selection, everything is grayed out.
Thank you :pray:

it must work on my computer and in the car. I do not have Linux at the moment and do not know if Ford SYNC runs on Linux base. We have Samsung, Huawei, Sony in the family/friends, everything works, only my FP4 does not connect.

Thank you :pray:

Was simply intended as a fundamental question to double check it.
Whether the device is recognized under Linux or whether it doesn’t work with it and is therefore a fundamental problem
Don’t want to force Linux on you.

Linux is fine, but I do not have Linux to test … I tested the cables and … It’s a question of how I want to spend my lifetime. It took too long already (April 18, 2022 the error appeared on my first FP4).

Thank you very much :pray:.

That happens when the phone doesn’t see that it’s connected over a cable valid for data. If we list some of the possibilities:

  • cable: you’ve tested several
  • bottom module: you’ve replaced it, twice in effect
  • some other hw component of the phone (which …?, how?)
  • phone software: you’ve done a reset
  • PC and Car hardware or software: unlikely, since neither work.

Above all, why did it work to begin with and then stop working, in both cases (original and replacement device)? The fact that two devices experienced the same symptoms leads me to suspect that there’s something in your local environment (in a very broad sense, including devices, software (including possible malware?), habits or ways you may have of going about things). I’m not criticizing anything here, just trying to reason.

Do you think there was anything in common in the events leading to both phones ceasing to connect over USB? Difficult I know :frowning_face:

Are you using any specific security software that might be disabling USB data?

No cange

there is no Problem

Thank you :pray: