FP4: Google-free Android

According to the installation notes

fastboot flash recovery_a recovery.img
fastboot flash recovery_b recovery.img

installing /e/ will overwrite your current recovery.

/e/ is degoogled anyway, so less work on that front :slightly_smiling_face:


Going a bit out of topic here, and I’m sorry for that, but can google maps be installed and more importantly run properly on a degoogled OS ? That’s pretty much the only google app I can’t really live without… I tried to get it to work on my Zenfone8 with microG on top of LineageOS, could launch the app but never managed to get the location dot to show up.

Dont know but I use Magic Earth (maps App preinstalled in e/OS) instead without using e/OS maybe worth a try

1 Like

Yeah… but I have to confess I’m pretty much hooked to the local guide system, 5 stars locations, etc etc. I have a LOT of favorites, visited places, to visit places pins basically everywhere… It’s also kind of a testimony of my past travels across the world so yeah, that’s the last google app I refuse to let go :confused:


Apparently Google Maps works on microG, but it might need some files and logging in may or may not work… not ideal probably :roll_eyes:

I get that, all my recorded tracks are in OsmAnd, I won’t switch away anytime soon. For my usecase the better outdoor (offline) maps and the ability to fix / improve the map myself makes OSM based apps always the better choice.


In my case (/e/OS on FP2) G.Maps works, but always says on startup that "Google play is outdated and has to be updated).
Though I’ve never tried to login with a G. account.

1 Like

You can flash MinMicroG on top of e/os to install the playstore. Maybe you can get maps working that way

What does “complete” mean in that sense?
For the sake of degoogling /e/OS misses some Google stuff which still is in LineageOS.
On the other hand /e/OS includes optional cloud service capabilities to substitute the Google cloud as well as an overall pretty positively received non-Google maps App (Magic Earth) by default.

Apart from some degoogling steps, microG is integrated in /e/OS in a non-removable way as of now. If the former perhaps wouldn’t do it already, then the latter for sure takes away the possibility to run the genuine Google services via e.g. Open GApps, which is possible with LineageOS.
Not that it would make any sense wanting to run genuine Google services on a degoogled Android OS anyway.

What else can’t be customised in /e/OS?

Can’t say that I’m affected, and for quite some time now, but there are bugs. As are in LineageOS. As are in Fairphone OS. In that regard … pick your poison.

You can use the website, and if you want you can install it to the home screen so that it behaves like an App when you open it from there.

Else … If you really, really need any Google-dependent App, in Custom ROM territory you would be better off using LineageOS in connection with the genuine Google services (installed e.g. via Open GApps ) and Google’s registration of devices running uncertified Android OSes for the legitimate use of Google services at https://www.google.com/android/uncertified.

There’s actually a pretty good chance you can get Google-dependent Apps to work with microG on /e/OS, but there are no guarantees, and even if an App might work at a certain point in time, Google can break this with changes on their side at any moment, with microG having to catch up again, if at all possible. This really happens sometimes.
It’s just not a state you want to be in if you really depend on a Google-dependent App working 100%, so make an informed decision.

You can uninstall pre-installed Apps in the usual Android way.


Oh yes, you are right. I was a bit imprecise. Sorry for that. You can uninstall it that way, of course.
(That seems to me to be exactly the approach I need to take to uninstall all the bloatware on any other commercially available device, for example.)
So I better rephrase: “what’s the point of installing ans more or less maintaining only ADB-removable non-functioning system apps and recommending users to use the working non-bundled non-forked original after all?”
But yes, in fact you are right. Technically spoken you can uninstall those apps.

I wanted my phone google free, and at the moment only /e/ is available. So I installed /e/
I started it and didn’t add an /e/ account. In that case the phone is not connected to the /e/ system.
Then I deinstalled all /e/ own apps.
After that I had a pure, let’s say, Los4mg system :wink:
I started then to install all my favourite apps from f-droid and aurora and connected me to my own nextcloud instance with DAVx5.
Until now, the only apps that are not working for me, and i don’t know why yet, are osmAND+ and Aegis.
All the rest works fine and smooth.

No goolge services are installed. MicroG is installed in version it is also the latest on microG GitHub

No, it is /e/ dedicated recovery


I’m sorry if my post wasn’t clear enough and seemed like a judgment on the OS: again I never used /e/ OS, just stated the vague impression I felt to read about it on there and there on this forum. I’m by no mean in position to judge the OS.

Can you chose to install microG or is it embedded in the system by default ? If so, won’t it prevent say the user who wants a minimal google service (for google maps as far as I’m concern) to flash gapps ? I remember having trouble getting google services to work properly side by side with systemized microG.

Well, I’m running LineageOS 18.1 on my Zenfone8 and OnePlus5T without a single bug nor quirk.

It is implemented by default
In this first FP4 build in newest version as well

In an ideal case we can get enough info together to get you close to that position :wink: .

In LineageOS, you can choose to install microG.

In LineageOS for microG, microG is embedded in the system by default in a way LineageOS didn’t want to allow by default (see the FAQ and this for the difference).

In /e/OS microG is embedded in the system in a way that achieves the same effect as in LineageOS for microG.

You aren’t affected then, which is the desirable situation for every user.
But there always will be bugs.

(There’s no public bug tracker for Fairphone OS on the Fairphone 4 currently.)


not 100% right

in LOS4mg the microG repo is included in f-droid store. not in /e/

The dark one is /e/ OS on FP4
The light one is LOS4mg on OnePlus 6T ( I didn’t add the microG repo not manually)

1 Like

You’re right, that was too general. Edited (hopefully better).

1 Like

That’s well detailled thanks. Just to be sure, and because I’m a bit slow, and also because I don’t want to make the wrong decision:

→ If I were to flash /e/ OS on my FP4 now:

  1. I would probably not be able to flash openGapps on top of it since it would conflict with microG ?
  2. I would probably have trouble to get Google Maps to fully work (ie with login/ratings/etc. features) with microG ?

Edit: you actually already answered in your previous comment:

I guess it’s a territory of uncertainty then.

Correct. This will definitely not work.

It’s worth a shot. To give microG credit, many users can use many different Google-dependent Apps without much trouble with it (I’m using some, too). But you have to be aware that you can’t really rely on it 100%, it’s more like a bonus.

1 Like

You can flash MinMicroG which will add a working Playstore.

Got you. It’s a shame I’m so dependant on GMaps, I guess I could “make it work” with the browser version though… What about Waze ? Isn’t it somehow google dependant ? Living in a massive traffic area I like my alternate road options to be accurate…

On top of the already system-embedded MicroG ?