FP4 - gcam-port

Installed MGC_8.6.263_A11_V14_snap.apk and found the option. But activating it does not make a difference.

After “shooting” a photo and tapping on the preview button, I see:

Me too, but it is not offered as a gallery option.

Did you try a reset of the default app setting for the gallery?

I use this version MGC_8.6.263_A11_V14_MGC.apk (com.android.mgc)

1 Like

thats kind of normal. What OS do you use? There might be a workaround using

Yes, makes no difference.

Did it (pm uninstall -k --user 0). GCam wants to have photos installed from play store. GCam Photo Preview cannot be installed (“…not installed”). Perhaps GCam Photo Preview is meant to be used only with CalyxOS?

as described in the linked thread what you did is not sufficient…and no it works fine without Calyx

I think it is not installed if gcam says I have to install it from play store. What else is necessary?

If I get it installed, is it just another gallery app or does it add the choice to use any gallery app?

it adds the choice to use the preview and open the gallery, so instead of getting this message telling you, you need Google Fotos, it will open the Gallery. My understanding is the package name is the same and with the commend used its not uninstalled for all user/completely. The command uninstalls for user 0, so its still there. How to remove completeley with root is a question for Hirnsushi :wink:

1 Like

You are right, it seems to be not sufficient.
I reinstalled photos from play store and removed it with

pm uninstall com.google.android.apps.photos

After that gcam asks for the gallery app (f-stop in my case). With other words: It works now, even without GCam photos preview.

Thanks for the helpful tips.


What is that your using there?

Here you can get the newest version (actually 0.4):
The version in your link is the initial version without the menu, to can edit, delete, etc… directly in preview

1 Like

i think you mean iodéOS
It is a custom ROM for FP4

I got my Fairphone 4 yesterday. Can I install another camera apk to test the difference with the standard camera app from Fairphone? Which apk do you advise? Can you provide a link? Thank you so much.

1 Like

Hi and welcome, you can and links to the GCam ports are already included above im one or the other post, just test which you like best, for me its Nikita over BSG, example pictures here

1 Like

Hi All,

I hope someone has found a solution to this.

I came from a Google Pixel phone to a Fairphone. I just love the Google Camera App. Then I found someone had a method to bring it over to the Fairphone. Happy days!

Except…about half the time, when I open the Google camera app, the camera doesn’t work. No image is seen, no image is captured if you click on the button.

The only “solution” that I’ve found these days is to restart the phone (and wait a minute or two). Other things I’ve tried:

  • turning phone on/off
  • switching to another app, then back to the Google Camera app
  • killing the Google Camera app, and restarting it
  • killing the Google Camera app, and starting the Fairphone Camera app.

I haven’t tried getting the console messages to see if there’s any logging that’s going on.

Anyone found a good solution (or a camera app that beats Googles (when it works)?

Which one exactly of the many GCam Ports do you use?

edit: moved your post, please also see above.

Edit2: else do some reading in the forum reg alternatives etc.


This file is no longer available. I am very interested to get a config file. Is there an updated version somewhere?

No, sorry. Don’t use a FP any longer

Which phone did you switch to, out off curiosity?