FP4 affected by GPS week rollover issue?

Probably not, because

  • I get a GPS fix within seconds
  • The position is accurate
  • The problem does not occur on my other GPS devices, including my FP2.

Since mde can confirm my observation, the issue seems to be independent of the used OS. Even Fairphone might not be able to fix this on their own if the Blobs need to be updated.

Anyway, this is a low-prio bug because you can use other apps which do not rely on GNSS time.
I will inform Fairphone support, maybe they consider this observation is worth to fix.

3 Likes

I remeber the previous software update had the issue, but then I resetted time and injected psds and time, and it got fixed.
The issue then re-appeared after the last software update

The problem just disappeared on my device - no software update, no reset, nothing. All previously affected apps are working again as expected.
Very strange but fine for me. Let’s hope it will not come back.

2 Likes

I can confirm that GPSTest does not complain any more on my device.

1 Like

I have just updated to FP4.FP3T.A.107.20220316.
The issue seemed solved at first boot, but reappeared after just one reboot.
It might be a result of some files which are not as persostent as they should…

Sorry about the double post.
It now seems to gave fixed itself after an automatic gps refresh. I gave no clue how this happen, but I will update if there are further news

1 Like

I have a similar problem.
If you select Berlin as the time zone in the system settings (in the original “Fairphone OS”), then daylight saving time is correctly taken into account. Only the GPS time is still an hour wrong. This can be seen, for example, in the arrival time in the TomTom app, which is an hour late. Apparently this is a known problem in the Android world, which also occurs on other devices.
As a workaround, you can select the Cairo time zone, which corresponds to that of Berlin (GMT+02:00), but without daylight saving time. However, you then have to change the time zone back to Berlin at the beginning of normal time (winter).

Build-Number: FP4.FP3T.A.107.20220316

I have the same issue, and it causes a problem with FitoTrack app

I have contacted fairphone support about it

Are you on the default FP OS? If so: Which patch level do you have? I cannot reproduce this any more since I’m on the April patch level. Also, did you check with GPSTest or some other app?

Hi mde,
Yes I’m on the default OS,

I’m on the march patch, build number FP4.FP3T.A.107.20220316, I don’t seem to have an upgrade available to me yet, that’s interesting to know it might be fixed in an update.

I checked with GPSTest yeah!

It depends on your network operator when and if you get the update. Did you already try a manual search in the updater app? If it’s still not found, try removing the SIM and searching again. Which operator do you use? Some are known to be late or not to release certain updates at all - because of compatibility issues with their network presumably.

2 Likes

Ah thanks for the tip. I’m with Vodafone in the UK. I tried searching without the SIM but no update. I’ll eventually resort to unlocking the bootloader and doing the offline install if I don’t see it in the next few weeks!

You can sideload (adb sideload) the ota.zip

…through recovery (adb reboot recovery), works for me. Should work with a locked bootloader, but I can’t try that, sorry.

I would back everything up first though, I’m only using it to directly update after flashing factory images so this might eat your data.

1 Like

hirnsushi, thank you! This update appears to have fixed the problem, GPSTest reports a correct time.

Glad to know these things get fixed.

1 Like

Hmm latest official OTA update seems to have undone it again.

Build number: FP4.FP3W.A.128.20220516

I still think that the issue is not related to a specific OS and/or release. I had the issue, it just disappeared without any system update and never came back.
Maybe the gps got some wrong time data which gets deleted during a system update or by using GPSTest? Or using gps for a longer time helps?
This topic remains a mystery for me…

Edit: it came back, I fixed it by

  1. activate flight mode, turn off gps
  2. delete gps data in GPSTest
  3. reboot
  4. activate gps, let GPSTest find the position (takes longer than usual due to missing almanac data)

The first fix had the wrong date, then the satellite list was discarded and a new attempt started. The 2nd fix had the correct time/date info.

Finally I switched off flight mode and loaded PSDS data with GPSTest.

Hi @w1900 thanks for the tip.

It hasn’t worked for me unfortunately, every time GPSTest gets a fix, the time is wrong!

Have you tried the “Inject time data” option in GPSTest? :thinking:

@hirnsushi thanks, I tried it but I don’t know what it does, and it didn’t seem to fix the time issue.

Hi all,

Fairphone support wrote me back and suggested my SIM might be at fault (using Vodafone micro?nano? SIM from a couple of years ago).

I took the SIM out and rebooted the phone and GPSTest reports a correct time!

I’m going to order a new SIM I suppose, suggest that anyone else with the same issue tries this themselves.

5 Likes