FP3 with EOS can't verify apps and won't update the apps

If have two fairphones FP3. On both it suddenly says it can’t verify an app hance the update does not install it.
This is for instance the case with an app called “wifi automatic”.
I am running EOS android 10.
Thank you very much for your help.

Hi there are lots of issues around having an SD card formatted as Internal. If you use one will you check that?

Thank you for your quick reply Amoun. I don’t have an SD card in either of them.

Ok forgot to ask how much memory you have left. If it’s under 10Gb it can be an issue, under 6G very often so

I have hardly any apps installed. 13 GB used of 64 GB is says.

1 Like

Ok The next thing I can think of is to try starting in safe mode to see if any ‘custom’ apps are failing or interfering with ‘normal’ functioning.

You may also enable ‘Developer mode’ which offers options to install ‘non google play store apks etc.’

Settings - About phone - Build number? Tap ten times

then go to Settings > System > Advanced > Developer options

Have to go now to catch train, will check in later

All the best

Thank you very much Amoun. I have developer mode allready enabled. I have the kill switch of Rob Braxman installed which asks for developer mode.

To install apps I have aurora installed. In aurora store it says google play services update avaiable. Is google play services still part of EOS?

I tried safe mode. I had to activate wifi and turn off flight mode to be able to check whether it would update the app. It does not. The app it tries to update is in “Apps” so not in Aurora Store.
Have a good day Amoun! Speak to you later.

Still here, about to go, you didn’t initially mention you are using EOS, I’ll put that in the title if that’s correct.

Sorry I forgot to mention that. Yes you are telepathic ;-). Just had the same thought. I will edit the title.

This is because the microG package has exactly the same name as Google Play Services. And so Aurora Store tries to update it - which of course fails because the package name is the only thing in common.
You can blacklist Google Play Services under Updates with long pressing on it and then selecting Add to Blacklist
:slight_smile:

3 Likes

Thank you very much. I am a bit confused now. On the EOS forum I got the following answer to the same question.
What do you think of that?
I quote:

What Aurora store detects is that a package with the name of the Play services is installed, and that package comes from microG, which poses as the Play services to Apps which need them to possibly work on /e/OS without the Play services.

That is also correct.
And since microG receives updates via F-Froid (and/or with OS updates) and not via Aurora Store, you can put this app on the Aurora blacklist.

Regarding this issue, could you take a screenshot of that error you mentioned?

Is that a typo or is there also an F-Froid. Just installed F-Droid.
So I understand I now have 3 apps who are able to install apps. 1. Aurora 2. F-Droid. 3. Apps.


When I click on “bijwerken” which means update in Dutch it says.

Can’t install this App. Verification Failed.

Yes, this a bit confusing.

    1. Aurora Store:
      Aurora Store provides all the apps directly from Google Play Store. You even can log in with your google account and install you paid apps.
    1. F-Droid:
      F-Droid offers you open source apps that are available in the official F-Droid repository: | F-Droid - Free and Open Source Android App Repository
      But you can also add custom repositories as it is possible with NewPipe (alternate Youtube app): Add the NewPipe repository to F-Droid. This has the advantage of getting updates faster (which ist sometimes important for NewPipe to work)
      Some OS developers have already integrated their own F-Droid repositories, so they can provide you directly with their own apps.
  1. Apps
    I think this is the “solution” developed by Murena aka /e/ Foundation for their operating system. They get their app database from APKpure, which IMHO is a bit of a security risk. [EDIT: I was wrong] Firstly, the apps from there can be very outdated. Secondly, there is a residual risk that you will not download what you want, but on the contrary spyware.

And I don’t trust APKpure in general, as they already have had some security issues with their own app in the past:

So I would go with F-Droid for open source apps and Aurora Store for everything else.

Is this the /e/OS App Store?
You probably previously have installed the app with Aurora Store and are now trying to update it with /e/OS App Store. This could be the reason for this error message…

EDIT: Sorry, that part about APKPure is wrong. /e/OS App Store seems to use https://info.cleanapk.org/
But there are or were some relations with APKPure: Where do Apps Come From? - #36 by pally - Applications - /e/ community
But nonetheless: If you look at the available apps on the App Checker webpage, you’ll find a lot of very old apps. The site lists Firefox 68.4.2 while on Google Play you can find Firefox 99.2.0
However, I hope that the information on the App Checker website is wrong. :see_no_evil:

Yes it is in the EOS app store. So I guess that problem is solved then. :partying_face:
Thank you so much for taking the time to write such an elaborate answer. This is a true dectitive spirit :-). It saves me a lot of days searching for answers. Would be a bummer if my search for privacy ends up in collecting malware ;-).

I understand now that despite the fact that APPS uses [quote=“HolosericaCaligo, post:14, topic:84288”]
https://info.cleanapk.org/
[/quote]

You would still advise to stick with F-Droid and Aurora which I wil do from now on.
Have a good day and weekend! :pray:

2 Likes

This seems to be possible.

Example: I let /e/OS App Lounge update the de.hafas.android.db App on my phone. The Checker reports version 20.08.p04.01, but I’m on 22.04.p02.03 currently (I think 22 is the year and 04 is the month, which would be quite current).

Seems the Checker is only good for checking whether the /e/OS Apps installer/ App Lounge has a particular App at all.

2 Likes

Remove wifi automatic and reinstall it. It cant update, because you can only update the app fom his original install source. If you it from aurora store, update it with aurora store and if you got if from f-droid update it with f-droid

Never use /e/OS own APP store!

Thank you Erik2, Is there a way to prevent APPS from trying to update? After reinstall trhough aurora the update request is still in the update list of APPS.
Have a good Sunday!

Thanx FairphoneHulk. Using only Aurora and F-Droid now.
Another user told me he/she is awaiting an update for the APP Store itself.