English

FP3: Wifi connection problems, no IP

Hi there,

I just fetched my FP3 yesterday from the delievery point and got started this morning to set it up.
I’m having trouble to connect to any(!) wifi with the FP3.
The default wifi at home does not complete the login and neither if I setup a hot spot on another phone and grant access there.
I was wondering if anybody has a similar experience somewhere?

Steps to reproduce:

  • Do not put in a SIM
  • Set phone language to Norwegian.
  • Run the initial configuration of the phone, connect to your WPA secured Wifi.

The connection never completes and the phone does not get online.

any tips appreciated.

Update:

What is the result of the WLAN test? You can find the test in the Service tests in the Developer Options.
First enable Developer Options
Go to Settings
Go to About phone (last one on the screen)
Tap multiple times on the word “Build number”

Now go to the Service Test
Go bto Settings
Go to System
Go to Advanced
Go to Developer options
Go to Service Menu (last option)
Go to Service tests
choose Test Single
tap on WLAN

Enable WLAN OK
Searching
Access points found
Connect to "<SSID>" WLAN connection
Successfully setup. Enter WEB address to connect to.
Connect Fail: Host unreachable
Test Stopped.

I work at the same time with a laptop using the same Network.

I tried this and now this happend

Now my FP3 only tries to connect…

I connect without any problems to a Fritzbox 7581 at home and at my friends place to a Fritzbox 7360 .
So I am wondering which router/modem you use.

1 Like

Some from Telekom. WLAN-“add Nummer here”.
The First time i tried it, my phone showed me what you can see in the picture and the second time i tried it, it only said “connecting”

Did you try to manually set the wifi?
Go to Settings
Go to Network & Internet
Go to Wi-Fi
Swipe down till you see " + Add network "

Perhaps you have to look at the Wi-Fi preferences (see just below " + Add network ")

Yes. We also tried this. Same result. Nothing happend.
The only thing that changed is a little grey “saved” underneath the WLAN.

Just be certain. It may sound strange.
But could you set the router to access restrictions for the WLAN and then make sure that your phone is allowed?

But could you set the router to access restrictions for the
WLAN and then make sure that your phone is allowed?

There are currently now limitations on which device might be allowed or not allowed to connect to the router.

Update: Just minutes after writing this answer, I’ve wanted to set the network manually in the settings, enabled WIfi and the phone connected successfully. I do not have any explanation for this in my case. There were no changes on the network infrastructure at all. The only difference I can come up with which might explain this was the utilization. I had to copy a couple of GB yesterday during the day. This did not affect any other device in the household, but is the only difference (beside the date) compared to today.

In other words: Issue resolved.

Atm we dont have any restrictions for our WLAN. So you mean we should do it and accept the FP3?
It’s worth a try.

Yes, that’s why I mean.

What you also can try is is a solution that worked forPietro_Ciuffreda with a FP2:
“changed WiFi mode from 11nbg to 11bg and my FP2 is able to connect to WiFi (WPA2).”

In a Fritzbox 7360 you can change this by:
go in your webbrowser to http://fritz.box
now you can go into the settings of your Fritzbox
go to Wireless
go to Radio Channel
choose Adjust radio channel settings
go to Additional settings
now you can set the Wireless Standard to 802.1b+g

2 Likes

We’ve been having the same issue for over 2 months with the FP2 https://bugtracker.fairphone.com/project/fairphone-android-7/issue/276

I had the same issue when i got my FP 3 . My home wifi has a hidden SSID and did the following to fix it:
*update system firmware
*Under wifi settings
*press add network
*choose advanced settings
*scroll down and select hidden network yes
*type in hidden ssid name and password WPA key.
hope it helps ! love this phone!

2 Likes

Same for me on my FP3 with Android 9 and security patch of Feb 2020.
This procedure worked well also on my case.
Too bad that this setting is so deeply buried in “advanced settings” …

Thanks for the tip !