Hidden WLAN SSID is not reconnectin when in range/doesn't work on initial setup

just got my FP3 today and recognized, that if you try to connect to a hidden WLAN it simply does not work.

If I choose to not hide SSID it works even when hiding the SSID again.

But: If you leave the range of the hidden WLAN and come back some time later, it is not reconnected / found.

1 Like

Did you enable the “Advanced settings” and set “Hidden network” to “Yes”?

I am missing this settings… Cannot find it.

1 Like

I don’t own a FP3, but a FP2 with Android 9 (LineageOS). Not sure if the settings menu is the same:

1 Like

Unfortunatly none of these settings here.
But thanks! :wink:

So I wonder whether only I have got this issue. I reproduced it yesterday. If I connect to a WLAN which is not hidden it works, but if the WLAN i connected before is hidden, the FP3 is not reconnecting to this WLAN.

I am aware that a hidden WLAN (SSID) is not more secure as the phone continuously spreads out the SSID of the hidden WLAN, but I think hidden SSIDs are common, so this should work. Perhaps it is only a little OS issue.

1 Like

Got my Fairphone3 yesterday. I was a little sad that hidden wifi is not going to work.
With not hidden wifi eyerything works fine. Any ideas or new facts?

Hi, so this is not only happening to me… Unfortunatly no ideas at the moment. Hope for a fix.

What about this here? …