FP3+ Sound Quality (not Mic)

Hi folks,

I’m new to the FP3+ (moved to it yesterday), and trying hard to like it. One thing that I’ve noticed immediately is the low sound quality of phone calls. This is not a hi-fi issue (it’s just voice) and does not have to do with the mic - it’s actually the receiving side (the voice of the other party). I’ve checked with phone on ear / speakerphone / bluetooth headset (good set), so not a hardware issue of earpiece / speaker.
I’ve moved from my good old LG G4(!). The drop in audio quality is very present and noticeable. I made a few A/B comparisons. The other side’s voice sounds a bit muffled and distorted, as if their microphone is broken.

Not a cellular coverage thing, as I’m comparing to other phones at the same spot.

Anyone else experiencing this? Could this be a software issue? Anything that can be done to improve it?

Thanks for any insight!

Hi Welcome to the forum.

You say it’s not a mic issue, ? meaning others have no problem hearing you as they expect.

Do you get this on handsfree as well as earpiece and external headsets?

One thing you can try is the onboard test.
Dial *#*#66#*#* > Service tests > Test single and then check the Speaker and Receiver ~ you should hear some a Taiwan song. If that’s ok on both then it is a network issue.

Is it the same at different volumes?

I don’t use networks except through wifi but there are options on network quality control, someone else may direct you to those settings.

Hi @amoun thanks for responding!
Definitely same issue with BT handsfree. I did just run the tests you recommended and they are both just fine (audio is good and clear). I also listened to local music before posting, and while it’s not high quality (not sure why, btw - it’s 2021), it’s certainly okay and nothing like what I hear on calls.

Here are a couple of topics referring to HD voice, but FP2 and FP1.

Still looking for more recent topics, will update here if no-one else responds.

1 Like

Another thing that I tried before posting is the Enhanced LTE thing in the carrier config.
Does not make any difference.
Am I the only one experiencing this? That would be really weird. I find it less plausible that it’s a hardware issue in my particular handset (see my original post above), although it could still be that.

That’s probably what I have missed. Contact support|@|fair|phone>com anyway in case you have some duff hardware.

1 Like

I guess you already checked it, just to make sure: You are running the latest updates?

There have been a lot of problems with call quality (audio quality, connection, disruptions). These have been fixed some months before by updating the firmware of the baseband processor.

As you just moved to the FP3, maybe there is still the older, buggy software running?

2 Likes

With ref to @ontheair
Settings > About phone > Build number (both the later options are at the bottom of the list) You hopefully will have 8901.3.A.0107.20200513

Yep. What I have is the latest f/w version…
I suppose I need to take it up with the vendor.
Thanks!!

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.