FP3+: Issues with Android 13 update

I didn’t lose anything with the update, and I also use signal. Of course, I can’t guarantee it’ll be the same for you.


The network issue wasn’t the Fairphones or Fritzboxs fault.
Also WPA3 + WPA2 works flawlessly.
It’s basically a feature.
Google removed the option to stay connected to a network without internet access.
Also Google sends some dns request while ignoring the vpn tunnel.
Now if you, like me, block tcp port 53 for outside connections, Android has no chance to reach or
Doing this prevents Google from collecting data about you and your smartphone.
In Android 13 Google forces this now and I got no idea how to work around this.

Also for those who use a VPN.
Don’t block non VPN connections or better exclude Googles services from it or you also will get a nonstop dropping network connection.

I have an issue with the NFC reader.

After i installed the Android 13 the fingerprint stopped working and i forgot my pincode for my banking security app.

I need to scan the chip on my passport to change the code but seems like i cant scan it after android 13.

I would gladly pay for a new fingerprint reader. I realy hope a fix is on the way, fast as this will be a dealbreaker for me regarding the fairphone and keep telling friends to buy it.

Do you mean to say that WPA3 + WPA2 mode worked flawlessly after you unblocked port 53? It’s unclear what the relationship between WiFi security mode and DNS is.

Yes, I just mentioned it because someone said it usually doesn’t work.
But for me it was the same for wireless and wired lan.
Now it works as it should but if someone talks about birds near my phone I probably will get a lot bird ads again.

So to be clear there never was a connection between dns and wifi security mode.

I found the real solution to this:
Go to Settings => Network & Internet => Private DNS
and switch it on and then off.

1 Like

First of all: THANKS to Fairphone for keeping FP3 up to date! I really appreciate that they took the pains to implement A13 for such an “old” device (old in the sens of: SOC-manufacturer does not support it anymore).
That said, my FP3 started to “act up” today. I updated to A13 two days ago, and had a flawless day yesterday, doing a longer, GPS assisted hike with lots of usage of the phone, however in airplane mode over a longer period.
Today, on day 2, for reasons I yet could not identify, the phone kindof freezes - sometimes after 10-20 minutes, sometimes after an hour or so: The touchscreen becomes unresponsive, or near unresponsive. If it reacts at all, it mis-interpretes the input, as if system resources for the touchscreen are not enough and it does not react quickly enough to the finger. If I succeed in restarting or switching off the phone, after it has rebooted, the issue remains, i.e. the phone is unresponsive from the beginning on! Only thing that solves it is removing the battery.
Main difference between yesterday and today: Yesterday the phone was mainly in airplane mode or had Wifi, while today I’m mainly on mobile data.
Any ideas? Anyone having the same?

EDIT: Ooooooohhh - now that I move around in the forum and read more, it came back to me - I DID change something today: I activated “Show notifications by swiping across fingerprint reader” (German: Benachrichtigungen durch Wischen über den Fingerabdrucksensor einblenden" - not sure if my translation is accurate), and since the fingerprint reader seems to be a neuralgic point, this may be the cause after all. I deactivated the setting again and will see if it is the root cause.

1 Like

…and it was. Have the setting off again, and since several hours stable again. For me OK - I do not use the fingerprint reader anyhow. But I guess for most users they need to find a solution…


Since updating my Fairphone3+ to Android13 I have experienced the following glitches

(1) the lowest volume setting for notifications is crazy loud. I cannot turn it down any further, have done in app and on device. Help, it is awful!

(2) volume for calls and volume for notifications are now on the same toggle - this is exceedingly stupid. Is there a fix?

(3) now the bedtime mode seems to stop messages and emails from arriving altogether, whereas previously they were simply silent. There is nowhere in app or in device settings that I can see to change this.
I would like to receive all communications but with no noise. Any fixes?

(4) the auto dimming setting in bedtime mode is messed up - it makes the apps brighter against the background, working in the opposite way from intended. Any fixes?

1 Like


  1. I agree the lowest volume setting is rather loud. I guess there may be a way to fix that in an update, so worth contacting official support.
  2. In Android 11 there was an option to link ring & notification volumes. This disappeared already in A12 and is presumably an Android design decision, but I haven’t checked.
  3. It seems to me that your night-time requirements may be better served by using Do Not Disturb, where you can allow notifications to show on the screen but cut the sound.

Sharing this, as it might help other people:

When doing calls, my FP3 switched on the display every 30 seconds. Which is annoying, as you have to be very careful not to accidentially press the “end call button” with your cheek.

Finally I found the reason: It was caused by the function “Keep screen on while viewing” (off by default). This function can be activated in the Android settings, using the front camera to check if somebody is looking at the display.
Unfortunately this (useful) function is buggy (at least on my phone), causing the mentioned behaviour.

Workaround: Turn off “keep screen on while viewing”. Then the proximity sensor works like a charm again.



I have notice number 5 as well in my FP3+. Many apps take a second before they respond to tapping them (to open the app) on the screen and often there is a general lag in everything.

I noticed that now there is only the google search bar when you swipe up to your apps and want to search for an app. You get the google results first and then “from your apps”. Is there any way to get it back to how it used to be, that you have a search bar that filters your apps when you are searchin for one?

I’d like to be able to enable the grayscale function on a schedule as before without it blocking functionality of apps.
Is this possible?

In the bedtime mode previously, this was possible (greyscale on a schedule, without messing with other functions).

I’d like to maintain user autonomy and ask for this to be reinstated.

@OldRoutard, how do I contact official support and simultaneously let them know that I’m not the only person who would like the volume settings to be fixed?
Do they not participate in the forum?

Not on a regular basis, There’s a “Community Manager” but who has other duties I believe. Fairphone employees do not systematically read the forum, which is there for the community. They publish official notices mostly about updates or for running beta test programmes for example. The only way to make sure they get the message and ensure follow-up is to contactsupport through support.fairphone.com, or by telephone or through the My Fairphone app. When you contact them, you can of course point to a forum thread which might contain information relevant to the problem you’re reporting.

1 Like

See under Settings > Accessibility > Text and display > Colour correction
You can also set Greyscale to be active during the Bedtime schedule (see under Digital wellbeing > Bedtime mode).

1 Like

since i updated my fp3 to android 13,
it randomly gets stuck - after the screen went black theres a >75% chance you cannot get back and have to restart the phone…
can anyone help - what is the solution ?
when it does not come back from black-screen, this crap is unusable cause i cant do anything when a call or message comes in… (except restarting … EVERY TIME !!! )

Since updating the OS on my FP3+ the phone has become very unstable. Screen brightness was constantly changing and had to disable auto adjust.
The main issue though is the phone just turns off. Screen is black and I need to remove battery in order to reboot. I am very disappointed. The phone is becoming unusable and is only 2 years old.


I have the same problem.
But for me I usually have to remove the battery to be able to restart it at all.

Try to turn off screen auto-rotate



I had also the problem, try to reset the adaptive brightness: Adaptive Brightness: Everything you need to know - Android Authority

1 Like