FP3+: Issues with Android 13 update

Do anyone else face problems with NFC and/or wallet after the update?
Seems NFC is not working any more.

I paid with my bank app using NFC and it worked. When you mention Wallet, do you talk about Google wallet?

Hi, since this seems to be the big thread for the update, I’d like to add another. I’m in Italy and my German SIM card struggled to log into the correct network for mobile internet, even on Android 12. Prior to the update I could manually pick the network and switch to the correct one. Now on 13 it just tells me there’s no connection possible on either of the available networks. It also used to tell me if the network is either 2G or 4G, nor they are all displayed the same. Look…

So my somewhat solvable issue became a problem.

1 Like

Yes, I talk about the Google Wallet

I paid using Google Wallet after the Android 13 update yesterday. No problem. NFC in general works just fine.

1 Like

Maybe you could delete your card and add it again in Google wallet.

I also updated to Android 13 yesterday and everything seems more or less fine except the wifi connection.
It disconnects and reconnects every few seconds.
I use a Fritzbox router with a WPA2+WPA3 2.4 GHz wifi.
Changed between WPA/WPA2/WPA3 but no success.
My two notebooks with MX Linux and one OpenWRT router got the same problem.
I made the wifi on the notebooks more reliable with manual connection settings and some time later fixed it with a kernel update.

I found another bug.
You can’t hear the ‘beep’ tone when you call someone.

You can add what we think is a DNS issue (or certificat issue) with custom DNS resolver.

Ok the wifi issue is not really a wifi issue…
I got the same problem with my usb-c lan adapter which worked before.
Now the lan connection drops every second.

I also use Wireguard to connect my Fairphone to my home network which provides ad blocking and dns resolving through Adguard Home and Unbound.
This still works.

In your router, do you have a WPA2-only mode?
I’m asking this because FP3/ Android 13 causes issues when WPA2/WPA3 combined mode with SAE.

I can use wpa + wpa2 or wpa2 only or wpa2 + wpa3.
I tested all of them.
But like I said, it’s the same with lan.
Doesn’t matter if wifi or wired lan.

Thank you… Well, then I will try again.

Thank you! I will try

Have a look here

I don’t have a lot of the other issues mentioned in the thread but I have found myself with a phone that will mysteriously crash in landscape mode. To fix it I’ve turned off autorotation. Anyone else experience it?

PS - haven’t quite noticed the fingerprint issues but I’ve trained myself to not really depend on the sensor anyway

It is a known problem that should be solved in an update.


I already tried this and my OS is also updated to the last version 7.56, same for my repeaters.
I also tried a static IP without success.

Hello there,

I got the update yesterday. Mostly, it runs fine, except for a few problems.

As someone else, I can’t cast my screen anymore. It causes the phone to “half reboot”: no shutting down, but the starting animation. I have to unlock the phone with the pass, and can’t use my finger, just like a first login after reboot. But I don’t have to enter my PIN code, the sim stays connected.

The phone takes a long time to ask for the PIN code. I think it’s Android who delays it so that it can start the phone faster. So, the phone starts, I log in. A moment pass, like 5 - 10 seconds, and it asks for the PIN. When I enter it, I get disconnected and must log in again. More problematic, the messages app may start before the sim is connected. There isn’t any problem with SMS/MMS. But for RCS, the app thinks there is no compatible SIM. The only solution is to force stop the app and re-open it, so it will re-detect the SIM card.

And last, and not the most important, I got some issues with the auto-luminosity. Sometimes, it just keep going up and down until I move to someplace else. In these moments, luminosity isn’t changing smoothly, instead it’s going by little steps, which feels a little bit like flickering.

If this is of any importance, I live in France, and using french sim and wifi. My phone operator is Orange, and my internet provider is SFR.

That’s all I’ve seen for now, thank you very much


Hi. I have an FP3 & am having the same issues with the phone not recognising the SIM card for nearly a minute after switch on.


i am consernd about updating my phone. for some reason i am unable to make a backup of my signal chats. i guess because i installed it with f-droid or aptoide, i cant remember. and instead of creating a new topic i may ask here, will my chats will be gone after the update to android 13? i remember that all my pictures where gone after i upgraded to android 11.
so i am asking everyone, was something gone or different after upgrading?