FP2 Won't turn on or charge - See first post for troubleshooting

thank you so much for answering that quickly!
Yes, a lot of problems… I already contacted the support last saturday because the camera doesn’t work. Till know, I haven’t heard anything from them. But: also there, I tried a lot of things and nothing worked. So, probably a replacement is the only thing to do.

Well you’ll probably not hear back from them on a weekend, but I’ll summon @anon48893843 to make sure someone answers your support ticket.

Thank you for your support!

When I turned on my new fairphone for the first time, the screen turned on and showed the “fairphone-logo”, but nothing else. I tried two diefferent chargers wtih different ampere and one batterypack with no result. No reaction when I pushed the start-button. I was just about to dismantle the whole thing to remove the screen when I tried the soft reset that @detobi suggested. The phone vibrated a few times and when I released the buttons it started as it should! I have also succesfulle charged it with my 5V 0,8A charger. Thanks for the tip!

1 Like

I have had similar problems:

  • The phone has become dead once or twise even though it was charged. Had to take the battery out and in to restart…
  • There’s an issue with scrolling. Its like the srceen doesent understand where my finger is touching. Usually works better after putting it to sleep and starting again. The problem usually occurs when charging for some reason.

Is it this problem?

It’s reported to be worse while charging.

1 Like

This is exactly my issue and worse when charging. But it was worse in the beginning. Have been working better lately.

Trying the fix with the settings now.

Thank you!

I have the same problem. Worked normal for one day and getting suddenly black screen. Only difference I have is when I put it on the charger with battery I get the red light. So I REMOVED the BACK COVER, and simply pressed the on button without the back cover case on and it worked !!!

1 Like

I have my FP2 for 2 weeks. First it worked perfectly fine (no unusual problems), but a few days it suddenly got a black screen and won’t turn on anymore. If it is plugged in the led light (left corner of the screen) works. I tried charging the battery for a long time, holding the power button for a long time, removing the sim-card and battery multiple times, and removing the back cover, still nothing.
After reading this thread I also changed the cables (tried a new four threaded data usb cable and a 5v and 1A charger), still the same.
I also haven’t dropped it once, it hasn’t gotten wet, no dubious apps installed…
What can I do to make it work again? Thank you!

1 Like

Hallo Michaela,

I have exactly the same thing, have just bought a new cable and will see, I also use Mac and hope to use FP2 if it gets itself going. Was wondering if you wanted to get in touch, am not in Munich at the moment, but I live in Lehel normally and will be back March 10. Debbie

Hallo Debbie, dann können wir doch deutsch schreiben. Ja, gerne, ich habe in meinem Bekanntenkreis leider niemanden der sich das FP2 leisten wollte. Hier ist meine private Email, schreibe mir, gerne:
info@michaila.de
LG
Michaila

Me and my partner got our new Fairphones 2s just a couple of days ago and have been very happy with them since. But today when my partner got home she realized hers had died even though it had about a quarter of battery life left. Since then I’ve tried to simply load the battery but that would not work so i tried to switch battery between the phones but her phone still did not respond to the on/off-button. I get nothing more than the red light loading indicator when plugging it in the charger. No vibrations, no screen activity, NOTHING! The phone has not taken any hits or been in contact with water. Any thoughts on what could be causing this?

Kind regards,
Karon

Hello,
My fairphone 2 can not be started. It just show the android symbol, nothing more.
Without influence the phone became warm. In this time i diden’t use it. I cant start it now. What can i do?
Sad greetings
Henk

Hi,
got the same prob with FP2. Used for a few hours, try to recharge. Now i’m not able to switch it on.
Only i can see a tiny red led in the front flashing. thats it. Will try to use different rechargers, but mine exactly fullfills the prereqs (OUT 5V 1A)

Greets
Joseph

So, I put my FP2 on to charge yesterday morning (battery was at 35%), however, when I returned to it several hours later the screen was blank and unresponsive.
At times there is a red led visible (on the top left hand corner of the phone) sometimes this is blinking, sometimes it is solid, after a while it may disappear altogether.
The charger is definitely the correct type, it is new and was purchased from Fairphone. Furthermore, it seemed to be working fine a couple of days ago.
I have tried removing the battery etc as suggested in other threads. The phone occasionally vibrates and the Fairphone Android screen appears briefly before it vanishes. Very occasionally I get a screen that shows me the battery is at 0% but charging. It has been on charge overnight but this morning I still have a blinking red led, a blank screen and unresponsive buttons…

I emailed support but it may take up to 8 working days for them to reply! In the meantime, I have no reliable means of communication!
I am so disappointed in this product as I wanted so much to support the Fairphone vision. At this point I am not sure whether to persevere and try and solve the issues or simply to return it immediately for a full refund. This was an enormous investment for me and I am worried that if I wait for a response from support I will find myself out with the 14 day, no questions asked, returns policy.

Is this a faulty phone or am I doing something wrong? Surely the ability to charge one’s phone battery quickly and easily is a fairly basic feature? Surely such issues would have been ironed out as the product was developed? And yet it seems I am not the only one having problems…

Has anyone else successfully resolved the same problem? Can anyone offer some advice? Thank you!

Hi @Fern,

I have exactly the same issue since yesterday night and the complete discharging of the battery when I was travelling; so no real choice. It is extremely annoying and embarrassing notwithstanding the fact it also disappoints me enormously. It is not the only issue I’ve been facing since I got my FP2 two weeks ago but I have been very tolerant so far. Unfortunately this issue completely paralyses the phone and consequently the two SIM cards.
I hope someone has an idea because this simply means I don’t have any phone anymore.

Cheers,

Fab

If there should be a problem with your phone, i wouldn’t worry about the 14 days; after all you have a warranty by law for faulty goods. Also, is you still want to support FP you could also change it for a new one. With every vendor and product there will be a small part of faulty devices.

So you mean blinking? To my knowledge it means battery is 0%, so maybe there’s an issue with charger. But indeed, some people reported problems with their charging cables, maybe d newer data cable would do the trick.

Hi @Fab87,

Sorry to hear you are having this problem too… I sent an email of intention to return my FP2 on Monday morning, they responded on Thursday.
I was definitely using the correct charger as we’d bought it from FP specifically for the new phone. Also, it seemed to charge okay for a couple of days.
I too experienced other problems that I was prepared to put up with but once the battery would not charge and I was left with no means of communication, no means of accessing any of my contacts, and such limited customer support I’m afraid returning it ASAP seemed like the only sensible option. It is also concerning to read so many similar reports here on the forum… it didn’t fill me with confidence.
I would contact them immediately with intention to return but make it clear there is a problem with the phone.
Good luck,
Fern.

My brand new phone worked perfectly fine yesterday. Battery was still ±75% when I went to sleep. This morning, it would not turn on anymore. Didn’t drop it, nothing strange happened, just placed it on the table.

When I try to charge it now, it does show the battery charging screen, and the ‘Fairphone’ splash screen, but then the screen turns black again.

Obviously I’d like to be able to call. Anyone knows how to solve it?

Hi - I had a similar problem, just to let you know this worked for me, so thanks very much!!