FP2 stopped working. FP2 no working

Hi, to everyone

Last night the battery of my FP2 was around 90%, without plugging it to the charger. It was on flight mode as I always do at night and no GPS or other data working, today I woke up and surprise! My FP2 was not on. If I plugged it to the charger, at the beginning(the first 5 seconds the red light remains on), after this time the red light starts blinking, but nothing else is happening. I’m trying 3 different chargers and I also took the battery out and put it on again, but the result is still the same: My FP2 is not working and the red light is blinking in case that I plug it on a charger. My FP2 has been plugged now for 5h and still not responding if I try to turn it on….Any idea?How should I proceed…?

More info: In case that I take out the battery and I plug the charger without the battery, the screen is turning on and “FAIRPHONE powered by Android” text appears on the screen and then the phone is rebooting continually. So the phone looks “”“good”"" and it seems that there is an issue with the battery or the “process” or link from the charger system to the battery… In case that the battery is already inside the phone and the screen never turns on and the red blink process starts directly…

I checked the battery voltage when I took it out using a multimeter and there are 4.0V between + and - so looks ok.

Regards, thanks in advance!Have a nice day to all!

Please try the battery reset as explained in the #batteryguide.
If that doesn’t help please continue in the following topic to avoid duplicate topics: