FP2 OpenOS Android 6: can't install APK

Hello all,

Have a bit of a problem since the OpenOS Android 6 update happened (via the Fairphone Updater):

1/ Amaze dissapeared (normal) but I can no longer install any APK :
When using the internal Parameter - Storage & USB dialog, I can access the APK to install… but when clicking on it, I get a “Impossible to Open File”

2/ I have read that when you use another file manager (Amaze, FX, Ghost Controller, etc), the problem is solved
The problem is, how to install any of those when you can’t install an APK ? Remember, this is OpenOS, so no “store” pre-installed. Even to install FDroid, you need to be able to install an APK.

3/ Probably unrelated but of course, Osmand~ maps got messed up and can no longer find their files. I wouldn’t mind uninstalling it and starting over via my wifi access, but for some odd reason, when I go and try to uninstall Osmand~, the option is grayed out under Parameter - Applications. Impossible to clean it out. I had a “terminal emulator” installed before the Android 6 update but this one also dissapeared…

Any clues as to what I can do to get out of this mess ?

I’m not sure why osmand won’t uninstall, but the other bit:

Aparently can be worked round around by launching apk files from the downloader, or at least installing f-droid (and then using that to install e.g. amaze) works:


Alternatively, adb sideload should work.

1 Like

To be sure, I put the FDroid APK (that I had transfered from my computer) in the download folder and tried to install via the download app (which is just the built-in file manager…). No success.

Ok so went online via Wifi, using the built-in navigator and got the FDroid APK that way instead of via a computer transfer.

The odd thing is that the APK let itself be installed (so it worked!)…even though it was completly indentical to another FDroid APK sitting right next to it in the same download folder. I suspect there must be some “access rights” issues here from the computer transfer.

To be sure, I uninstalled the FDroid and started over via the Download menu … and this time, both APK worked (the older one and the one via the navigator). This leaves me just surprised but points to access rights again.

Started downloading what I need via the FDroid and must now figure out why the OSMand~ won’t let itself be uninstalled. FDroid updated it but he somehow cannot find the 6 GB of maps that are already installed… Will keep digging but I am definiltly much further now.

For uninstalling OSMand~, I found where the issue was. I had to go to Security - Administrators for this machine : uncheck OSMand~

Somehow, he had administrator rights and thus disabling any uninstallation possibilities.

All problems solved now and I’ll get back to redownloading my maps and apps. Many thanks !

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.