English

Updating LineageOS with nightlies

Hello - I just want to make sure that I will do the right things and that I proceed correctly :slight_smile:
I plan to update from lineage-14.1-20171121-nightly-FP2-signed.zip directly to lineage-14.1-20171212-nightly-FP2-signed.zip, omitting the ones between.
Is this all right, or should I proceed step-by-step and not skip any?
I download the .zip from https://download.lineageos.org/FP2 and copy it into the download folder on the sd-card (I use HandShaker with convenient drag-and-drop) — I shut down the FP and reboot into TWRP — I tap install (navigating to the .zip sitting on the sd-card) — I tap reboot system.
Will that be it?
Detail: should I include the addonsu-14.1-arm-signed.zip again, or every time I am doing an update, or may I forget about that if installed once?

1 Like

Skipping versions shouldn’t be a problem AFAIK, but why don’t you just use the OTA updater in Settings -> About Phone -> Lineage OS Updates?
You don’t need to install addonsu again - at least not with OTA updates.

4 Likes

ok, I did go to the OTA updater, chose the latest version, the download started, the phone switched to TWRP — and then what? which of the buttons should I proceed with? I assumed it was automatical, at least I got that impresson when it started. Shouldn’t the updater download the file and just ask for confirmation to proceed now and then? … I’m a bit confused at the moment. (restarted the phone, have to go for just now… will resume the operation later)

It is normally. Something must have gone wrong.
On my FP2 TWRP automatically does it’s thing for a few seconds and then the phone restarts into the updated Lineage OS.

2 Likes

As paula said, it should be automatic. Information which might help us to help you: Which version of TWRP are you running? Is your phone encrypted? What exactly does TWRP show? Could you copy the logfile here or take a picture?

1 Like

TWRP is v.2.8.7.0
encrypted: not
TWRP shows this (couldn’t take screenshot, used compactcamera instead - and just missed the top…):


where and how can I get a logfile for you?
whatever I try to do after I’m on TWRP’s screen with the big buttons, the phone gets stuck, won’t budge any more. Just a minute ago I tried Install, had to resort to pressing power button looooong - phone reboots in TWRP again, I try “power off” - it lights the button and pffffft_ nothing more.

I just read that you will need a current version of TWRP (>= 3.1.0.0) since partitions have changed. Unfortunately this information is in german ( https://www.lineage-os-forum.de/Thread-LineageOS-LineageOS-14-1-update-installieren )

2 Likes

The currant TWRP version is 3.2.1-0

1 Like

I just finished installing TWRP 3.2.1-0, following the instructions on https://wiki.lineageos.org/devices/FP2/install and was about to check if that was successful. So I will once again follow Paula’s instructions and try to update via the installed routine in the settings.

1 Like

Another information I found. If automatic update does not work you can try to do it manually.

  • first check if the update has been downloaded correctely; you can find it in directory
    root:/data/lineageos_updates
  • boot into recovery mode, choose the zip and install.

(http://www.zdnet.de/88290757/lineageos-updates-manuell-durchfuehren/)

1 Like

it seems to work… but again stops at the TWRP screen with the big buttons: which one should I tap?

Thanks, everybody!
The updated TWRP did it’s job prefectly! I had a minor shock when I got to the big buttons again and TWRP stopped there, but I decided to tap on Install and to see where it would take me: it worked, I got to navigate to the previously parked zip-file on the external sc-card and had that installed (with signature unchecked) - successfully done. And then, surprise, TWRP asked if it should be installed as an app – no objections there, and voilà, everything completed, phone rebooted and the user is happy again.
Hats off from me to all the friendly mods and users who are so competent in helping the clueless…

2 Likes

Just for the future, in TWRP you can press this icon to switch between the big button menu and the logfile:

2 Likes

Thank you, m4lvin, good to have learnt one more thing – I hope I will remember next time I’m asked.
While we’re at it: there IS something that has come up meanwhile, related with TWRP. I wrote:

So I did consent to TWRP being installed as an app… but when I went into the apps list and tapped on the icon to start it, I was informed that what I had activated was only a placeholder, and that I had to actually install the app. Looks like this:


I tap «website», and on the next page

I choose «Primary (Europe)», and I get this page with the list of apk’s:

I choose the top one and tap on it.

I tap «Download … apk».

«Herunterladen» (to download) is what I want — tap!
After a while, I check in «Amaze» and find the file ok. But what should I do to get the .apk installed? There is no option in the menu…

I never installed or used the TWRP app. As far as I know, having it installed as the recovery is already enough. Or are there any extra functions only available when it is also installed as an app?

About installing the APK, it should do so if you tap on the file in amaze, without holding to get a menu or any “open with …” but there have been problems with this, I think mainly (or only?) on OpenOS, though. See here and here.

1 Like

I imagined the «extra functions» in having it as an app would be in the ease-of-use, like tapping an option and then it would execute a script and I would not have to feel insecure whether to press volume-UP-plus-power, or rather volume-DOWN-plus-power, etc.etc. But maybe your skepticism is justified and I shouldn’t bother and just get those manipulations in my head at last (or make a note and stick it to the monitor) :grinning:
Thanks, that was exactly what was irritating me: I thought I remembered from other apks that I had simply tapped them in Amaze… but here, nothing happened, and then nothing in the menus… But hold on!—— I just gave it another try — and this time it was no problem at all. Must have had a case of thick fingertip or sth. like it. Whatever: thanks! Problem solved.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.