FP2 not rebooting after updating to 21 / Android 9

Well, than I should wait till something pop up? It was flashing for 4h and nothing happend…

No, it was not flashing for 4h but waiting 4 hours for you to flash it…
To do that - you’ll need the laptop you’ve mentioned above and connect your phone via a USB cable to this notebook.
Next step would be to download the manual installation files from https://storage.googleapis.com/fairphone-updates/13484ddf-8791-4a7a-a876-641d5e8eb3ab/fp2-gms-19.11.2-manual-v2.zip
(as mentioned in the manual installation documentation)


Any computer device can fail you at any given most inconvenient time.

You could take your SIM card out of the phone and put it into another phone. If your phone is important for your profession, there must be some sort of plan B? Just saying.

Else … @Volker is right. The manual install is your fastest option to resolve the issue on your Fairphone 2. And you don’t need to pick up another profession to do it, many non-IT specialists have done that before.


The word ‘flashing’ is confusing here. @kubeti - ‘flashing’ can refer to both the blue light flashing on and off, as well as the process of applying new core software to the phone.

Sorry you’re getting the problem when under pressure from clients already. I’m also busy for the next few hours, but will try to help a bit.

Have you seen the recovery instructions here yet? Manually install Fairphone OS for the Fairphone 2 – Support

And you’ll need a computer to connect the phone to - what computer are you running, windows, mac or linux?

Windows. Process not working. File .bat activated, could not find the device (it is data cable), blue light flashing (booting mode), I do not know what else to do

This here was posted for a Fairphone 3+, but the process ist the same for the Fairphone 2 …

There’s also this …

There was a time when fastboot on Windows was the most robust thing and the last thing to fail. We need a time machine.

1 Like

Not possible do anything. 3laptops, 5people involved, there is no Other device or Android. It is NIGHTMARE!!!

You could ask your mobile network provider whether they could reroute calls to a phone in your office or institution temporarily.
(Hopefully there’s a landline or somebody will lend you a phone for the call.)

What got to be done, if this fails?
[finally, my FP2 even does not boot anymore, after factory-reset…]

Before, I tried to manually install via fastboot.
It mentions in the cmd.exe-Windows different things, but never anything, which leads to success:

** Fairphone OS 19.11.2 Manual Flashing Script **
Validating files…
All files are valid, let’s go!
One device in fastboot mode is connected.
Proceeding to flash the device.
< waiting for ??? >

or that it could not flash the rpm partition on device XYZ

2nd memory and sim-cards are out

finally, I escalated…
wipe cache partitition: no changes
factory-reset: no changes

it keep on sticking in boot loops, just showing:

“FAIRPHONE Powerded by Android” plus buzzing again and again (all about 45 sec or so)

or [in the “Power” PLUS “Volume-down”-Mode] “FAIRPHONE Powerded by Android” without buzzing but with blue light

with battery in and out,
connected, or not…

What else could be done???
Thanks for your help!

(I E-mailed the Support-Team last monday, but no reaction, so far :frowning: )

1 Like

I’m stuck in the same loop for days now… Finally I managed to put my FFP2 into fastboot mode and start the manual installtion today. I now two times recevied the message:
“Could not flash the modem partition on device xy.”

Any idea what to do now?

I neither couldn’t find “android” in the device manager. When I conntected other android devices, they appeared in the field “transportable devices”. Since I checked if these updates were ok (it didn’t work to follow the instructions and update google inc updates) I could finally connect my fairphone in fastboot mode and start the flash process, which cloudn’t finish though.

now I also tried to flash a smaller Android 5 version. Also without success. Here two jpg’s which tell a bit more, what does not work. But: what to do now?
(sorry, no jpg’s, forbidden for new users… :frowning: (Also I am actually not new, but could not log in anymore, with the account I used 2 years ago, without having changed my password)

in the “…system32\cmd.exe”-window, it is said:
sending ‘sbl1’ (274kB)… ok … writing ‘sbl1’ … ok …
sending ‘modem’ (57377kB) … Failed (data transfer failure (Unknown error)) … finished … Error: could not flash the modem partition.

The only halfway encouraging reference I’m able to find for this is this …

thanks, but not encouraging for me at all, I tried that in all combinations, with android 5 as well as 7, now for about 30 times. No way. Even the sending process of bigger data seems not to work. (Is Fairphone demanding for updates, even if the system-requirements are not sufficient?)

Thanks for all the help here on this thread. My phone also melted down today after trying to update to Android 9. So I managed to do the manual (re)install of the previous version, and my data hasn’t been lost either. I feel reluctant to try and update to Android 9 again now though, after all the stress today! Has anyone else had all these problems and got their phone up and working again with the re-install and then tried to update to 9? How has it worked out?


Also from me many many many thanks for the help in this thread. The update yesterday went wrong and the stress a loop can give you… but you all saved my day. Again thank you!
I’m also not to keen on trying another update and will leave it like this for now. In June I have my FP2 for 5 years and I think its time for a FP3


@Manon_A_Borsje @Spokes Glad it’s been useful for you. In my case, I removed some apps after getting the phone working again (just in case), and re-attempted the update to Android 9, and it went fine aside from one manual reboot. Been running Android 9 no problems since then, and just updated to the latest release without a hitch.

@AxelS @Jufi Sorry to hear it’s not been better for you. @AxelS - have you tried doing Power + Volume Up (instead of Down) at reboot, as suggested near the top of the thread?


yes, of course (sorry, I wrote volume-Down, but meant volume-up); It does not boot successfully even after the factory-reset…, whether booting in normal or -up-way… Is there anything left, what could be done/tried? Pretty bad, what happened - complete crash of the phone - while making a normal update.

If fastboot is still able to flash TWRP or to boot it temporarily (see #twrpwoflashing), you could try to install the #modemfiles with TWRP (either directly with TWRP’s Install function if you can get the ZIP file onto the phone, or via Advanced - ADB Sideload).
If this works without errors, every partition for which there is an image in the modemfiles ZIP file would be taken care of, and flashing the rest with fastboot could be tried manually one by one.

Have you tried flashing each image manually? (open the images folder, and flash each partition with fastboot flash {partition name} {partition file} in fastboot mode)