English

FP2 not rebooting after updating to 21 / Android 9

Ok, thanks, now I know what you mean. I don’t think that should apply here. Especially now that you’ve done a factory reset and the data partition should be cleared.

Yes, you’ll need a working usb cable for the manual installation. You might check the cable by going to #dic:fastboot and typing fastboot devices which should show the code of your device if all is working.

I’ll keep my fingers crossed! :crossed_fingers:

1 Like

Great news: the manual installation eventually worked!

Thank you infinitely for your answers!
I really was on the verge of a nervous breakdown here (in full isolation ugh) so it gave me a push to stay calm and keep up with the instructions :pray:

4 Likes

Congratulations, that’s great! :+1: :slight_smile:

1 Like

Glad it worked - I had the same feeling when my phone failed to restart!

1 Like

I have the sam issue as @scribe and @Ludwina

After upgrading the Fairphone now i cannot leave from the TWRP menu. I will try again the manual update with the computer. I did it yesterday but the window kept saying there was no Fairphone connected. Hope it works now!

If the Fairphone is not detected and your PC is on Windows 10: here is a HowTo install the necessary drivers via Windows Update

3 Likes

Thanks @Ingo I have FP2 and I’m trying to connect it to a macbook.

I’ve tried following the instructions as here: Manually install Fairphone OS for the Fairphone 2 – Support

But the computer doesn’t recognise my FP2, so I’m still stuck at the TWRP menu.

For Mac you might want to watch this issue: Stuck in Recovery Project (#50) · Issues · products / Android 9 on the FP2 · GitLab

There is no solution yet but it seems like the same problem, also with Mac.

2 Likes

Yesterday I downloaded the new Fairphone II Update (directly on the phone, not via computer). After that I did the requested new start. Then “Fehler” (failure) appeared on the display for a short time. Then it changed to a black display, with “Fairphone” on it (like the start display). Nothing moves, and the phone doesnt start. I can only stop it by removing the battery. When I want to start the FP II again (with the battery inside), its the same situation.

Maybe the battery was a problem during that process. At the beginning there was enough battery. Later not. So I charged the phone completely again. If I charge it now, there is a green light. So I guess the battery is complete now.

This year I bought a new bottom module, so that should not be the problem.

I already spent lots of time at the Fairphone Forum and at different Fairphone helping sites, but I could not fix the problem yet. Do you have an idea? I really would be very grateful for that, since I dont want to lose all my stuff and numbers! Thank you very much in advance!

Hi and welcome to the community forum!

I moved your post here to the existing topic with the same problem. It seems people were able to fix the situation with a manual installation. For the details check the earlier posts.

1 Like

Hi DaG, that does sound like what I hit. If you hold down power+volume up when restarting the phone as per this post above, do you get the Recovery menu?

Hi,
I pressed volume up + power, then I was here: Android Recovery / 7.1.2/19.11.2.
Then I did the following:
“Reboot system now” (I press power + volume up, this option gets green then and the FP II trys to start again. But the black display only showing „Fairphone“ stays the same).
I press power + volume up again, then it says: “No command” (and the lying robot above). Again I press power + volume up and reboot system now, and again there is that black display with “Fairphone”.

Do you have any idea? Maybe @scribe or @urs_lesse who had that problem, too? How did you manage it finally? I am so grateful for your help - I really need the data and numbers on my phone… Thanks!!!

Other options at “Android Revovery” are the following (I really hope NOT to have ro reset everything!!!):

  • Reboot to bootloader
  • Apply update from ADB
  • Apply update from SC card
  • Wipe data / factory reset
  • Wipe cache partition
  • Mount / system
  • View recovery logs
  • Run graphic test
  • Power off

Same with me. I already tried the “Wipe cache partition” function bit it it didn’t change anything. The Phone is still stuck in the “Fairphone powered by android” screen.

I can only repeat the advice I gave further above:

As scribe says a little later, the manual reinstallation of 19.11.2 seemed to have left his personal data intact.

4 Likes

@DaG @Pons Same here - I think I wrote up what I did above, but just to be clear:

  1. I downloaded the latest 19.11.2 binary image (Android 7) as per this page, and installed it via adb/fastboot using my Linux laptop. I had adb setup from a previous tablet, so I’m afraid I can’t help much if you’re on Windows or Mac currently.

  2. That went fine, so I cleared out some apps to ensure I had enough space, and then re-tried the update to Android 9 via the usual updater. I had to reboot once as it got stuck on the Fairphone screen, but it loaded OK after that. (I didn’t have to repeat any adb stuff or try the updater any more times.)

Good luck!

2 Likes

Hi!
I just wanted to say thank you for all the explanations over here. I encountered the same problem as described and with the help of this forum I could fix it!

6 Likes

Hello, I am sorry for disturbing. Looking for a help urgently. After update Android 9, ill robot is lying at the black screen, no command sign. I am really not IT, I am doctor, clients will call me tomorrrow and my phone is dead. I am not able to install anything from laptop and even tried, waiting for 4h of blicking blue light to reboot mode. Can you tell me how to get my previous android? Thank you

“Ill robot” is #dic:recoverymode , blinking blue light is #dic:fastboot .
So did you try manuall reinstallation of Android 7 (“I am not able to install anything from laptop”) as mentioned e.g. in this post?

EDIT: and does it always end up in recovery mode (“ill robot”) now when you try to boot the phone?

1 Like

Thank you for reply. No, no manual, I am not able that, I bought the phone cos of world social reason, not to have other profession :confused:
Back to your question, yes is ended up with ill robot. Power+Volume up I tried as people here mentioned, than first Reboot - ill robot always. I tried Powew+Volume down, flashing blue for 4h with no action/screen.

I can completely understand that.
Still as something seems to have gone wrong during the update I only see the manuall install as solution in case you’ll need the phone back fast… (and if you have a working USB cable and a notebook it might not show to be too difficult - and with help maybe you manage to do that…)

Yes, that’s normal. This is (as mentioned above) the fastboot mode. This would be needed for manual installation but in this mode it’s normal that it indefinitely stays like this until you reboot again (it’s waiting for fastboot commands…).

2 Likes