FP2 is an unknown device via USB to Windows?

Hi Fairphone angels,

a friend of mine got a bricked FP2 through an update. We dont know why it happened but he asked me to help him fix it. The first problem which holds me back from fixing is that Windows points out that it cant recognize the device when connected via USB to the computer. Weird, because I also owned a FP2 for a few years (before my FP3) and Windows recognized it anytime. Yeah, sometimes ADB had some trouble but thats another thing. Do you have some thoughts to help me overcome this issue?

Many thanks in advance!

Which version of windows is it?

And what mode is the phone in? Recovery? Fastboot/Bootloader?

How exactly did you check “is not recognized”? Did you run any commands? Looked at the device manager?

Running Windows 7, FP is neither in recovery or fastboot recognized. As soon as I plug it in, Windows shows this message of an unknown device

I don’t know exactly how Windows 7 would behave (it was long gone in my environment before I got any Fairphone), Fastboot usually shouldn’t need much from Windows to work.

Please confirm that with the phone in Fastboot Mode and connected via USB, the fastboot devices command doesn’t find it.
If this is the case, is there an error message?

I confirm that with the phone in fastboot mode and connected via USB the command line in adb cannot find it as you can see here: adb
Also you can see how Win7 behaves when the FP2 is connected via USB (its in german, sorry):
win7 - usb-device unknown win7 - usb-device unknown2

Well, honestly I think there are even many more important reasons than a driver problem to move urgently away from Windows 7…

That ADB can’t find the phone in Fastboot Mode is normal, only the fastboot command works in Fastboot Mode.

That the fastboot command can’t find the phone is an issue, but at least the fastboot command doesn’t throw an error message already just for running it, so it indeed seems there’s driver trouble.
You could try whether these resources here fix it for you …

There are driver/ADB/Fastboot installers for Windows, too. If the driver alone doesn’t help, perhaps you might want to try those, perhaps they do the trick …

Usually every USB device has a programmed string that is submitted to the OS when the device is connected, considered that communication works. (In Windows, this string can be read in the device manager, probably with an exclamation mark next to it.)

Situations where e.g. Windows reports an “unknown device” are when there is voltage, but no data flow. The string is not submitted to the OS. (It is like meeting a person whom I ask “Hi, who are you?”, and the person just does not answer.)

Seems like the device (FP2) is bricked and cannot communicate over USB anymore…

This is the case now, yes, but the owner, my friend, told me that Windows on his computer were not able to find it before the FP2 was bricked and got the same message.

That could be a bad coincidence, but have you checked the pins of the FP2 USB jack as well as the USB data cable?

I cannot install these following the installation guide: due to the fact that Win7 cant detect the device, it is not shown in the device manager, so Im stuck on step5 of the installation guide and cant go further.

When I want to download the file it reports on the page “invalid file”.

The USB data cable is brand new so this is fine. I cant see any peculiarities on the FP2 USB jack, seems fine to me. The bottom module is new, my friend replaced it about a year ago.

Isn’t it shown in the Device Manager as an Unknown Device under the USB Root Hub entry in the same way as in your screenshot? This should allow to install drivers for it manually by right-clicking it in the Device Manager (similar to what the guide suggests for when Windows can identify it).

Unfortunately, not :frowning:

In Device Manager you can enable View - Show hidden devices.
Is it visible then, or is anything maybe conflicting visible there (other smartphone names, older drivers, anything with “MTP” or “ADB” in its name)?

If so, perhaps a little generic cleanup might help … Trying to install /e/OS on FP3, but it hangs on fastboot on Windows 10 - #2 by AnotherElk … even if I don’t think Windows 7 would automatically install the necessary drivers like I’ve written there with Windows 10 in mind, but that’s where we are anyway.

You were right, it was hidden but when I tried to update the driver software with the Google driver or adb drivers it reports that the driver software is the latest.
This is the error code I see when I open the characteristics to the “unknown device”: unknown device eigenschaften

For code 43 this here suggests uninstalling and reinstalling the USB controllers, but I’m really just internet searching stuff now, I can’t troubleshoot Windows 7 much anymore remotely … error 43 when I try to connect smart phone - Microsoft Community

You could also boot a Linux Live DVD or USB stick on your computer to see whether Linux can get fastboot to work with the phone. I would recommend Ubuntu, because it is very popular and thus has vast online coverage for almost any topic.

So the same message appears on two different Windows systems? Then I would not mess around with USB controller/hub drivers anymore…

Maybe try another USB port, but I think that will not succeed either…

Already tried that and yes, it didnt succeed.

Unfortunately, this didnt help :frowning:

If your friend is lucky, it might just be a failure with the FP2 USB jack, although the bottom module is fairly new. Unfortunately such jacks belong to the group of most vulnerable parts due to daily plugging/unplugging of cables…