English

FP2: Fairphone Open 19.02.1 release

openos
nougat
Tags: #<Tag:0x00007fefbd860b00> #<Tag:0x00007fefbd8607e0>

#44

… many thanks, that did the trick!


#45

Updating TWRP and re-installing Open GAPPS did the trick for me. All apps are working again and no high CPU processes draining the battery. I should’ve read the general information regarding Fairphone Open updates :smiley:


#46

Fixed.
I didn’t had so much time to read in detail this threat. But now i did.

  1. Download GAPPS to reinstall (pico version)
    2.Twarp update to the newer version, since FP OS update downgraded TWARP. (Remeber to boot in recovery mode directly after updating TWARP)
    3.Reinstall GAPPS
  2. I had problems with Google maps, but i reinstalled it

Battery consumtion is back to aprox. 250mA/h.
Mental note: Only update FP OS in weekends. :smiley:


#47

Best practice for any OS :+1: .
(Adapt to “if you have time on your hands”, if you don’t have time on weekends.)


#48

Hi @Pascal_A - I’ve managed to get my phone back. I’ll tell you what I did based on reading this forum and others - some may not be necessary but they worked for me.

  1. I couldn’t boot into TWRP; I had to backup my SD card then repurpose as portable media (it was set to be treated as internal storage). Once I had done that I could boot into TWRP
  2. Once in I couldn’t re-install GAppsDownloader and Xposed Modules (I read you need to reinstall these after each update)
  3. I used the Official TWRP App to download the latest version and flash it to recovery
  4. I installed the image and then rebooted back into TWRP (I read that you need to reboot to recovery for the update to take) and am now on v.-3.2.3-0
    5, I was then able to reinstall GAppsdownloader and Xposed Module through TWRP

Having done all that my phone is working perfectly again - it charges when on, battery life is back up to over 24 hours and there are no heating issues with the processor. As a matter of fact it is all running cooler than it has ever done.

Don’t give up - I hope this helps you too.

S


#49

Ah, I just posted pretty much the same - didn’t see you had been successful too.

Excellent news

S


#50

Thanks, i fixed today too!
:smiley:


split this topic #52

A post was merged into an existing topic: Lineage OS 16.x?


#53

OS update was not as easy as the last time but I got it at the end.

Advantage: Bug to switch of the FP2 while the torch is switched on is fixed now. I can switch off the phone without problems.

Disadvanatge: It seems that there is a new bug because I can not connect my signal and WA account to contacts. Any help?

Cheers

Joerg


#54

I also had the problem of terrible battery drain and various (google) things not working in FPOpen. Thanks to this post I checked and found that TWRP had been downgraded. I had a similar problem with the original FP upgrade to Android 8 but had already forgotten about it!

Now I have latest TWRP and gApps; and also needed to set permissions for some apps. All is working properly again :smiley:

Permissions seems to be a common problem: usually if an app had its permissions removed it will ask again when it needs to do something, but they don’t always (eg. WhatsApp) and you need to figure it out.

Having thought about this for a day or so I realise there must be a good reason why FairPhone developers want a particular version of TWRP installed before system updates, so that’s fair enough. Those of us who want to meddle by adding gApps back into a system which has been carefully de-googled only have ourselves to blame!

So if we want to use FPOpen and then add non-standard parts we must also install a suitable base first (TWRP) and then get the latest versions of gApps, Xposed and whatever other things we like to play with. We can’t expect FairPhone developers to predict everything we might like to do with our devices.


#55

It seems a bit unfortunate that Fairphone bundle an older TWRP version with their OSes, with which some stuff unsupported by Fairphone doesn’t work.

But then it is a TWRP version Fairphone themselves build and control, which for them as a company is important, as the community TWRP theoretically could be abandoned or developed into something incompatible with Fairphone updates or else, how ever unlikely that may be.

So Fairphone play it safe in business mode, with some unfortunate side effects for those who didn’ t stumble across this before trying something which doesn’t work.
But that’s what the forum’s here for :wink: .


#56

We are very much aware of the situation and we are currently taking steps towards a source code release, however it is still too early to announce a timeline.


#57

Thanks for the response :smile: It’s nice to know that it’s at least being worked on :slight_smile:


#58

Is there any ongoing WLAN code work happening in the current kernel? Just thinking about the WLAN issues in the bugtracker ;).


#59

In the bugtracker and in the forum a lot of people said that they suffer from spontaneous reboots since the update (I tried the beta and it made my FP unusable as daily driver due to several reboots/day). Switching to Android 6-based Sailfish solved the problems for me.
Is there any hope the situation could improve? As the release notes don’t include a word on the reboot-issue, I can’t switch back to Android…


#60

Random reboots may be caused by incompatible apps or incompatible data configuration coming from the previous installation, you may want to consider a clean installation for testing (make a full system backup so you can go back if necessary).


#61

In principal you are right, but during betatest I made a clean installation. My comment is related to the issue
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/34


#62

and https://bugtracker.fairphone.com/project/fairphone-android-7/issue/182


#63

After the update I can’t charge my FP2 anymore. Both charger and charging cable are intact. I can only charge my FP2 with a Powerbank.
When I turn off the FP2 and connect it to the power supplies it is not charging with, the charging icon appears. However, the battery will be discharged instead of charged. What happened here? This was not the case before the update (18.03.1).

I can’t charge the FP2 anymore.


#64

18.03.1 was still Android 6, the current update is Android 7, so basically it could be some App running wild that is no longer compatible (maybe because of this bug https://bugtracker.fairphone.com/project/fairphone-android-7/issue/56).

Are you on FP Open OS or the regular OS with Google services? Did you flash something special for Android 6 (super user binary, microG, opengapps, …)? Those would need to be flashed again matching the now updated Android version.