English

FP2: Fairphone Open 19.02.1 release

Tags: #<Tag:0x00007f05da1a8880> #<Tag:0x00007f05da1a83a8>

This doesn’t work for me this time, I installed the update, TWRP was downgraded, I used the older TWRP to flash my 3.2.3-0 image, rebooted from TWRP to recovery, booted normally, then booted back to recovery and I am back on TWRP 3.1.1-0

Hi, I updated to Android 7 today and got a notification that there was a further update available to 19.02.01. I’ve been trying to do it for hours and it just sits at the “Download started…Just a moment…” screen, without any progress showing. Any ideas?

Alan

I’ve also repeatedly tried manually updating but repeatedly get the warning “No device found in fastboot mode.”

What is shown on the phone screen when that happens?

Are you sure you have a data cable and not just a charge-only cable?
Does the same cable/USB port work to transfer files to/from other devices than your FP2?

2 Likes

… and in case you try from a Linux machine you might have to use sudo fastboot

1 Like

Hi,

today I upgraded to 19.2.1 and had the very same issue. It turned out the file is uploaded from some URL blocked by Blokada (Google or alike). Temporarily disabling Blokada made FP Updater loading the update file quickly.

If You are running software like Blokada, AFWall+ or alike try temporarily disabling it.

BTW: Not so nice Fairphone relies on those strange data miners for playing out their updates.

Best Regards

Marcus

1 Like

Hi,
someone else has noticed if after update the device is not able to upload the report generated (under Maintenance/Hiccup)?
This is my actually situation:

There are so few crashreports because 3 days ago I made a master reset. Before the reports was about a couple a day…

I have also view that I haven’t the Device UUID :-/

Update on encrypted phone from 18.10.0 to 19.02.1 seemed to have gone well…

2 Likes

I had the same issue, rebooting into recovery after installing version 3.2.3-0 didn’t help. Using fastboot or the official installer app didn’t made any difference.
I then realized that the ‘swipe to allow modifications’ notification after a fresh twrp install didn’t show up although my system partition was mounted read-only. This prevented twrp 3.2.3-0 to make itself permanent during reboot.
The following procedure worked for me: install twrp 3.2.3-0, then reboot into recovery (verify that version 3.2.3-0 is running). On the main screen, choose Mount and uncheck the option ‘Mount system partition read-only’. Not sure if the System partition has to be selected as well in the upper screen part.
Then, reboot into recovery again. The new twrp version should now remain active. You may set the system partition again to read-only if you like.

2 Likes

Walter,

thanks for describing this solution. It worked on my FP2. Great!

My TWRP 3.2.3-0 installation finally is permanent now.

Front camera problem here too :confused:

This week i received my factory refurbished FP2. ( https://shop.fairphone.com/refurbished )
(my old have broken main module and i bought this instead of repairing as main module is expensive - I will sell some parts later after testing them out on this new phone :slight_smile: )

I decided to try Fairphone Open almost directly. So i told the upgrader to update to it (it took two upgrades as it was released with android 6). Now it report it is Fairphone OS 19.02.1.

The default camera app only use face camera, and offer no alternative. Same for the app Open Camera. The phone main settings menu, bottom item “telephone status”, say in Camera module info section: Unknown

Nice! thanks that worked

Same here. Since the update to V 19.02.01, my battery only lasts for 4 hours. For Selection “Kernel Wakelock” BetterBatteryStats shows 100% for PowerManagerService.WakeLocks and 99% for PowerManagerService.Display.
So is this OK or not?
Batterz was already on 0% and according to BatteryGuide currently also discharges to 0%.
I remember that same happened to my phone when installing the last update.

The update to Fairphone Open OS 19.05.2 is released.

3 Likes