English

FP2: Fairphone Open 19.02.1 release

openos
nougat
Tags: #<Tag:0x00007fefbdb56300> #<Tag:0x00007fefbdb561c0>

#24

I’ll leave this here as a last resort …

And in case a fresh install of Android 7 doesn’t seem enough … Links to installation files for Android 6 can be found in the “I regret upgrading, how do I downgrade?” section here …


#25

System updates are in my experience always a challenge. Be it Windows, Mac, or Android. Always need time, patience and tweaking. The truth is that software engineering by far doesn’t follow the same strict engineering quality standards that used to be applied to electrical and mechanical devices, for evident reasons of trying to remain edgy and ahead of the pack at any cost. Battery management is a typical example in modern devices, it’s ludicrous how badly it’s designed under an engineering viewpoint.

So never expect the transition to be smooth. If you do so, maybe you should ignore system upgrades, with all it means in terms of losing compatibility with future apps. Yes, smartphone ecosystems are a b*tch, welcome to the real world!

Personally I’m still waiting for the moment when I’ll have time available to do the upgrade, and I immensely thanks Fairphone for allowing my device to remain functional much beyond what any other brand would allow me to. And I also thanks all the tweakers that will make my own upgrading process much easier when I finally do it.

For the unlucky upgraders, a simple advice: think about resetting the data of your apps one by one, or start from a clean installation of the new system. You probably have a deep incompatibility between an app that still thinks you are in Marshmallow when the system is Nougat, and it wasn’t configured correctly for Nougat.


#26

Update went smoothly.
Installing Gapps failed due to old TWRP version.
After installing TWRP App version 1.13 I succeeded in installing Gapps.


#27

Quite old the 1.13 version, I installed the 3.2.3.0 yesterday.

@All
For who have issue with this new release my hint is to reinstall the specific application of your device. Starting from TWRP, then Google apps, XPosed,… And so on.
To be clear I didn’t think that are related to the FP Open software.


#28

First I must get back into my phone again…no success yet


#29

I beg to differ.
It’s the version of the app I mention, not the version of TWRP, which is indeed 3.2.3.0.
I know it’s confusing.


#30

Can’t stress this enough. If you’re relying on openGApps for google services / play store etc, you will need to reinstall openGApps after every update, or risk having an unstable, over-active (heat, battery drain), or non-bootable system. The advice in the guide, unless the update procedure is very different with this update, still stands:

The update may (in this case will) also downgrade TWRP. Check whether TWRP is still up to date before starting the update (or make sure to install it after the update completes. Remember to reboot from TWRP straight back into TWRP, or the TWRP update will not complete).


#31

I have followed the battery guide and even had to reset my battery to get any power to my phone.

Now I cannot boot into teamwin as it freezes on the recovery screen.
Root privileges are enabled but cannot grant super user access to all the apps that had it before
Battery has gone from 96 to 84% in 10 minutes
Phone is so slow to use it is almost unusable.
I would not expect this from an OS upgrade - it has rendered my phone near unusable

Not v. happy right now


#32

Dear Fairphone-Team,

since the Update (I did it today) my rear camera isn’t working anymore. Neither the main camera app nor WhatsApp recognise it. In the settings it is mentioned as “unknown”. I’m pretty shure that this is caused by the Update, because during the last days (i was on vacation) it worked fine and it didn’t fall down since then.

Am I the only one with this problem?

Greetings!


#33

This is a community forum, not the company.
Perhaps somebody here can answer, but in the meantime you might be interested in the #bugtracker .

Edit: Have you turned off and on the phone already (real shutdown, not just reboot)?


#34

I’d first check if taking out the camera, cleaning the contacts and putting it all together again already fixes the problem (in case a simple power off, cool down, power on doesn’t fix it first).


#35

I followed your instructions, many thanks.

Unfortunately, upon starting up with TWRP, I then cannot select/find the previously downloaded .img for TWRP 3.2.1 - although I do see in the same directories the recent downloads for the the opengapps (and yes, I have selected “image” at the bottom).

Any ideas much appreciated …


#36

Download the TWRP app in the play store.


#37

Same problem. Updated yesterday, and till now i have problems to charge the phone. Now i decided to turn it off and see what happens. During the night it went out of battery and it was permamently overheated…


#38

I have downloaded the TWRP app, but not in the Play Store (since the Play Store is not working after the update) …


#39

OK, solved: for some reason, the TWRP app downloads the .img files not into the Download folder, but elsewehere. I moved them to the Download folder and can access them from TWRP. I am flashing with the new 3.2.1. image (following @fp2user-2000), but apparently without success - after rebooting, the version of TWRP remains 3.1.1.


#40

Most often it’s a case of when trying to update,


#41

After updating today with FP Open 19.02.1, at first everthing seemed to work smoothly. However… something came up after all.

  1. As far as I can see, I have an issue since the 19.02.1 update that doesn’t seem to be mentioned yet. The orientation of the front camera is now upside down, and the live image is very obscure. Reboot makes no diference, nor does switching between fixed or automatic orientation. However, the orientation of the picture made with this orientation is upright again, with normal quality.
    However if the front camera is activated via Whatsapp, all is normal! Is there a workaround for this? (I still have the original camera module in my FP2.)
    Front video is normal, the live image has a normal orientation and clarity.
  2. I am still a bit dissapointed that the possibility to switch between SIM-cards is still not fixed. Is there any hope this will happen any time soon?

#42

TWRP-app
To install the new TWRP version you have to use the app itself.
Install the app and open it.
Agree to the Terms.
Select TWRP Flash. Select your device from the device list (FP2) - FP2 should already be selected.
Tap on ‘Download TWRP’
Choose 'twrp-3.2.3-0-FP2.img
Tap on Flash to Recovery.


#43

Hi all,
24 hours after this update i have havy batterie problems. This problem apeared directly after the update.
Overheating and high battery consumtion.
I have peaks with 1600 mA /h
Additionaly i cannot open some apps, like Reddit,and opera browser.
Normal batterie consumtion without doing anything is around 700 to 1000 mA/h
Without doing nothing at all, because i left the phone in my office, after 4 hours the phone/batterie was dead. I had 91% of battery.

So, since @SimmoMaz has the same issue, i guess it is a problem of the update.