FP2 cannot answer/receive calls

Hey there,
I got my FP2 for 1 month, 2 weeks and 4 days now. I am using only one SIM card slot and everything works perfectly well - apart from the fact that I cannot answer calls. I can call everybody, but once they call me and I want to answer, it beeps in the line and I get disconnected. Does anybody have an idea why that is? Are there any ways to fix this?
Thanks,
Caroline (Germany)

Hi, I have a similiar problem (not excactly the same): When I am called on my FP2, I do not see the incoming call and the caller immediately hears my mailbox message. Seconds later, I receive a text message that somebody tried to reach me.

My setup is similar: I’ve had the phone for about a month, am using only one SIM card slot and am based in Germany. My provider is O2. Everything used to work until about two or three days ago.

Is there a way to find out if this is a provider problem or a fairphone problem?

Thanks! Ricarda

1 Like

My provider is also O2. However, I do have my problem since using the FP2 and did not have it with my previous smartphone. I do see the incoming calls and once I try do answer, the line is cut. Thus, I do not receive messages about missed calls.

Ah, ok, so it’s probably a different problem … Have you tried talking with O2?

What I’ve also started noticing, maybe related: It takes about 15 seconds to place a call – when I call a contact, I hear nothing for about 15 seconds and only then do I start hearing the dial tone. Which is pretty irritating.

So I asked in the O2 shop and was told to take out the battery for a couple of minutes to reset the phones memory – that seems to have worked for the incoming calls (I can now receive them again), but it still takes long (about 9 seconds now) to place a call.

I have a similar problem and my provider is O2 too (O2 cant do?)
Since a week or so I am frequently disconnected from the network, that is I cant place and recieve calls nor SMS. Bizarre though, data services such as email, apps and browser still work. So often I don’t notice that people cant reach me via phone, which is very serious for me.
Mostly I re-connect chosing a network provider from the menue (in German: Einstellungen / Mehr…/ Mobilfunknetze / Mobilfunkbetreiber ), but today this didn’t work at all. The phone told me it had registered on the network, but still I couldn’t place a call or send an SMS!
I had to reboot, and this was successful. The bug is very disturbing. I am sure it will occur again.

This behaviour I did also observe and I am very annoyed by this.
I reported it already here in the “FeatureRequest” as it is more an improvement than a bug and here as as a more lengthy post:
https://forum.fairphone.com/t/suggestions-for-improvement-of-the-dialer-app-fp2-android-5-1-compared-to-fp1-android-4-2/14442?source_topic_id=16045

I hope the best that it is considered in one of the future updates.
And I would also support assigning it as a bug…If more people think it’s neccassary.

With your other problem, unfortunately I can’t help you out…
Cheers, Robert

I have tested it with my Fairphone 2 and I can answer calls on both SIM cards (both in the O2 Germany network [FONIC and winSIM], but not by O2 directly). I have also no problems with placing a call.

You have to swipe right to answer the call. Swiping left will reject the call. (This was my mistake in the first try.)


Maybe it has to do with the merge of the O2 and E-Plus network. The affected regions (postal code) can be reached through the winSIM FAQ:

My postal code (01468) doesn’t appear in this list yet, so I am in the old, unmerged network. Maybe the others who have this problem could look whether they are in the old, unmerged or in the new, merged network or even in a region where the technicians work now.


Maybe it has also to do with the network type: Mine has 2G only for SIM1 and H+ for SIM2 (LTE enabled and included with contract, but not available here).

Hi
Since a few weeks (i don´t receive so many calls - so I don´t know since exactly it does not work) I also can not answer calls . Its no problem with wrong handling of the swipe - I tried with callling my self at home: swipe left (reject) or up (mailbox) does work - but no swipe to the right works…
And since the last update I can not shut of the WLAN konstatly (it shut on be it self within a minute)
…