English

FP2 Bricked - Recovery Help

Hi Flogo,
OTA stands for Over the Air and refers to an update that is delivered via the internet. That aside, in the OTA you’ll find the original system, meaning the FP-stock-rom your phone came with. I would assume, that your method should have reverted the OS to the original. I wonder why it didn’t…
What you could try is to use adb sideload to flash the image. That worked for me in any case…
To do that, start into recovery mode and select “apply update via adb”, then connect your phone and use

adb sideload FP2-gms36-1.1.7-ota.zip

to flash the image to the phone…

Hope that works for you!

Moritz

Thanks. I tried adb sideload but got the same error as @Jannis:

interesting…
for me that worked…
dunno what to tell you here… :confused:

–Edit–
Just had another idea: as far as I know, even in the FP-OSOS the updated app should be installed, right? Can you try using it to install the stock-rom again?

Yes, the updater app is there, but I don’t know how to use it to reinstall the stock OS. When I opened it, it showed me one entry for the OS (“Fairphone Onion 1.0”, I believe it was. I write this from memory, I currently don’t have the phone in front of me). After a while, an error message was shown at the bottom (“error downloading config file”). I assumed that was because the updater asked for an update of the self-compiled OSOS and the server responded that it doesn’t have updates for this OS (only for the official OS). I was able to tap on the os name a couple of times to get to a “developer mode” or something like this, but the only other option I had there was to change the URL of where the app looks for the ota. The default (“http://ota.fairphone.com”, I think) looked fine to me, so I didn’t change it. I didn’t see any other buttons or interactive elements in the app.

In the updater, press the button for the advanced options on the bottom. From there you should be able to select the newest version and install it. I dunno what will happen next, as everything works for me right now and I don’t want to reset at the moment…

Unfortunately, I don’t see any button there. The only clickable thing on the screen is the OS name (I tried clicking everywhere in case the button is just invisible for some reason). Must be a different version of the updater. Strange.

Hello,

I would like to try the FairphoneOpenSourceOS following the code.fairphone.com instructions. But I would like to know if there is a way to recover the Fairphone2 as it was by default from factory?

Thanks

Yes, there is. You can simply download the official stock-rom and flash it back. Plus, it should be possible to use the built-in updater to download and install the original system…
Regards,

Moritz

1 Like

I changed “Firephone2” in the title to “Fairphone 2”.

1 Like

Firephone did have a nice ring to it though… :slight_smile:

From where is the official primary ROM supposed to be downloaded? I managed to save one of the Updater ZIPs on my laptop before flashing my own build, but it’d be great to know.

BTW, in my own-built FairphoneOS-OS, the Updater keep saying something like “Unable to download config file” (in Spanish) and doesn’t show me the “Advanced options” to reinstall any official ROM. Do you know if this is something exclusive from my build or a general issue?

EDIT: Quoting @Flogo for additional info to new readers

I can confirm this behaviour, I get the same message (in German though :wink: )

1 Like

I might have an issue now as well after I experienced difficulties getting the SD card to work properly. Now I would like to start from scratch and reinstall factory Android FP (or actually any other image you can recommend).

My phone is not bricked (yet) which is the reason that I’m asking here before doing anything stupid.
What doesn’t work:

  • download FP2-GMS36 1.1.7 via updater (Error downloading FP2-gms36 FP)
  • writing to any storage with Amaze (no permissions for sdcard0 or sdcard1)

I’d like to fix these issues obviously, maybe they are connected, who knows.

I get access with adb and can write onto the sdcards with that. What also works is mounting the sdcard1 via USB.

What do you recommend? Install FP2-GSM or directly installing a different image?

Thanks for the help!

I don’t think there are any official other images out there yet. All what is “official” out there is the stock google rom.

Updater-file:
http://storage.googleapis.com/fairphone-updates/FP2-gms36-1.1.7-ota.zip

Images-file:
http://storage.googleapis.com/fairphone-updates/FP2-gms36-1.1.7-img.zip

I would use the 2nd one with the images and fastboot flash. And I would replace the recovery while doing so. You don’t need Amaze if you have adb or fastboot or a working recovery.

I haven’t fully understood your SD card issue yet, so I can’t really help. Just providing links to files. I always thought SD card handling would get better in Android 5 not worse.

1 Like

Thanks a lot for that information.
What is the difference between the two files?
What do you recommend replacing the recovery with? Is there a better one? Should I flash first and then change recovery or the other way round?
Do I flash those files simply by putting them onto the SD card, restarting the phone to bootloader and flashing them there? Or should I do it from recovery?
I have exactly the same problem as @barney now

There is a twrp port here in the forum. But I would try to learn all this step by step. How to do a backup, how to reinstall stuff … so that you have all this when you need it. The best is you just try it and write a howto while doing so :slightly_smiling:

I don’t own a FP2 so I don’t want to give you wrong information. But if you read the wiki about building your own non-google images, you can also see how these images get flashed. It’s the same with other images.

Normally you put your phone into the bootloader/fastboot mode and unzip the images (FP2-gms36-1.1.7-img.zip, the twrp image) on your computer and flash your phone from there.

I wonder why I am so afraid of flashing again. It’s just been a while since I flashed by old phone.
Managed to install the original ROM with:

  • reboot to recovery
  • reboot to bootloader
  • download FP2-gms36-1.1.7-img.zip
  • unzip FP2*img.zip
  • fastboot flash boot boot.img
  • fastboot flash system system.img
  • … do for all 5 images
  • fastboot reboot

Good, now you can try to replace your recovery with twrp! But don’t blame me if something goes wrong :slight_smile:

Not sure if I should…

I’d start with fastboot flash -w system system.img